Samsung C410 Laser Printer Cleaning (Solved)

Hi All! This is a (sort of) follow up to my last, aborted, post!

My Samsung printer has suddenly decided to play up - it’s now producing multi-colour vertical streaks on the printed page. I’ve researched the net and found many ‘reasons why’ videos and have given the printer as thorough a clean (inside and out) as I can - including emptying the waste tank - without (yet) dismantling any internal components . I refilled all the toners about 3 months ago and it has run fine since, so I’m reasonably sure they aren’t the issue.

After cleaning the printer and to test it, I’ve run a blank page document through it and there’s no streaking. I’ve then run a simple b&w text document through and it streaks in colour and lastly run a multi-colour document through and again, it streaks. It seems that when the printer is asked (by the computer) to actually print something, it is dragging in unwanted toner from somewhere.

I conclude that it is either a) there is residual toner powder within the machine that needs removing, or b) the printer software is somehow corrupted and is asking for colour when none is required?

My suspicion is b) because if I print an info page directly from the printer’s control buttons it prints out fine with no streaking…! Weird? I’d prefer to run through any software options first before stripping the printer so any advice from your good selves would be welcome!

So - how do I remove, then reinstall all of the CUPS software and print manager software on my machine?

Then - Samsung have an ‘Easy Printer Manager’ available (but not in Linux - no surprise) but they do a MAC version. I’ve downloaded it’s zip file as standby and wonder if there’s away to run it on my machine (Linux Mint 17)? This would be very useful as you can do printer component re-sets with it which aren’t available otherwise.

Thanks in advance and a very merry Christmas to one and all!


How did you install the drivers for your printer in the first place ?

from here:

What’s the output from:

dpkg -l | grep slud


dpkg -l | grep -i samsung

Mark, I followed your instructions from the post on this forum dated 29th April 2016 (Samsung Xpress C410W) - I tried to copy/paste the link but it wouldn’t take, for some reason?

Info as requested -

dpkg -l | grep slud
richard@richard-Ei-306 ~ $ (no info returned)

dpkg -l | grep -i samsung
ii printer-driver-splix 2.0.0+svn315-2fakesync1 i386 Driver for Samsung and Xerox SPL2 and SPLc laser printers
richard@richard-Ei-306 ~ $

Hope this helps?


Okay let’s try uninstalling / reinstalling the same software first … if that doesn’t work we can try another way.

First run:


right-click any samsung printer and select “Delete” … then close the “Printers” window

Back in the terminal and run these commands in sequence:
Run these commands in sequence:

mkdir ~/samsung-unified-linux-driver


cd ~/samsung-unified-linux-driver




tar xvf ULD_V1.00.21.tar.gz


cd ~/samsung-unified-linux-driver/uld


sudo ./

hit “Enter” when prompted.

Once it’s finished uninstalling, run:

cd ~/samsung-unified-linux-driver/uld


sudo ./

hit “Enter” when prompted.

When you see “–More–” hit the spacebar until you get to:-
**** Do you agree ? [y/n] :
type “y” … and hit enter.

type “Y” again at the “configure firewall” prompt … and hit enter.

When finished, see if your printer is detected if you switch it off/on again.

If it doesn’t configure automatically … add the printer in the normal way, and try one of these drivers


Thanks Mark - I’ve run the commands exactly and everything has re-installed ok with the printer being found automatically. Running test sheets through has produced exactly the same result as before -

Printing from the computer gives - Blank document - no smearing, B&W text document - smearing, Colour document - smearing

Printing directly from the printer (B&W text) gives - no smearing… ???

Now I’m stumped! Logically, if there was rogue toner floating about in the printer, then it would pick up on any sheet passed through, but it doesn’t, only when there is a call for text.

Perhaps I should bite the bullet and do a complete strip and clean, unless you could suggest anything else to try?

Thanks again for the help.


No, if its printing properly directly from the printer it’s probably OK and sounds like a driver issue.

I’ll try to type up different instructions either later tonight or tomorrow.

That would be great, thank you! No rush … :wink:

Hi Mark - You can hold off on the new instructions as I think (?) I’ve sorted the problem… I decided to go ahead and give the printer a thorough clean and service anyway as it couldn’t make things worse and it seems to have done the trick.

Removing and dismantling the Imaging Drum unit was the key - a bit fiddly and you have to be careful but there are several ‘how-to’ videos available for anyone who wants to try it. (Just ‘Google’ your printer model number and ‘cleaning’ for full instructions)

I was amazed at how much waste toner there was in the receptacle, given how little printing has actually been done with this machine. The manufacturers must be laughing all the way to the bank. ::slight_smile: The waste had built up so much that the drum was touching it (on the back-side, so to speak) and must have been picking up the waste while still hot from the laser, hence the streaking. Anyway, all test prints have come up clean and correct so I’ve marked this as solved but will monitor printing and come back again if necessary.

I’ll start a new thread regarding the ‘Samsung Easy Printer Manager’ as this is a separate issue anyway.

Thanks again for the help - invaluable as always! :wink: