Samsung ML-331x Series & Peppermint 2 Acer One ZG5 rastertosamsungspl

Have just installed Peppermint 2 and have tried to get it to print on a Samsung ML-3310.

It will not print saying it is missing rastertosamsungspl i have found the file on my netbook but am “lost” as what to do next

Can you explain what you did to install any driver for the samsung printer ?


tried to plug and play - driver not there - went to samsung got zip file for drivers and then directed the printer “installer” to where the dll? file was

then it did not run saying missing the r… “file” looked on net seems same file needed by Dell Printers - tried to follow the instructions from that “blog” but could not get it to work

as i said before am a novice

dll … did you get the Windows drivers ? … .dll’s are Windows files.

Can you answer4 that question whilst I type up instructions.

Oh, and post a link to the instructions you followed in caase we need to undo something first.

went to samsung got zip file for drivers and then directed the printer "installer" to where the dll? file was
Looks like you have downloaded the windows drivers

You might want to install the Samsung drivers:
Select the Linux 3.00.82 Unified Driver
Extract the contents to your home folder then:

sudo -s

Proced with the installation

Sorry Mark, not intentional. Should have got a warning that you posted :o

Hold on … there’s a better way than that.

I’m about to post instructions to add a repository which will mean you always have the latest drivers (ie. they will be automagically kept up to date by the update manager) … which are 4.00.35 not 3.00.82 :o

But I still need to know if anything needs undoing first … Samsung are VERY specific about NOT installing drivers without removing any old one FIRST


they were what i downloaded - but do not understand the sudo etc to be able to install

have downloaded again and put in home

is the text for terminal 2 lines ?

ok will await next post

OK, lets install the Samsung Unified Printer Driver …

This needs a software source and gpg key to be added to the system, so open a terminal (Ctrl+Alt+T) and run:

sudo gedit /etc/apt/sources.list

When gedit opens a file with a ton of stuff in it … scroll to the bottom, and add 2 new lines that read:

## Samsung Unified Linux Driver repository added by 16fairfield
deb Captcha debian extra

SAVE the file, and close gedit.

Back in the terminal run:

wget -O - | sudo apt-key add -


sudo apt-get update


sudo apt-get install samsungmfp-driver

Now try your printer … and please let me know if it works.

SeZo’s method would have worked perfectly … this method will also keep your driver up to date … but really, either method is fine :slight_smile:

This method is also probably easier to back out of :slight_smile:

Sorry SeZo … I’d already typed it up (and tested it on my AA1), and felt it a waste not to post it :wink:

It’s all covered in a HUGE thread here:

No problem, I had that instructions too but I am always a bit weary of advocating the use of a third party repository.
Thought the direct download from Samsung would be more secure.


Have followed the repository route

the printer icon went grey - printer recognised - but test page prints out over 10 plus pages 1 line each page and wing dings

rebooted - uninstalled -plugged and played - loaded drivers grey icon - same print as before - same if try to print a doc from file


You are of course right, third party repos can be a risk … and if it wasn’t that it seems to be a widely accepted and well known way of installing them, and used by many, I’d probably not have mentioned it :wink:

Prior to uninstalling and trying SeZo’s method … lets try this first:

sudo apt-get remove samsungmfp-driver-4.00.35


sudo apt-get install samsungmfp-driver-3.00.90

and see if they work.

If not, we’ll uninstall everything, then try SeZo’s suggested method :slight_smile:

sorry to report no change still pages of one line characters

will ask before doing anything in future!

OK, lets remove everything that was installed from that repo:

sudo apt-get remove --purge samsungmfp-driver samsungmfp-driver-3.00.90 samsungmfp-common samsungmfp-data samsungmfp-network libstdc++5


sudo apt-get autoremove


sudo gedit /etc/apt/sources.list

when gedit opens … remove the 2 lines you added at the bottom … SAVE the file, and exit gedit.

Back in the terminal run:

sudo apt-get update

OK, that’s everything gone.

Now for the drivers directly from Samsung, as SeZo suggested …

Still in the terminal, run:

cd ~




tar -xvf UnifiedLinuxDriver_0.99.tar.gz


cd ~/cdroot


sudo ./autorun

and follow the onscreen installer.

When it asks … be sure to let it add your username to the lp group

working - you are a star !! :slight_smile:

Thanks must go to SeZo … his were the correct instructions … mine turned out to be a wild goose chase :wink:

You can now delete the cdroot directory, and the UnifiedLinuxDriver_0.99.tar.gz archive, from your Home directory if you wish.