Sandisk Sansa Clip not mounted in Linux Mint (SOLVED)


I’m just getting used to using Linux Mint 16, via a USB stick I created to boot up with. So far it’s great, works with everything - printer, USB sticks, SD cards etc. But it won’t accept the new Sandisk Sansa Clip MP3 player. The MP3 player shows up, but a warning sign says Unable to Mount, so I can’t access it/add music. It works fine in Windows XP, but I aim to go totally over to Linux, so need to ensure that I can utilise the Sandisk player.

Is anyone able to advice please? Is Linux totally incompatible with this MP3 player, or is it just some Linux distros, such as Mint which I’m using?


ls /dev | grep sd

then plug it in.

ls /dev | grep sd

you’ll see one or more new disk devices;

run tune2fs on each on the device pointers with the -l option;

tune2fs -l /dev/sd[a-z?][0-9?]

paste the output here;

this will show the patition type and the default mount options.

with this you can try to mount manually, and or debug what happens when you mount manually.

I think this is a setting on the Clip itself

Try changing the player setting to MTP mode only
(watch the video below)

If it still doesn’t work, make sure you have mtpfs installed:

sudo apt-get install mtpfs

Many thanks guys.
Mark - changed the setting as shown on video and the MP3 player is now recognised.



You’re most welcome :slight_smile:

Can you please mark the topic as (SOLVED)

You can do this by editing the FIRST posting in this topic and changing:-

Subject: Sandisk Sansa Clip not mounted in Linux Mint (SOLVED)

Thanks in advance :slight_smile: