Scanning issue (SOLVED)

Hi Guys,
I am running the latest version of Ubuntu and have a HP Deskjet 3634, after several attempts I have now got the printer connected wirelessly and can print. I have X sane installed and it detects two HP scanners, however the first selection causes X sane to stop working, the second takes me to the application but when I click the scan button the scanner bed moves but I then get the error message Failed to start scanner invalid argument. Crazy thing is, is that if I click the preview button, it shows the document I wish to scan. How do I resolve this issue.
Many thanks

I would recommend installing the HP Linux Imaging & Printing system (HPLIP) from here: HP Developers Portal | Version: 3.23.12.
I would be tempted then to remove all the listed printers from your computer (via the settings menu) and add your printer via HPLIP so that you can be sure about the installation.

Secondly: Is there a particular reason for using Xsane? “Simple Scan” in the Graphics menu does the job very well unless you have some very special requirements, and is very straightforward to use.


Hi Keith,

Thanks for the quick reply.
I have the HPLIP installed, as for removing all the printers, it took move over an hour to get the printer recognised and printing, so loathed to go through all that again. I installed X sane as I could not find simple scan in the Ubuntu software list.

Simple Scan is a standard part of Ubuntu so it will be there somewhere.
If you start a terminal session and enter the following command:


it should start immediately.

By the way; are you using the Unity Desktop or Classic View. The latter is easier to use.


Hi Keith,
Typed in simple scanner into the terminal and it starts Document scanner, so that must be the new name. Hey presto, it scans. I cannot thank you enough for your help. Have a great day.

Excellent news!

Please edit the first post on this topic as [SOLVED], to help other readers.