Setting up an E3131dongle (Huawei) on Ubuntu 12.04

I am trying to set up the Huawei dongle (E3131) on Ubuntu 12.04
when I insert the dongle in the pc after inputting the pin do pop up appears.
the autorun doesn’t work.

its operating systems are:
Windows XP (SP1/SP2/SP3 solo 32bit), Vista (32bit/64bit), 7 (32bit/64bit), 8 (Modalità Desktop) MAC OSX 10.5.x, 10.6.x, 10.7.x, 10.8.x

How can install it?

Thanks for your support.

With the dongle plugged in, open a terminal and send the output from running this command:


Now unplug the dongle … wait 10 seconds … then replug the dongle.
Now send the output from:

dmesg | tail -n 30

Thank you Mark

now it works.


Weird … none of the commands I gave you would have made it work … they were just about gathering some info on the dongle and what was happening when it was plugged in ???

Maybe it just needed replugging :o

I use a Huawei 3231 quite often and a simple unplug and replug does the job.

Dont know why but it works.


That’s that mystery solved then … cheers Jocklad :slight_smile:

I’m struggling with the same modem, could you please give me some instructions how to make it work, thanks.