Sharing files and folders via the LAN (Closed)

I have installed peppermint 6 32 bit.

I need to share files and folders via my LAN but found there was no option to set up sharing.

I have installed SAMBA but still can not see any options to set up sharing of files/folders.

I have installed SAMBA and SAMBA Server Configuration utility. But still unable to share the folders.

Here is the readout from when I checked if SAMBA was running:

usertwo@usertwo-R59P-R60P-R61P ~ $ ps ax | grep smbd
593 ? Ss 0:00 smbd -F
822 ? S 0:00 smbd -F
3049 pts/1 S+ 0:00 grep --colour=auto smbd
usertwo@usertwo-R59P-R60P-R61P ~ $

What do I need to install or if SAMBA is not running how do we make it start at boot?

Hi Tramlink

Have you installed the peppermint-networking-pack that should give you all the files you need for samba and other file sharing protocols, if not you’ll find it in the repos or

sudo apt-get install peppermint-networking-pack

Good luck

Graeme

Install either the peppermint-networking-pack or system-config-samba

then configure the folders you want to share via
menu > System Tools > Samba

In there, click
Preferences > Server settings
and make sure
Workgroup:

Click “OK

then click the “Add a samba share” button (+)

On the “Basic” tab, add a directory you want to share, eg.
Directory: /home//Public
Share name:
Description:

and tick both “Writeable” and “Visible” boxes.

on the “Access” tab, select “Allow access to anyone

Click “OK


After this you may need to restart the PC … and any other PC’s on the network.

HI all have done this but still unable to share the folders/files in file manager and my ther Linux computers can not see the files folders.

What’s the IP of the Peppermint box ?

You can get this by right-clicking the networkmanager icon (by the clock) and selecting “Connection Information”

you’e then looking for

IPv4
IP Address: xxx.xxx.xxx.xxx

Can you also list the
Default Route: xxx.xxx.xxx.xxx
and
Primary DNS: xxx.xxx.xxx.xxx
and if present
Secondary DNS: xxx.xxx.xxx.xxx
from the same place

IP - 192.168.11.8

Default Route - 192.168.11.1

Primary DNS - 192.168.11.1

On the other Linux PC

Open the file manager, and in its address bar enter:
smb://192.168.11.8
and hit enter.

do you see the shares ?

Yes I can see the shares.

OK the problem appears to be with name resolution.

Static IP’s and bookmarking (and/or a hosts file entry) would be a solution, but before we go down that route let’s try adding “netbios name” to smb.conf

Can you (from the Peppermint box) post the output from:

echo $HOSTNAME

and the contents of both

gedit /etc/samba/smb.conf

and

gedit /etc/nsswitch.conf

usertwo@usertwo-R59P-R60P-R61P ~ $ echo $HOSTNAME
usertwo-R59P-R60P-R61P
usertwo@usertwo-R59P-R60P-R61P ~ $

Sample configuration file for the Samba suite for Debian GNU/Linux.

This is the main Samba configuration file. You should read the

smb.conf(5) manual page in order to understand the options listed

here. Samba has a huge number of configurable options most of which

are not shown in this example

Some options that are often worth tuning have been included as

commented-out examples in this file.

- When such options are commented with “;”, the proposed setting

differs from the default Samba behaviour

- When commented with “#”, the proposed setting is the default

behaviour of Samba but the option is considered important

enough to be mentioned here

NOTE: Whenever you modify this file you should run the command

“testparm” to check that you have not made any basic syntactic

errors.

#======================= Global Settings =======================

[global]

Browsing/Identification

Change this to the workgroup/NT-domain name your Samba server will part of

workgroup = 000d0b6da3c4

server string is the equivalent of the NT Description field

server string = %h server (Samba, Ubuntu)

Windows Internet Name Serving Support Section:

WINS Support - Tells the NMBD component of Samba to enable its WINS Server

wins support = no

WINS Server - Tells the NMBD components of Samba to be a WINS Client

Note: Samba can be either a WINS Server, or a WINS Client, but NOT both

; wins server = w.x.y.z

This will prevent nmbd to search for NetBIOS names through DNS.

dns proxy = no

Networking

The specific set of interfaces / networks to bind to

This can be either the interface name or an IP address/netmask;

interface names are normally preferred

; interfaces = 127.0.0.0/8 eth0

Only bind to the named interfaces and/or networks; you must use the

‘interfaces’ option above to use this.

It is recommended that you enable this feature if your Samba machine is

not protected by a firewall or is a firewall itself. However, this

option cannot handle dynamic or non-broadcast interfaces correctly.

; bind interfaces only = yes

Debugging/Accounting

This tells Samba to use a separate log file for each machine

that connects

log file = /var/log/samba/log.%m

Cap the size of the individual log files (in KiB).

max log size = 1000

If you want Samba to only log through syslog then set the following

parameter to ‘yes’.

syslog only = no

We want Samba to log a minimum amount of information to syslog. Everything

should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log

through syslog you should set the following parameter to something higher.

syslog = 0

Do something sensible when Samba crashes: mail the admin a backtrace

panic action = /usr/share/samba/panic-action %d

####### Authentication #######

Server role. Defines in which mode Samba will operate. Possible

values are “standalone server”, “member server”, "classic primary

domain controller", “classic backup domain controller”, "active

directory domain controller".

Most people will want “standalone sever” or “member server”.

Running as “active directory domain controller” will require first

running “samba-tool domain provision” to wipe databases and create a

new domain.

server role = standalone server

If you are using encrypted passwords, Samba will need to know what

password database type you are using.

; passdb backend = tdbsam

obey pam restrictions = yes

This boolean parameter controls whether Samba attempts to sync the Unix

password with the SMB password when the encrypted SMB password in the

passdb is changed.

unix password sync = yes

For Unix password sync to work on a Debian GNU/Linux system, the following

parameters must be set (thanks to Ian Kahan <[email protected] for

sending the correct chat script for the passwd program in Debian Sarge).

passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

This boolean controls whether PAM will be used for password changes

when requested by an SMB client instead of the program listed in

‘passwd program’. The default is ‘no’.

pam password change = yes

This option controls how unsuccessful authentication attempts are mapped

to anonymous connections

map to guest = bad user

########## Domains ###########

The following settings only takes effect if 'server role = primary

classic domain controller’, ‘server role = backup domain controller’

or ‘domain logons’ is set

It specifies the location of the user’s

profile directory from the client point of view) The following

required a [profiles] share to be setup on the samba server (see

below)

; logon path = \%N\profiles%U

Another common choice is storing the profile in the user’s home directory

(this is Samba’s default)

logon path = \%N%U\profile

The following setting only takes effect if ‘domain logons’ is set

It specifies the location of a user’s home directory (from the client

point of view)

; logon drive = H:

logon home = \%N%U

The following setting only takes effect if ‘domain logons’ is set

It specifies the script to run during logon. The script must be stored

in the [netlogon] share

NOTE: Must be store in ‘DOS’ file format convention

; logon script = logon.cmd

This allows Unix users to be created on the domain controller via the SAMR

RPC pipe. The example command creates a user account with a disabled Unix

password; please adapt to your needs

; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos “” %u

This allows machine accounts to be created on the domain controller via the

SAMR RPC pipe.

The following assumes a “machines” group exists on the system

; add machine script = /usr/sbin/useradd -g machines -c “%u machine account” -d /var/lib/samba -s /bin/false %u

This allows Unix groups to be created on the domain controller via the SAMR

RPC pipe.

; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

Using the following line enables you to customise your configuration

on a per machine basis. The %m gets replaced with the netbios name

of the machine that is connecting

; include = /home/samba/etc/smb.conf.%m

Some defaults for winbind (make sure you’re not using the ranges

for something else.)

; idmap uid = 10000-20000
; idmap gid = 10000-20000
; template shell = /bin/bash

Setup usershare options to enable non-root users to share folders

with the net usershare command.

Maximum number of usershare. 0 (default) means that usershare is disabled.

; usershare max shares = 100

Allow users who’ve been granted usershare privileges to create

public shares, not just authenticated ones

usershare allow guests = yes
username map = /etc/samba/smbusers
security = user
encrypt passwords = no

; guest ok = no
; guest account = nobody

#======================= Share Definitions =======================

Un-comment the following (and tweak the other settings below to suit)

to enable the default home directory shares. This will share each

user’s home directory as \server\username

;[homes]
; comment = Home Directories
; browseable = no

By default, the home directories are exported read-only. Change the

next parameter to ‘no’ if you want to be able to write to them.

; read only = yes

File creation mask is set to 0700 for security reasons. If you want to

create files with group=rw permissions, set next parameter to 0775.

; create mask = 0700

Directory creation mask is set to 0700 for security reasons. If you want to

create dirs. with group=rw permissions, set next parameter to 0775.

; directory mask = 0700

By default, \server\username shares can be connected to by anyone

with access to the samba server.

Un-comment the following parameter to make sure that only “username”

can connect to \server\username

This might need tweaking when using external authentication schemes

; valid users = %S

Un-comment the following and create the netlogon directory for Domain Logons

(you need to configure Samba to act as a domain controller too.)

;[netlogon]
; comment = Network Logon Service
; path = /home/samba/netlogon
; guest ok = yes
; read only = yes

Un-comment the following and create the profiles directory to store

users profiles (see the “logon path” option above)

(you need to configure Samba to act as a domain controller too.)

The path below should be writable by all users so that their

profile directory may be created the first time they log on

;[profiles]
; comment = Users profiles
; path = /home/samba/profiles
; guest ok = no
; browseable = no
; create mask = 0600
; directory mask = 0700

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
; guest ok = no
; read only = yes
create mask = 0700

Windows clients look for this share name as a source of downloadable

printer drivers

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
; browseable = yes
; read only = yes
; guest ok = no

Uncomment to allow remote administration of Windows print drivers.

You may need to replace ‘lpadmin’ with the name of the group your

admin users are members of.

Please note that you also need to set appropriate Unix permissions

to the drivers directory for these users to have write rights in it

; write list = root, @lpadmin

[Documents]
path = /home/usertwo/Documents
writeable = yes
; browseable = yes
guest ok = yes
comment = Documents folder

[Downloads]
comment = Downloads folder
path = /home/usertwo/Downloads
writeable = yes
; browseable = yes
guest ok = yes

[Public]
comment = Public files
path = /home/usertwo/Public
writeable = yes
; browseable = yes
guest ok = yes

/etc/nsswitch.conf

Example configuration of GNU Name Service Switch functionality.

If you have the glibc-doc-reference' and info’ packages installed, try:

`info libc “Name Service Switch”’ for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

Can you post the output from:

dpkg -l | grep mdns

and

dpkg -l | grep avahi

and

ps aux | grep [a]vahi

and is Peppermint able to see shares from other PC’s (even though the others can’t see Peppermint shares ?

usertwo@usertwo-R59P-R60P-R61P ~ $ dpkg -l | grep mdns
ii libjmdns-java 3.4.1-2 all Java implementation of multi-cast DNS (Apple Rendezvous)
usertwo@usertwo-R59P-R60P-R61P ~ $

usertwo@usertwo-R59P-R60P-R61P ~ $ dpkg -l | grep avahi
ii libavahi-client3:i386 0.6.31-4ubuntu1 i386 Avahi client library
ii libavahi-common-data:i386 0.6.31-4ubuntu1 i386 Avahi common data files
ii libavahi-common3:i386 0.6.31-4ubuntu1 i386 Avahi common library
ii libavahi-glib1:i386 0.6.31-4ubuntu1 i386 Avahi GLib integration library
usertwo@usertwo-R59P-R60P-R61P ~ $

usertwo@usertwo-R59P-R60P-R61P ~ $ ps aux | grep [a]vahi
usertwo@usertwo-R59P-R60P-R61P ~ $

Yes peppermint laptop can see and access other computers on the network. In network there is an entry “smb-server-” which I assume is this laptop if I click on it it opens 000D0B6DA3C4 which is the work group name there is nothing shown if I click through.

Run:

sudo apt-get install libnss-mdns avahi-daemon libavahi-core7

then open smb.conf for editing:

sudo gedit /etc/samba/smb.conf

find the section that reads:-

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = 000d0b6da3c4

and change it to

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = 000d0b6da3c4
   netbios name = samsung

SAVE the file and exit gedit.

Now open nsswitch.conf for editing

sudo gedit /etc/nsswitch.conf

find the line that reads

hosts:          files dns

and change it to

hosts:          files myhostname mdns4_minimal [NOTFOUND=return] dns

SAVE the file and exit gedit.

REBOOT both the Peppermint PC and the other one … now see if the other PC can see the Peppermint shares ?

No the other PC can not see the pepermint system and I also tried my wifes win 7 laptop and that can not see it ether.

I now have a SMMSUNG in the network and I can not access this because it wants a password that I do not have.

Why are there so many issues with the networking I did not have these issues with mint?

OK the easiest way round this would be to give the Peppermint box a static IP … something like
192.168.1.200

then just create bookmarks on the other PC’s to
smb://192.168.1.200

If you can see “SAMSUNG” from the other PC’s but it asks for a password, I’d have to guess the peppermint PC is in a different workgroup that the other PC’s

OK thanks for the help…I will think about how to proceed.

I know your part of the peppermint team so I wonder why networking is not installed as a standard option?

Is it something to think about for version 7?

Thanks again.

Well weirdly it’s always worked for me, but you appear to have some stuff missing in your installation.
(that said I’m also not convinced this is a Peppermint problem … Peppermint is having no problems seeing the other PC’s so its network stack is obviously working, I think it’s more a network configuration problem)

If you need help with setting a static IP, and using bookmarks from the other PC’s … let me know.

I am OK with setting up the static I.P and the bookmarks.

I went back through my records and found that I had similar issues when I tried peppermint 3 on an old laptop.

I checked all the settings on the router and can not find any issues.

My mint 64bit computer my wife’s win7 Laptop and my tablet and network printer can all see each other and yes the peppermint laptop can see them but they do not see it.

The work-group name is set by the router I may try a clean installation and give it another go from a blank sheet.

With the heavier Linux distributions networking is already installed as standard and a few clicks and off you go.

I will have a think about what to do. Thanks for your assistance.

The work-group name is set by the router

The router does NOT set the workgroup … I think you might be confusing “workgroup” with “SSID”
(the router doesn’t have a workgroup)

Currently you’ve set the Peppermint workgroup to 000d0b6da3c4 which I’m guessing is the routers SSID (station identifier) … I’m also going to guess both the Windows and Ubuntu boxes are using the default workgroup WORKGROUP

If this is the case, you’d need to either

a) set the workgroups of the Windows and Ubuntu boxes to 000d0b6da3c4
or
b) Set the Peppermint box workgroup to WORKGROUP (or whatever the actual workgroup of the Windows and Ubuntu boxes are)

I know this isn’t a Peppermint problem as I’ve just tested it with a Windows box and it was able to see the Peppermint shares without issue.

All my computers/tablet are part of workgroup 000d0b6da3c4 and that is the workgroup set on the peppermint box.

As a test I installed mint 17.1 32 bit alongside peppermint and after I changed the workgroup to 000d0b6da3c4 everything is working fine in mint.

I will try a fresh install of peppermint and give it another go and if no joy I can stick with mint.

Once again thanks for your help.