software repository

I’ve been trying to replace all my lovely old gnome-panel-applets with the new indicator-applets, with great results - unfortunately, one of the software repositories I recently added (one for the ‘pastie’ indicator) has messed everything up.
I added it with

sudo add-apt-repository ppa:hel-sheep/pastie && sudo apt-get update

and I get the error:
E: Type ‘ain’ is not known on line 3 in source list /etc/apt/sources.list.d/hel-sheep-pastie-natty.list
E: The list of sources could not be read.

And when I open synaptic to remove it from my software sources I get the error and have to close synaptic! (this is added on the end):

Go to the repository dialogue to correct the problem.
E: _cache->open() failed, please report.

That PPA only contains packages for Lucid and Maverick… NOT Natty:

Try this…

Make sure Synaptic is closed

Move /etc/apt/sources.list.d/hel-sheep-pastie-natty.list to your home directory:

sudo mv /etc/apt/sources.list.d/hel-sheep-pastie-natty.list ~/hel-sheep-pastie-natty.list

This should remove the PPA from the sources.

Now start Synaptic

If you want a clipboard manager, why not try the parcellite package… as long as you’ve enabled the Universe repo, it should be available in Synaptic.

or with:

sudo apt-get install parcellite

Parcellite automatically adds an icon to the top panel… at least it does in Maverick.

yes, thanks, that worked perfectly :slight_smile:

On a similar note, I recently downloaded pastie and got the error message:

WARNING: Failed to parse default value `' for schema (/schemas/apps/devhelp/state/main/contents/books_disabled)

What does this mean, and are there any problematic consequences?
Thanks in advance

First I must say I’m not a programmer, so can’t be 100% sure…

But I’m guessing some setting or other disagreed with gconf and never got added in gconf-editor at schemas>apps>devhelp>state>main>contents>books_disabled

This is likely to be an application specific entry (as I don’t have an entry there in Maverick), so as long as pastie is working I doubt if it will cause problems with anything else.

Though personally I’d uninstall pastie and use parcellite… just in case.

on parcellite, I’m a bit confused - if I click on the indicator I get a list of copied items but I can’t access them in any way? How are you meant to paste from old clipboard data?

a. Someone missed a “'” in their config file (bug!)
b. Indicators are currently “as buggy as hell” … if you see a problem, best bet is report it back to Ubuntu …
(or even better, avoid all but the built-in indicators …)

ok, but I can’t find the path at all - I can’t even find the schemas folder :frowning: a search finds me three ‘schema’ folders, none of which contain an apps folder

That’s not really what I meant…

Hit Alt+F2… enter gconf-editor… click the Run button.

Now (in left-hand column) navigate to schemas>apps>devhelp>state>main>contents>books_disabled

Which probably doesn’t exist, because it was never set up by the installer.

BE CAREFUL what you mess with in gconf-editor :wink:

OK, lets try this another way… where did you get pastie, and what did you do to install it, and into which distro/version ?

the file exists but it can’t be editted.

I got pastie as instructed here: Pastie - handy clipboard manager indicator applet - OMG! Ubuntu
Not sure why it worked the second time and not the first.
I’m on ubuntu 11.04
And I’ve tried on clipit (parcellite) and diodon, they do the same thing ??? am I doing it wrong? You’d think that if you click the preview of the text, in the main menu under the applet icon, it would paste that bit of text?

Just to be clear - when you click something in the clipboard panel applet list… it isn’t automatically pasted anywhere, how would it know where you wanted it pasted ?
all the clipboard manager does is let you select any of the last 25 (by default) items that have been copied to the clipboard… you still have to manually paste it yourself.

ie. select what you want in the list from the panel applet… now right-click in a document (for text) and select paste.
or for complete files… select from list > paste in a folder etc.

Firstly… there IS now a version of pastie in the PPA, and it works in 11.04.

OK, all 3 packages work properly in 11.04 on a VM for me. (parcellite, clipit, and pastie… didn’t try diodon… at least they do on the GNOME desktop (I still can’t get Unity to work properly in a VM).

First try them logged on to a GNOME (classic) desktop session rather than Unity… and see if they work in that.

If not… try this…


Uninstall them ALL of them (including config files):

sudo apt-get purge diodon


sudo apt-get purge pastie


sudo apt-get purge clipit


sudo apt-get purge parcellite

Next, remove the pastie PPA:

sudo mv /etc/apt/sources.list.d/hel-sheep-pastie-natty.list ~/hel-sheep-pastie-natty.list

Now clear the local apt package cache:

sudo apt-get clean

And remove any unecessary (left over) packages:

sudo apt-get autoremove

Hopefully that will have got rid of them all… now lets reinstall pastie…

Add the pastie PPA

sudo add-apt-repository ppa:hel-sheep/pastie

update the cache:

sudo apt-get update

Install pastie again:

sudo apt-get install pastie

and just to be 100% sure nothing got left behind that want overwritten, reinstall pastie again which should overwrite everything:

sudo apt-get install --reinstall pastie

Now anything (last 25 things by default) you copy should be available in the list when you normal (left) click the “Clipboard” icon on the top panel… just click what you want in the clipboard… then when you select “Paste”, that will be the item that is pasted.

Thanks so much - I was just using it wrong! This is a great tool now I know how to use it :slight_smile:
And thanks for the extra terminal vocab - is ‘purge’ the same as ‘complete removal’ in synaptic?

Yup :slight_smile:

see the man page (manual) for the apt-get syntax/options:

man apt-get

Or any other command for that matter… just enter “man”, a space and the command you want to find out about.


man cp


man mv


man cat