[SOLVED] Drives missing

I am trying to go (cd) to a folder in Drive3 but in Terminal, they’re not there (Drive 2 & Drive 3), what’s going on?
Screenshots included.

Something new, I just tired right-clicking on the ‘Drive3’ icon as in the first screenshot and then ‘open in terminal’ which worked.
Why does it not show up in the terminal entry as described above?

It appears that Drive1 is mounted in your home folder under media but the other drives are mounted somewhere else.
If they are auto mounted then they should be listed in your fstab:

cat /etc/fstab

Alternatively you could look with:

mount | grep Drive

I’m not sure any of the are mounted at /media

IIRC they’re mounted at /mnt … but I could be wrong.

As SeZo says … run:


to see where they are mounted.

[spoiler]pooky2483@pooky2483-ubuntu12:~$ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdb1 during installation

UUID=86fe3809-17a6-412c-be0a-250f6f29fa41 / ext4 errors=remount-ro 0 1

swap was on /dev/sda5 during installation

UUID=e56dad6b-358f-4948-b51f-4abce81f50b1 none swap sw 0 0

swap was on /dev/sdb2 during installation

UUID=03b9f227-9f5c-4abc-a50b-74ecc1590f44 none swap sw 0 0

Mounted Drives

UUID=959cb526-06f8-4d5d-bec2-a6b42f438b07 /media/Drive1 ext4 defaults 0 0

UUID=d5e1db61-b980-4624-801c-e0546b288b8f /media/Drive1 ext4 defaults 0 0

Old one

UUID=40d97c21-aec9-48ed-a089-082c41024994 /media/Drive2 ext4 defaults 0 0

New one

UUID=fece8a70-7f38-4ad2-aaf3-49a69a8fb91e /media/Drive2 ext4 defaults 0 0
UUID=1e72a175-851f-43c3-a251-241d0e3800a7 /media/Drive3 ext4 defaults 0 0

mount | grep Drive

pooky2483@pooky2483-ubuntu12:~$ mount | grep Drive
/dev/sdd1 on /media/Drive1 type ext4 (rw)
/dev/sdc1 on /media/Drive2 type ext4 (rw)
/dev/sdb1 on /media/Drive3 type ext4 (rw)

OK, so cd into the drive you want to be in (replace X with number):

cd /media/DriveX/<folder name>

That wont work (see screenshot)

What SeZo says WILL work :o

in that screenshot you entered:

cd media

(which s a “relative path” … as you were already in /home/pooky2483 it looked for a folder called “media” at that location, and as there WAS one, it entered it)

so ended up at ~/media … or put another way … /home/pooky2483/media

You should have entered:

cd /media

(which is an “absolute path”, starting at /)

and you’d have ended up at /media

Kinda pointless saying something won’'t work until you’ve tried it :wink:

I can get to media/Drive1/any/folder
But I can’t get to
media/Drive2/any/folder or media/Drive3/any/folder
See screenshot

It seems the only way I can get to Drive2 or Drive 3 is to use ‘open in terminal’ after right clicking on the drive icon on the desktop

OK… Just saw the ‘/’
why is it different when I did it the way I did before???
:o Confused

Sorry for the confusion

re-read my last response … the answer is in there :wink:

when you run:

cd media

it looks for a directory called media in the CURRENT DIRECTORY (which happened to be your Home folder at that time)

when you run:

cd /media

it starts from / … not the CURRENT DIRECTORY.

pooky2483@pooky2483-ubuntu12:~$ cd /media
pooky2483@pooky2483-ubuntu12:/media$ dir
12.04Boot Drive1 Drive2 Drive3 Drive4 Home

Just spotted something else… Drive4… I only have 12.04Boot Drive1 Drive2 Drive3
Not Drive4
Where’s that come from? can I remove it somehow?

I’m sorry, I still can’t get my head round why it only shows ‘Drive1’ when I type ‘cd media’ and when I type ‘cd /media’ it shows all of them!

make sure it’s empty, and not referenced in fstab … then yes you can:

sudo rm -r /media/Drive4

Be SURE to get that command right … you wouldn’t want to erase one of your hard drives.

A simpler (GUI) method may be to open nautilus as root:

sudo nautilus

then in the nautilus window that just opened … navigate to /media … and delete the folder in the normal way.


I'm sorry, I still can't get my head round why it only shows 'Drive1' when I type 'cd media' and when I type 'cd /media' it shows all of them!

you must have a folder called “media” in your Home folder, that contains a folder or symlink called “Drive1”
(possibly a symlink we placed there so you can open/save files on Drive1 from within libreoffice ?)

What’s the output from:

ls -l ~/media


Re Drive4, seems safe enough to delete. so, it’s ok to delete it from within Nautilus?

Only you can decide that :wink:

It’s also safe to leave it :wink:

BTW, re-read my last posting … I was adding something.

pooky2483@pooky2483-ubuntu12:~$ ls -l ~/media
total 4
drwxr-xr-x 3 pooky2483 pooky2483 4096 Dec 3 04:14 Drive1

Like I said … you have a folder in your Home folder called “media”, and it contains a folder called “Drive1”

It’s not needed there so I’m going to remove it.