[SOLVED] 'HOME directory is out of disk space', laptop refusing to boot

Hello there, I’m Debra and I’ve got myself in a bit of a mess.

My laptop was running low on disk space but I chose to ignore it until I could get myself a decent external hard drive. I was looking through an ebook online (FireFox) when the window froze. I got the warning box that told me that all my other windows would be closing too so I clicked OK. After FireFox shut down, I couldn’t open a new window. I tried and failed a couple of times so I decided to just restart the computer…

(By the way, I’m running Pardus Linux 2011.)
Normally when starting up, you have a grey rectangle in the centre of the screen onto which icons appear from left to right (to signify loading I suppose?) but that time 3 out of the 5 appeared. Then a beep and nothing until 5/10 minutes later when a box appeared with the following;

The following installation problem was detected while trying KDE: HOME directory /home/(username) is out of disk space.
KDE is unable to start.

I clicked ‘Okay’ and got another box;

Could not start ksmserver
Check your installation

If you click Okay this time you get a GUI username and password prompt, (normally, I won’t have to enter a password unless coming back from Hibernation or Sleep). After clicking [Enter], it restarts the computer and you go around in a circle again.

Hours later.
I’ve figured out how to get to a terminal (ctrl-alt-F2) and logged into the Home directory under my username. I used ‘ls’ to list what was in /home and used the ‘rm’ and ‘rmdir’ to delete some files. Then ‘sudo reboot’… but nothing had changed. I hoped that deleting a whole bunch of stuff would do it but it hasn’t and I’m sleepy now and my words are beginning to fail me.

I’d rather not have to system restore quite yet as there are files I’d like to retrieve first – I write so I have some important notes on GNote I’d hate to lose, a few word docs and my Firefox favourites. I don’t have any back ups…

Thank you in advance for any advice.

Kind regards

Can you log into a terminal, and send the output from:

sudo df -h

Are there any clues in ~/.xsession-errors

What happens if you try to start KDE with:

kwrapper4 ksmserver



Hi, thanks for the quick reply!
This is what I got:

sudo df –h

Filesystem Size Used Avail Use% Mounted on
45G 5.3G 39G 12% /
/dev/sda1 485M 23M 437M 5% /boot
4.4G 4.3G 0 100% /home
tmpfs 1003M 2.6M 1000M 1% /dev/shm


$DISPLAY is not set or cannot connect to the X server.

Kwrapper4 ksmserver

The following installation problem was detected
while trying to start KDE:
$HOME directory (/home/babs) is out of disk space.
KDE is unable to start.
ksmserver: cannot connect to X server.

It still reckons you have no space in /home

Did you remove the files you said you deleted, or did you just send them to the trash ?

Personally, I’d boot to a LiveCD/LiveUSB and move some stuff from your home directory to an external source.

You might also want to empty, both:-


Thanks, I think you’re right.

I’ve made an Ubuntu Live CD and used that to try and access my hard drive but still no luck. It’s just not showing up, as if it’s not there?.. Tried it twice but it’s just showing the CD stuff.
Can you recommend an easy Live CD distro that I can use to get to my hard drive? Preferably without having to use the terminal please.


I’m not sure which (if any) distro’s have a desktop edition with LVM support “out-of-the-box”.

We do however have a few options …

a) boot pardus to the command line as you did before, then temporarily move something like the contents of your “Music” directory from your Home directory to a directoy we create in / … as / seems to have plenty of room … then see if it boots, if it does, move stuff off to an external source.

b) plug in an external drive, bott to the pardus command line, mount the external drive, and move stuff from your Home directory to it directly.

c) Boot to the Ubuntu LiveCD, install lvm2 in the Live environment, modprobe dm-mod, scan for your volumes, then mount them.

in ALL cases you’ll have to use the command line.

Have you got an external drive ?

Links for future reference:


Hello and thank you for your replies!
I don’t have an external hard drive, just a 2Gb Usb pen.

Sorry to be difficult but could you go through your first two suggestions step by step please? And possibly how to empty the trash by command line please?



Sorry, I didn’t see the links at the end of your reply!

Following the first link, does it mean that by Step 8, I will have accessed my hard drive and the files will be sitting in a graphical window?


OK one bit at a time … let’ try to find a decent size directory we can move to your USB stick.

Boot to the pardus command line, and send the output from these 4 commands:

du -h ~/Documents


du -h ~/Downloads


du -h ~/Music


du -h ~/Pictures

OK, now plug in your USB stick, wait a couple of seconds and run:

sudo fdisk -l

work out which is your USB stick frrom the disk size … if you only have one hard drive it will probably be /dev/sdb

and post back here which partitions are contained on it …

/dev/sdb1 62 7818695 3909317 c W95 FAT32 (LBA)

does it mean that by Step 8, I will have accessed my hard drive and the files will be sitting in a graphical window?

It will … BUT command 8 is wrong for your purposes … you DON’T weant the “ro” (read-only) option during the mount.

Would you rather do it that way ?

No, I’d rather do it ‘here’ :).

Following your instructions, I’ll post back what it said. One ‘sec’!

Sorry it took so long.

du -h ~/Documents

87M /home/babs/Documents/photos
928K /home/babs/Documents/Maths/Relativity
361M /home/babs/Documents/Maths/Avid.Sibelius.v7.0.0.x86.x64.WORKiNG-ASSiGN
362M /home/babs/Documents/Maths
75M /home/babs/Documents/New Folder
562M /home/babs/Documents

du -h ~/Downloads

79M /home/babs/Downloads

du -h ~/Music

du: cannot access ‘/home/babs/Music’ : No such file or directory

(as expected because this was one of the things I ‘removed’ earlier)

du -h ~/Pictures

512M /home/babs/Pictures/Tennis
122M /home/babs/Pictures/Susan’s 21st
72M /home/babs/Pictures/New Folder/DCIM/100MSDCF
72M /home/babs/Pictures/New Folder/DCIM
168M /home/babs/Pictures/New Folder
807M /home/babs/Pictures

sudo fdisk -1

fdisk: invalid option – ‘1’

fdisk [options] change partition table
fdisk [options] -1 list partition table(s)
fdisk -s give partition size(s) in blocks

-b Sector size (512, 1024, 2048 or 4096)
-c[=) compatible mode: ‘dos’ or ‘mondos’ (default)
-h print this help text
-u[<=unit>] display units: ‘cylinders’ or ‘sectors’ (default)
-C specify the number of cylinders
-H specify the number of heads
-S specify the number of sectors per track

OK, we’ll move the ~/Downloads directory … that’s only going to free up 79MB … but hopefully it will be enough to get you booted.


I’ll need the output that I asked for from

sudo fdisk -l

that’s a lower case L at the end … not an I or a 1

So the command reads:-


but all lower case

Oooo, how embarrassing…

sudo fdisk -l

/dev/sda1 * 2048 1026047 512000 83 Linux
/dev/sda2 1026048 114270207 56622000 8e Linux LVM
/dev/sdb1 32 3913727 1956848 6 FAT16

2 secs … typing up the instructions

Have you got access to 2 PC’s or are you having to reboot to run these commands ?

No worries and yes, I have access to another computer.

First, I’ve decided to move the Pictures folder rather than Downloads … it will free up more space … don’t panic, we’ll check they copied before removing them from the hard drive :slight_smile:

OK, lets do this bit by bit … with the USB stick still inserted, run:

sudo mkdir /mnt/usbstick


sudo mount /dev/sdb1 /mnt/usbstick


cp -v ~/Pictures /mnt/usbstick

did a ton of stuff fly past in the terminal ?

if so run:

du -h /mnt/usbstick/Pictures

is this returned:-

du -h /mnt/usbstick/Pictures

512M /mnt/usbstick/Pictures/Tennis
122M /mnt/usbstick/Pictures/Susan’s 21st
72M /mnt/usbstick/Pictures/New Folder/DCIM/100MSDCF
72M /mnt/usbstick/Pictures/New Folder/DCIM
168M /mnt/usbstick/Pictures/New Folder
807M /mnt/usbstick/Pictures


Thanks :slight_smile:

A ton of stuff didn’t happen.
After the third line entered, I got

cp: omitting directory ‘/home/babs/Pictures’

I haven’t entered the fourth line yet.

Am I supposed to?

Yeh, run:

du -h /mnt/usbstick/Pictures

and see if what I said is returned.