[SOLVED] Platform Device Creation Failed

I have just tried to reboot my laptop (Kubuntu 16.04) and it failed to boot OK, I got the following warning;
I had not long ago had the same problem (less than a week) and after a quick google, found no solution, so I had to resort to re-installing the system. I don’t want to have to do that this time. I tried Boot Repair Disk but it reported it could not continue due to having a UEFI partition or something similar.


What happens if you hit Ctrl+D to continue … do you end up at a text console ?

If so, what happens if you log in in text mode, then run:

sudo service lightdm restart

I ended up reinstalling the OS.

I’ve encountered the same problem again, this time I don’t want to reinstall the OS as it seems it’s a recurring problem.

I tried what you said Mark but it failed, I entered

service lightdm restart

With & without sudo

I booted into recovery mode (root) and CTRL+D goes back to the recovery menu.
I get the warning;
failed to restart lightdm.service:Unit lightdm.service not found

The second screenshot mentions UEFI, when I tried to use my recovery disc, I was informed it couldn’t do it due to something to do with UEFI.



I have a multiboot USB with an upto date copy of boot repair and when I run it I get a warning ‘BIOS-Boot detected. You may want to retry after deactivating the [Separate /boot/efi partition:] option.
Do you want to continue?’

The problem is, I don’t know how to deactivate it!

Check your PC’s BIOS and see if there is a setting to turn off the Trusted Platform Module (TPM).

Sorted it.
I had a look at the partitions with Gparted Live and the EFI one had ‘—’ for used & free instead of an actual amount, so I reformatterd it and reset it and then rebooted and it fixed it.

The secureboot is switched on/off when legacy is used/not used, so it was off as legacy was not selected.

I now no longer get a warning similar to that of the first 2 lines in the screenshot(s)

Nice, glad you figured it out :slight_smile: