[SOLVED] Printer immediatley putting print jobs on hold/pause/pending

I was able to print earlier, 26 March was the last time I was able then for some reason I am now unable to get anything to print, even ‘Test Print’ does not work.
I’m using an Epson ET3600.
I’ve tried rebooting both printer & PC, still nothing prints.
I thought it could be to do with the size of what I’m printing, a book with over 600 pages, so I used a PDF editor and chopped it up into 100 pages and I still get the same result… nothing prints.

I also tried searching to see if anyone else had the same problem, but did not find a solution!

I’m at a loss at to figure out how to fix it!

I also try ‘release’ on jobs which are ‘held’ but I get an error;

‘Failed to release…’
‘Job#000 is not held’

I had a similar problem recently with my Samsung on Mint 18. Have you tried deleting the printer and starting again?

(Assuming CUPS is installed?)

Switch off the printer, go to Print Manager and delete the printer. Switch on the printer and see if it auto detects. Run a test print.

Naturally, check all connections are secure and (prior to the above) make a note of any special print settings you may have implemented so you can easily reinstate them afterwards. This worked for me. :wink:

I was leaving that as a last resort, yet it seems that it’s the only solution.

I’ve removed the printer (& rebooted) twice and I’m still having problems. It’s now not showing jobs in the print queue, yet they show up in CUPS.
They also don’t print immediately, even a small document. It Seems like it prints them if it wants to!!!

I’ve tried another way;
I’ve hard-wired it (USB cable) as I got nowhere wireless.

It was connected wirelessly to the network and the PC was wired to the SKY router.
I was able to print this way as up until last night I was able to print 4 PDF’s and then when sending the 5th one, it would not print anything, not even small documents from LibreOffice, yet I gould get the printer to print test pages!

This is only a temporary fix as I don’t plan on leaving the printer in the same room as my PC.

I’ve found what was wrong with the printer…
The driver was missing… Don’t ask me how it was removed!!!


Cool, glad you got it sorted pooky :slight_smile: