[SOLVED] Problems Formatting Hd

I am trying to format my 3Tb Hd but for some reason I cant format it with ‘Disk Utility’ and when I use GParted it takes 6% knocking it down from 2.7Gb to 2.5Gb and the other 3Hd I’ve got hasn’t done that?

How do I format it properly???
I’ve been trying now for the last 4 hours >:(

Unmount and delete all partitions … create a new partition table … create a new partition using the filesystem of your choice.

What are you formatting it as, and from FAT → EXT4 or what ?

Using which program to do all the work?

What are you formatting it as, and from FAT --> EXT4 or what ?

From NTFS to EXT4

Are you trying to create a single partition to span the 3tb drive?
If so you could try to create 2 partitions (one at a time) or switch to GPT.
It appears that the msdos partition table will not work with that size of drive.
See here

What’s ‘GPT’?

GUID Partition Table

You learn something every day, I didn’t realise that about the msdos partition table :slight_smile:


So I’m going to have to put it back to NTFS…

No … just use a GPT partition table.

How do I do that?

In Gparted, first make sure you’re working with the right drive

then -

Device > Create Partition Tablee

then select Advanced > GPT

Be aware, that will wipe the drive

Then create a partition and format it to whatever file system you want

How do I get rid of the bit at the front where it’s stealing it for itself as Ive done other drives and it’s not done that?



You can’t, that’s reserved space for the master file table.

Windows file systems do the same thing but it usually starts off very small and grows as needed … problem is that scatters it all over the partition.


Any particular reason you included a swap partition on that drive ?

And if it’s an external drive that may be plugged into with a Windows PC, why EXT4 (as Windows can’t read/write to EXT) ?

But it actually shows up as used space on the usable part of the Hd

Any particular reason you included a swap partition on that drive ?

Doesn’t it need it, I put it there because the existing one with my current OS - 12.04LTS



That’s because it IS used space … effectively it’s the drive map

If this is a storage drive, and not going to have an OS on it … no, you don’t need a swap partition.

You only need one swap partition for the OS to use a virtual memory if necessary … you don’t need one on every drive.

And if it’s an external HDD, you most definitely don’t want the swap partition on that drive … ideally swap would be on your fastest drive.

I know you’re getting the two threads mixed up but as I’m talking about the ‘yellow’ bit at the front of the ‘usable’ part of the formatted Hd (for the 3TbHd), I’ve just redone the Hd that I want to put multiple OS’s on and the partitions DON’T have the little ‘yellow’ section of used space at the beginning of each partition. Why’s that?


I’ve decided to format it back to NTFS so you could class this as problem solved.