[SOLVED] Torrents causing system restart. Hardware issue?

What's strange, is that my syslog files are still giving me UFW entries? Didn't I just remove the firewall?
Uninstalling will not stop the running processes. Hence your UFW logs. Reboot would have cleared up (or stopping the service). Just to rule out faulty memory, try running memtest from a Live CD (instructions here). Mint would have similar options.

SeZo, that’s what I thought but shouldn’t the power-down and boot have stopped the UFW as a running process, after I had removed it? I booted my computer after the iPad crash and power-down but UFW is still running.

I’ll try the memory test, thanks.

If UFW is still running after reboot, then what did you uninstall, the gui?

Try to disable UFW with the following:

sudo ufw disable

I would stop at this point and see if it makes any difference.

To remove it you can type the following:

sudo apt-get remove ufw

To purge it you can type the following:

sudo apt-get purge ufw

As far as the iPad thing goes … is there anything in the

log files that might give a clue what’s happening just prior to the shutdown (ie. as the device is being detected)

Sorry, I was under the impression that when you “removed” a program from the Software Manager it completely uninstalled it from your system? I’ll try disabling it and see what happens…

Try reinstalling ufw

sudo apt-get install ufw gufw

reset it to defaults:

sudo ufw reset

then purge it

sudo apt-get remove --purge gufw ufw

then reboot.

Ok, I followed SeZo’s instructions and disabled, removed, then purged UFW. Guess what? My iPad mounts and I can access the files! No power-down. :slight_smile:

But now I have fresh problems. When Mint starts, the Update Manager in the panel remains in the “searching” status; Chrome won’t load; Firefox loads but remains in the “connecting” status.

I really appreciate your help with all this guys. Hopefully, we’re learning something together here which will help future users with similar issues. I’m wondering if I should start a new thread, as the original problem has been solved?

I just went to reboot my system and can’t bring up the shutdown dialog either.

Ok, I decided to wait and I got a “Firefox is still running, do you want to shutdown?” notice. I answered in the affirmative, and then all my desktop icons and system tray items went low-res and Mint is taking forever to shutdown. You lot probably think I’m on a wind-up. I’m really not. There must be a reason these things are happening in the order they are. Frustrating.

So is it just shutdown that is broken, or is connectivity broken too? Is it just the applications, or the network connection itself?
What’s written to dmesg while it’s trying to shutdown? Run this code before trying to shutdown (might have to read it quickly!):

tail -f /var/log/dmesg

In the end, I did a hard reset. I know that’s stupid but it’s getting so late and ten minutes had gone by with the Mint logo frozen on the screen.

I then had additional problems at BIOS; the USB initialisation stage was taking ages and so was Mint in booting. Then my USB wifi dongle wasn’t being recognised (hence no internet for Firefox to connect to). But after a couple of reboots, things seem back to normal.

This really has been a saga. Thanks for your patience guys.

This is pointing towards a hardware issue :frowning:
What CPU is in this machine?

I wonder if this is a hard drive problem ?

do you know how to check the SMART data ?

Ok guys, I’m back where I started as far as the iPad is concerned, abrupt power-down when I plug it in. Everything else is in order.

Chemicalfan, it’s a ten-year-old Pentium 4 running at 2.4GHz. Motherboard is an eight-year-old ASRock model. I’ll check the SMART thing too, Mark. I’m going to start a new thread for the iPad issue if that’s ok guys.

sure … it would probably help if you attach the dmesg logs to the new topic.