[SOLVED] Torrents causing system restart. Hardware issue?

I have a recurring problem with my Mint 16 (Mate) installation. Whenever I start downloading a torrent with Transmission there is, at some point, an abrupt system restart. I have looked at my syslog files at the time of the crashes and something which appears a lot is this message (sometimes rows and rows of them):

[  238.032104] [UFW BLOCK] IN=wlan0 OUT= MAC=64:66:b3:0d:89:35:5c:35:3b:d1:d0:fd:08:00 SRC= DST= LEN=58 TOS=0x00 PREC=0x40 TTL=35 ID=52921 PROTO=UDP SPT=45685 DPT=51413 LEN=38

Is this a clue I wonder? It also happened one time as I was assembling the “key captcha” pic on here. Very frustrating.

My hardware setup:

System:    Host: lee-P4i65G Kernel: 3.11.0-12-generic i686 (32 bit) Desktop: N/A Distro: Linux Mint 16 Petra
Machine:   Mobo: N/A model: P4i65G version: 1.00 Bios: American Megatrends version: P1.30 date: 09/08/2006
CPU:       Single core Intel Pentium 4 CPU (-UP-) cache: 512 KB flags: (sse sse2) clocked at 2396.680 MHz 
Graphics:  Card: NVIDIA NV44A [GeForce 6200] 
           X.Org: 1.14.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1440x900@50.0hz 
           GLX Renderer: GeForce 6200/AGP/SSE2 GLX Version: 2.1.2 NVIDIA 173.14.37
Audio:     Card: Intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic
Network:   Card-1: Realtek RTL-8139/8139C/8139C+ driver: 8139too 
           IF: eth0 state: down mac: 00:13:8f:f4:ed:02
           Card-2: Ralink RT5572 Wireless Adapter driver: rt2800usb 
           IF: wlan0 state: up mac: 64:66:b3:0d:89:35
Drives:    HDD Total Size: 160.0GB (11.9% used) 1: id: /dev/sda model: ST3160022ACE size: 160.0GB 
Partition: ID: / size: 19G used: 4.3G (25%) fs: ext4 ID: /home size: 125G used: 14G (12%) fs: ext4 
           ID: swap-1 size: 4.04GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 148 Uptime: 2:58 Memory: 524.9/2015.4MB Client: Shell inxi: 1.8.4 

Hi Morgan

Welcome to the forum

Your syslog doesn’t mean a lot to me I’m afraid but in my experience sudden system crashes usually point to hardware maybe a bad memory chip

if you have more than one memory chip on your board it might be worth removing one at a time to see if resolves the issue and nail it down to one chip,

also overheating could be behind it so it might also be worth checking the cooling fan is working ok and the heatsink is located properly and not choked with dust

but before you do that it would probably be better to wait until some of the more technically experienced guys come on board with their advice

Good luck


Do you have the latest kernel installed? Is that the only line listed at the time, or are there several? Check the dmesg log rather than syslog

That line [UFW BLOCK] seems to be harmless (see here)
You could check out UFW logs:

cat /var/log/ufw.log | grep "DPT=51413"

To eliminate UFW problem try switching it off and see if the problem still manifests itself.
Though I doubt this is the underlying problem.

I doubt if this is firewall related, particularly if it happens whilst doing the keycaptcha

but to disable the ufw firewall, run:

sudo ufw disaable

to switch it back on:

sudo ufw enable

Can you explain, “abrupt system restart” … the system suddenly goes OFF followed by automatic reboot ?
(in other words it doesn’t “lock up” or do a controlled power down and reboot ?)

Did it do this before you loaded the proprietary nvidia drivers … IIRC the 6200 uses turbocache (shared memory)

Thanks for your suggestions guys. Today, I started my computer and there was nothing, not even the BIOS screen. I removed one stick of RAM and so far so good. I have a torrent downloading at the minute so we’ll see if it happens.

I’d already had the video card out, had the battery out, cleaned out the dust, etc. As things stand, it does appear to have been a bad RAM module. I can live with that but sorry for wasting everyone’s time.

Yes, Mark, I was getting complete shut-downs without warnings (sometimes rebooting, sometimes not).

I can’t help with the problem but I can tell you that I had this issue for a while regardless of what client I was using.
After a while it just sorted itself.

Sent from Galaxy S4 via Tapatalk

Out of curiosity, why would torrents trigger a RAM fail? I wouldn’t have considered downloading stuff to be particularly memory-sapping. If I was trying to burn a DVD or something I could understand my system running out of pop.

Ok, I may have spoken too soon. :frowning:

While the torrent was downloading, I decided (genius that I am) to plug in my iPad. This had also caused system crashes on previous installs so I was curious to see what happened. Result: system crash without rebooting.

I took my good stick of RAM out and replaced it with the “bad” to double-check. No BIOS on startup, so definitely bad. I put my good stick back in the same socket as I’d had the bad RAM and it booted fine, so no problem with the socket either.

So now I’m wondering, was one 1GB RAM not enough to cope with a torrent downloading AND an iPad connection on the USB? Surely not? Could my other stick be failing too? It would be a massive coincidence!

I don’t want this experience to sour my affection for Linux but it’s starting to frustrate me. I had no such problems with my old XP install up to last week. Does Linux access RAM differently? Again, it would seem a massive coincidence that my RAM would fail the minute I switch to Linux!

The torrent has resumed and no problems so far after the reboot.

So if I understand your post correctly doesn’t the problem point to plugging in your iPad

If you iPad is running ios7 you won’t be able to connect it to your Linux system but even then it shouldn’t cause a sudden shutdown but the problem may be the USB socket you’re plugging it into, Have you tried plugging another usb device into that usb socket ?


Graeme, removing the bad stick of RAM has stopped the torrent downloads crashing my system. However, the iPad issue has reared its head again.

I was having the iPad problem before (on a previous install) but it seemed to be fixed by a fresh install and using the libimobiledevice included with Mint rather than downloading it through the Software Manager. It’s actually an original iPad running iOS 5 and, like I said, I had it working fine. Other peripherals work fine on my USB ports and I tried plugging my iPad into ones at the back of my tower but it still crashes my system.

I’m really at a loss with this.

Searching on the internet doesn’t turn up anyone else with this issue, so is it not possible the iPad is the problem or perhaps the lead your using to connect it

Do you have another PC or Laptop you can plug the iPad into or have another lead you can try ?


Found this user with a similar problem. The culprit was Logitech drivers but I have none of those as far as I’m aware and even if I had, like I said, my iPad has worked fine before with its proprietary USB cable.


I wonder if there was something in the latest Mint update file I downloaded causing a conflict?

Well, here’s a curious thing.

In my efforts to get around the iPad issue, I set up a Dropbox account to transfer my files that way. Would you believe me if I told you that when my file starts uploading… you guessed it… system crash with reboot! Also, after Mint reboots and Dropbox starts automatically, if I don’t immediately click on “Quit Dropbox” on the panel, it crashes again as the upload begins.

What. The. Heck. Is. Going. On?

Did you say you’ve tried other distros ? … which ?

Do you want to try a different kernel and see if that helps ?

when it crashes, are any of the keyboard lights flashing ?

have you tried either turning off ACPI or booting with the acpi=off kernel boot parameter just as a test ?

2 of these issues are to do with the web … have you tried disabling wireless and connecting with an ethernet cable (to rule in/out wireless drivers/firmware) ?

No, Mark, I’ve only ever used the Mint 16 (Mate) distro.

No keyboard lights, just an abrupt power-off. Thanks for your suggestions. Not sure what ACPI is but I’ll check it out. I had another, seemingly random, crash late last night, checked the syslog and, again, rows and rows of the UFW phrase immediately prior to the crash. I haven’t tried with an ethernet cable as my computer is upstairs and my router is in the lounge.

This is HIGHLY unlikely to be being caused by the firewall (ufw) … but disable it as a test if you wish, your routers firewall is sufficient anyway.

What’s the output from:

uname -a

and would you like instructions to try a later kernel ?

What’s weird, though, is that the iPad was working fine on this kernel I’m using. Why should anything have changed? Is it possible something I’ve installed through the Software Manager is now causing a conflict?

I guess I can try another kernel. The “uname -a” command gave me:

Linux lee-P4i65G 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013 i686 i686 i686 GNU/Linux

I uninstalled the firewall and tried the iPad. It mounted, I briefly saw the folders and then came the power-down (no reboot).

What’s strange, is that my syslog files are still giving me UFW entries? Didn’t I just remove the firewall? :o