[SOLVED] TP-Link Model No. TL-WN725N (not working on Ubuntu 12.04)

Good Day!

As the subject states, I currently bought a TP-Link Wireless N Nano USB Adapter Model No. TL-WN725N and I assume that every TP-Link product works on any Ubuntu OS not knowing that this new product would not work on my Ubuntu 12.04. Any suggestions on how to make this thing work? Because I have older models of TP-Link’s wireless USB Adapter that works out of the box, but not this one.

Hope to get a response regarding this matter.

Thanks in advance!

Hi ben214, and welcome to the forum :slight_smile:

With the USB wireless adapter plugged in, can you open a terminal (Ctrl+Alt+T), and send the output from this command:


For clarity, that’s LSUSB … but it MUST be all lower case.

Good Day!

Thanks for the reply Mr. Mark Greaves, I manage to solve the problem since yesterday using this as reference: Edimax EW-7811Un USB wireless – connecting to a network (on ubuntu 11.10) | R-statistics blog and found out that the chipset of my USB Adapter is Realtek and the driver is RTL8188CUS. But still, thanks for the answer and the warm welcome for a newcomer. I will edit the subject as well.

BTW, I’m a newly hired I.T. here in our office and a much more familiar with Windows ecosystem, but my boss wants us to use Ubuntu as our desktop OS and would like to ask help on migrating from Windows XP and 7 to Ubuntu (12.10 to be specific) specially on network issues because I’m really having a hard time figuring out how to view network on Ubuntu using a Windows desktop, I know this is not the right post to say this but I will be glad to here response regarding my issues from you guys. I will post another thread regarding my issue.

Thanks and have a nice day!

If you mean how do you share directories and printers on an Ubuntu PC with a Windows PC (?)

Simple … install samba and system-config-samba:

sudo apt-get install samba system-config-samba

Then fire up system-config-samba (with elevated privileges):

gksudo system-config-samba

When it starts, go to Preferences>Server Settings … and make sure the Workgroup is set the same as the the rest of the network

Then click the “+” button to “Add a Samba share”

You should be able to work the rest out :wink:


Thanks for a very quick response regarding my issue. You instructions are very well explained and I manage to make Windows desktop see the Ubuntu network. Now my problem is whenever I try to print a document on an HP printer (HP LaserJet P2035) or dotmatrix printers like EPSON FX-2175 or LX-300 using Ubuntu it always ask me for authentication or keyring password. BTW, the printer was installed using Windows Printer via Samba since the printer is currently connected to a Windows OS and was shared through network.

I appreciate all your efforts, thanks and more power!

Which username and password is it requesting … the Windows ones, or the Ubuntu ones ?

The Ubuntu ones are asking for Authentication, I have no problem in Windows printer sharing. I also try making some changes on the windows homegroup options which is to share file and printer to everyone. Sorry for being a noob, I’ts just that I’m not familiar with this OS but I’m willing and eager to learn.

Thanks for the help, I really appreciate it.

Can you print if you authenticate ?

If so, which login details did you need to enter … the Ubuntu ones, or the Windows ones ?

No, I tried typing different usernames and passwords with no success, even username and password of both windows where the printer is currently installed and ubuntu machine.

Thanks for your patience in solving my problems.

Have a nice day!

I’m going to guess this is a Windows thing … I’m guessing Windows wants you to log in as a user that has permission to print.

Try giving the Windows “Guest” account permission to print (on the Win7 box) … then when prompted by Ubuntu for username and password to print, try

Username = Guest
Password = <leave blank … unless you’ve set up a password for the Guest account>

I haven’t got a Win7 PC handy, so I can’t test this.

i got a this nano router TP-Link Model No. TL-WN725N and can´t work!! please help

Can you open a terminal (Ctrl+Alt+T) and post the output from these 2 commands:



sudo lshw -C network