Sound issue


I’ve recently decided to give Linux a shot and have installed Ubuntu 10.10 on to a spare hard drive I’ve placed in an enclosure so as to maintain my windows laptop and thus gaming ability. So far it’s looking good, however I seem to be unable to use my headphones at all. The internal speakers of the laptop work but are low quality (and always have been), when I plug my headphones into the headphone jack there is no sound. I’ve had a look around the forums but I didn’t find anything obviously related/with the same problem but if i missed it point me in the right direction.

This is my first foray into the world of “advanced computing” (as opposed to simply using word etc.) so I’m not massively confident or knowledgeable, and what i do know is somewhat patchy but I’m willing to learn by asking stupid questions!

Furthermore in my random browsing of the forums I’ve seen lots of well explained and helpful stuff, so let me extend my thanks to everyone just for that!

Firstly, Welcome to the forum

Secondly… Great Username and Avatar :wink:

Can you tell us a bit about your hardware. (eg. laptop make and model)
Can you also open a terminal (Applications>Accessories>Terminal) and enter:

sudo lshw -C multimedia

hit enter, and your password when asked… be aware, you won’t "see anything being entered when you type your password but it IS going in… also remeber Linux commands ARE case sensitive… copy and paste the command if you need to.

Then post back the output.

Cheers, i like these forums, seem a lot nicer than others I’ve seen around, just in terms of content, patience etc.
It’s my standard Internet name, people just don’t seem to like having capitalized, two part names on the net…Once got asked if it was from World of Warcraft (it’s not, I’ve never played) which says a lot…

Anyway the important stuff:
laptop is a Hi-Grade Mobile scholar, Intel Core 2 Duo T5750 2GHz (2GB RAM)
2GHz 667Mhz CPU, 2GHz (2x1024) DDR2 RAM, 160GB HHD, DVD-RW,
15.4" WXGA Display, Independent 128MB ATI Grapics VGA with shared system memory,

Copied from the receipt for the laptop (minus stuff like web cam, screen size etc which I don’t think is relevant)

Unbuntu is installed on a Samsung Spinpoint M7 (160GB) running through an enclosure and a USB hub

Output from command
description: Audio device
product: RV610 audio device [Radeon HD 2400 PRO]
vendor: ATI Technologies Inc
physical id: 0.1
bus info: pci@0000:01:00.1
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:49 memory:fb010000-fb013fff
description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:47 memory:fb300000-fb303fff

Can you post the output from

cat /proc/asound/card0/codec#* | grep Codec

Codec: SigmaTel STAC9205
Codec: LSI ID 1040

OK, try this…

Open a terminal and enter:

sudo gedit /etc/modprobe.d/alsa-base.conf

hit enter, and your password when asked.

When gedit opens, scroll to the bottom, and add a new line at the end that reads:

options snd-hda-intel model=eapd probe_mask=1 position_fix=1

So the bottom part looks SIMILAR to this:

# Keep snd-pcsp from being loaded as first soundcard options snd-pcsp index=-2 # Keep snd-usb-audio from beeing loaded as first soundcard options snd-usb-audio index=-2 options snd-hda-intel model=eapd probe_mask=1 position_fix=1

Click Save, and close gedit.

Now reboot.

Thank you very much, that’s solved the problem!
As it happens what appears at the bottom is pretty much exactly what you typed, i take my hat off to you sir!

Just for my own curiosity I don’t suppose you could explain what I just did? or link/direct me to somewhere where i could start to get an idea of that? I’m currently rather enthusiastic to learn about the technical side of things, even if its only a little…

Once again thanks for the help and the wonderful forums/site


OK, the command:
sudo lshw -C multimedia

sudo = run this command as root… ie. with admin privileges.
lshw = list hardware
-C multimedia = only echo the “multimedia” Class to screen.

Told me what your sound card(s) were, which drivers they were using, and if they were loading…

That gave me a hint, as I knew the Intel HD audio sometimes need a “tweak”.

So, the command:
cat /proc/asound/card0/codec#* | grep Codec

cat = concatenate files and print to (in this case) screen
/proc/asound/card0/codec#* = path to, and name of, the files to read
| = pipe the output to the next command, which is…
grep Codec = search the input for lines containing the word Codec and display them.

Told me the correct Codec to search for the “options” for.

If you want to know more about a particular command, see its man page (manual)… eg. to see the man page for the grep command -
in a terminal enter:

man grep

or to see the man page for cat

man cat


man sudo


you can also check their info page, eg.:

info grep


info cat


The problem was getting the Intel Hi-Def alsa audio drivers to load the correct options, and load the sound cards in the correct order

First read this

And this:
lists the usable options for the STAC9205 codec


A quick “Google” told me most people had the best result with the eapd option for the STAC9205 codec .

So the Line you put in the “alsa-base.conf” config file…

options snd-hda-intel model=eapd probe_mask=1 position_fix=1


options snd-hda-intel model=eapd Told alsa to use the eapd option for the snd-hda-intel sound module.

probe_mask=1 effectively, probes for codec slots missed by the BIOS.

position_fix=1 fixes a DMA (direct memory access) position problem.

See here:
also see:

Or The short answer - You reconfigured the way your sound card drivers are handled.

Does that help any? :wink: