Steam on Kubuntu 16.04

Hi Guys

I’m trying to get steam running on Kubuntu 16.04, It installed ok from the repos via apt-get but when I click on the steam icon nothing happens, running from the terminal giver this error message

graeme@Media-Centre:~$ steam
Running Steam on ubuntu 16.04 64-bit
STEAM_RUNTIME is enabled automatically
[2016-06-10 19:47:42] Startup - updater built Apr 29 2016 22:18:33
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I searched for a solution and found this page

This solution

LD_PRELOAD='/usr/$LIB/' DISPLAY=:0 steam

worked except it wont load my steam library even though I’m logged in

Apparently this issue is caused by the open source AMD GPU drivers but I have an Nvidia Geforce card

graeme@Media-Centre:~$ sudo lshw -c display
[sudo] password for graeme: 
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:20:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:31 memory:f2000000-f2ffffff memory:e8000000-efffffff memory:f0000000-f1ffffff ioport:1100(size=128) memory:f3080000-f30fffff

Any suggestions would be much appreciated


Please disregard my last post I’ve decided KDE isn’t the DE I thought it was

So I’m gonna uninstall and start over


Whichever *buntu you settle on, installing steam via the .deb on the steam website seems to go better for most people.

Thanks for your suggestion Mark I have already tried that on more than one 16.04 variant, and I’m certainly not the only one one with this issue

I know it works with Peppermint 6 (once I get the i386 libraries sorted out) so i’ve decided to go with that

I’m trying to build a kinda Media Centre/Games console box for my Grand-Daughter and for the most part it’s working out ok but I seem to hit road blocks whatever direction I go in at the moment in PM6 I the best resolution I can get is 1024x768 which is too low and I’m not being offered any additional drivers for the nvidia geforce card I have installed but I’ll start a new thread for that and for some weird reason even though I’m logged in I can’t access my steam library

Many thanks


Have you tried this solution from a helpful guy with the same name as you