SuperTuxKart segmentation fault (SOLVED)

HI Guys

I installed Tux Racer and Supertuxkart to my grand-daughters PC, Tux Racer works fine but Supertuxkart crashes always at the point of “Start Race”

I ran it from the terminal, here’s the output if it helps

chloe@Linux2 ~ $ supertuxkart
Irrlicht Engine version 1.8.0
Linux 3.2.0-37-generic #58-Ubuntu SMP Thu Jan 24 15:28:57 UTC 2013 i686
[FileManager] Data files will be fetched from: '/usr/share/games/supertuxkart'
[FileManager] Addons files will be stored in '/home/chloe/.local/share/supertuxkart/addons'.
[translate] Env var LANGUAGE = 'en_GB:en'
[translate] Env var LANGUAGE = 'en_GB:en', which corresponds to 'English (Great Britain)'
Adding language fallback en
[IrrDriver] Trying OpenGL rendering.
WARNING: Only power of two textures are supported.
[IrrDriver Temp Logger] Level 3: FBO format unsupported
[IrrDriver Temp Logger] Level 3: FBO error
Couldn't create the render target for post-processing, disabling it
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-PtJtYw/pkcs11: No such file or directory
Error messages and other text output will be logged to /home/chloe/.config/supertuxkart/stdout.log and /home/chloe/.config/supertuxkart/stderr.log
Segmentation fault
chloe@Linux2 ~ $ 

Any help or advice would be much appreciated

Many thanks


Which graphics driver are you running ?

sudo lshw -C display

chloe@Linux2 ~ $ sudo lshw -C display
[sudo] password for chloe:
description: VGA compatible controller
product: NV31 [GeForce FX 5600]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 32 bits
clock: 66MHz
capabilities: pm agp agp-3.0 vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
resources: irq:16 memory:e8000000-e8ffffff memory:d0000000-dfffffff memory:e9000000-e901ffff
chloe@Linux2 ~ $

which version of supertuxkart have you got installed ?

dpkg -l | grep supertuxkart

loe@Linux2 ~ $ dpkg -l | grep supertuxkart
ii supertuxkart 0.8-1~ubuntu12.04.1 3D kart racing game
ii supertuxkart-data 0.8-1~ubuntu12.04.1 3D kart racing game (data)
chloe@Linux2 ~ $

I wonder what would happen if you force version 0.7 instead of 0.8 from precise-backports.

Fire up Synaptic

Search for supertuxkart and highlight it.

click Package>Force Version

From the drop menu, select 0.7

click the Force Version button.

now do the same thing for the supertuxkart-data package.

Once they’re both marked for downgrade … click the “Apply” button.

You can always go back to 0.8 … I’m just wondering if 0.7 will work.

Ok Mark your plan worked again v7 works fine :slight_smile:

There’s an official PPA with a different version of 0.8 if you wanna give that a go:

Ok I’ll have a look at that

Many thanks once again


No problem :slight_smile:

If you add that PPA and run an update, you’ll probably have to do the “force version” thing again to select the version from the PPA as it seems slightly older that the one from precise-backports.

And when you’ve settled on one that works … go back into Synaptic and lock the version (so it doesn’t get updated by update-manager)

In Synaptic highlight the supertuxkart package.

Then click Package>Lock Version

(You should see a little lock icon appear in the little green box for supertuxcart)

Then do the same for supertuxkart-data

I decided just to leave it at v7, it works fine and she’s had some fun with it and all that matters to me, so if it aint broke i see no point in fixing it

So I’ll mark this solved and thank you again for your help


You’re welcome :slight_smile: