Support Thread - Installing PeppermintOS Four on an Acer Aspire One AOA110L ZG5

This is the support thread for the:

Tutorial - Installing PeppermintOS Four on an Acer Aspire One AOA110L ZG5

topic located here:

Hi Mark,
I have updated from Peppermint 2 to Peppermint 4 on my AAO with HDD. It all went fine. Thank you so much for the efffort you have put into compiling a tutorial once again. It makes such a difference for people like me who want to use their existing hardware rather than buying new one every two years.
The only issue I am having is a message that appears every time during bootup and says something along the lines of “keys: Press I to ignore, S to skip mounting, or M for manual recovery”. I assume this is because of a suboptimal fstab and this again might have been caused by the fact that the initial boot was from the USB stick. Although I have some knowledge on fstab, I still hesitate to modify it because the error is not too grave. But I thought it might be worthwile looking into this as others might experience the same issue.
I am attaching the fstab and would appreciate any comments on which of the lines is causing the problem.
Thanks again and kind regards,

OK, somehow you’ve elected to use LVM and an encrypted swap file … I wouldn’t have done this, and can’t say for sure how it will affect things.

If I were you I’d start again and NOT use LVM … but we can attempt to stop the filesystem check dialog … run:

sudo touch /forcefsck

that will force a run of the file system checker (fsck) at next boot … hopefully this will automatically fix any errors.

If you still get the same message, hit the “M” key for manual recovery, cross your fingers, and accept any suggested changes.

Once finished, see if it boots without that message.

Thanks, Mark. The option to use LVM was one of the first ones to make during the installation, and as you did not mention it I thought it may be a good idea.Well, it probably was not.
I have rebooted with fsck and also hit the “M” key for manual recovery, but the message still appears during bootup. Booting now also takes very long…seems it does the fsck every time?
Anyway, thanks for your help. I think I can live with this message.

Okey Dokey :slight_smile:

Press I to ignore, S to skip mounting, or M for manual recovery

I get that message every time I boot up my laptop and occasionally when i boot my PC I just leave it and it continues to boot, it doesn’t seem to slow down the boot process at least not noticeably so I just live with it


Can’t say I do … odd :o

I wonder if booting a LiveUSB/LiveCD and manually running an fsck would help … if anyone want to try, let me know if you need instructions.


I do occasionally get:-


Displayed top left during boot, and I vaguely remember seeing that in the plymouth configs during the beta testing … but I just ignore it.

I have followed your steps closely but when I boot the usb it just says “SYSLINUX 4. 03 2010-10-22 EDD Copyright (c) 1994-2010 H. Peter Anvin et al” and doesn’t move from this screen what have I done wrong?

Shut down the AA1

Insert the LiveUSB

Turn ON the AA1, and immediately hit and hold the F12 key

When the boot device options are displayed, is the USB stick listed as a

or a


It is listed as a USB FDD

You’ll need to usde a different USB stick … for some reason the AA1 is pretty choosy about which USB sticks it will recognise as an HDD :o

Oh okay thnkyou, I will have another go wheni find a different USB then.

OK, please let us know how you get on :slight_smile:

Purchased a new USB drive today and it worked fine im now running peppermint 4. Thanks for the support :slight_smile:

Thanks for the feedback, and you’re welcome :slight_smile:

I followed the instructions and tried (twice) to upgrade from Peppermint 3 to 4. It did not work, my A110 hangs itself after reboot. I am reverting back to version 3 and will avoid all updates except Firefox.

See your other topic:

hi mark
decided to take the plunge! Not doing very well so far, i clicked the try first icon, but have no internet connection. i have to do it wireless but can not find the correct section in the menu. i have the home hub pull out tab next to me.
any help would be great to get me started

Personally in your position I’d probably wait till Peppermint 5 now … but if you want to continue…

Are you booted to the Peppermint 4 LiveUSB, and are you at the desktop ?

If so, click the networkmanager icon in the system tray by the clock (bottom right of screen) … then select your network from the list, and enter your wireless key … you should then have a wireless connection.

Firstly, thanks so much for the great ZG5 tutorial! :smiley:

I’m currently trying to optimize the fan but get stuck with an error after entering ‘make’. Here is the error message:

timo@timo-AA1 ~/acerhdf/acerhdf_kmod $ make
make -C /lib/modules/3.8.0-33-generic/build SUBDIRS=/home/timo/acerhdf/acerhdf_kmod modules
make: *** /lib/modules/3.8.0-33-generic/build: No such file or directory. Stop.
make: *** [default] Error 2

Any advice would be gratefully received!