The address wasn't understood

Hi, I’m using Firefox 50.1.0 on Linux Mint 18.1, on trying to watch sky- go I get the following message,
The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (skygo) isn’t associated with any program or is not allowed in this context.

You might need to install other software to open this address.

I been watching sky-go for well over a year no problems, on Linux Mint 17.3 and more recently on Linux Mint 18.1, I get netflex OK and silverlight5.0 is working this has just happen in the last couple of days skygo works fine on windows 10 with Firefox.
I have tried reseting Firefox, and reinstalling Firefox, any one got any ideas on how to fix this.

Try clearing the Firefox cache, and cookies … then close ALL running instances of Firefox … reopen Firefox and try again.

Thank you for your reply, I have tried clearing the cache and cookies still the same, I’m beginning to think this is a update by Linux Mint or Firefox, that’s stop this from working. I am getting the same problem on other web sites but it’s intermittent, but it’s with video or still pictures, has far has I can tell.

Have you tried downgrading Firefox ?

or maybe tried it in Chrome ?

When you say you’ve tried “resetting” firefox, how did you do this ?

I have restarted Firefox with no add-ons and in safe mode, I have log out and uninstallled Firefox and then reinstall Firefox, I have tried Chromium,and Opera to no success . I’m still left with the same problem, I have tried removing add blocker, and I have also tried disabling each plugin and add on but still nothing. This has happen on two PCs one Intel and one AMD and a Lenovo laptop all over Christmas.I have now uninstalled Linux Mint from one PCs and am going to do a fresh install tomorrow so we see what happens.I have also use clamtk and Comodo and Eset NOD32 just in case also check with F-Secure Router checker all fine.

Google Chrome might have been a better bet than Chromium/Opera

Get Chrome from here:

(get the .deb version … then just double click it to install)

Also it might have been worth COMPLETELY setting Firefox back to defaults by closing it, then whilst firefox is closed renaming the ~/.mozilla folder

mv -v ~/.mozilla ~/.mozilla-original

then firing up Firefox again.

The config directory will automatically get recreated on first run … but you can always go back to the original by running the following 2 commands with Firefox closed:

rm -rv ~/.mozilla


mv -v ~/.mozilla-original ~/.mozilla

At the very least that would rule out a firefox config/cache/addon issue.

Thank you for your help, I have now tried this,so as you say we can now rule out, firefox config/cache/addon issue.
I have now downloaded all files and folders and am going to reinstall Linux Mint just to see if that works if not I will reconsidor where I go next,
bid of a hair puller this one I have only had little silly problems with Linux in the two or a bit more years that I have been using it and I have to say I feel this just a frustrating problem that I will find an answer for eventually.

My problem is I no longer have sky, so have no way of testing if it’s something that’s changed at sky’s end.

I have now resolved all my picture and video problems on Linux Mint, except one and that’s Sky Go surprise surprise. It appears that the issue with my Browser was an add on call Quickjava I can only think it was causing conflict with Pipelight or Silverlight or both of some kind, however when you remove the plugin your browsers retains the settings that Quickjava had so you have to reset Firefox,and then only reinstall the plugins you want.
I am able to watch Netflex and some other on line program that I have, but not got Sky Go and have had no success in anyway, which odd because I was watching this just before Christmas and before New Year, I can only think that Sky have changed there set-up in some way which now stops Linux user watching Sky go so that’s money down the drain.
I’m not saying don’t use Quickjava or it’s a bad plugin it just never worked for me, and I can only say to Sky well your losing good customers because of your policy of not wanting Linux users very sad and very poor.
I like to thank everyone who tried to help it’s been great project now thats it’s fixed.

Just a quick update for anyone interested, I now have Sky Go back it took two days had to reinstall pipelight/ sliverlight after that all is well even today.

Nice … thanks for the solution :slight_smile: