touchpad doesent work in peppermint os acer aspire one aoa150 -bb

Hello ppl,
as the tittle say my touchpad dont work in peppermint os.
It did worked coz i had pepp2 installed but i wanted to try osx
and when i reinstalled it again no touchpad and no left and right button.
wht i have tried> 1. Fn+F7 (nothing, every other funktion work)
johny@acer ~ $ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
↳ USB 2.0 Camera id=12 [slave keyboard (3)]

johny@acer ~ $ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

johny@acer ~ $ sudo modprobe -r psmouse && sudo modprobe psmouse

tried even some scprits to enable touchpad after using keyboard
and checked is touchpad on menu options
untill monday i cant check is this hardware failure so any further help is wellcome

Looking at the assigned "id"numbers from xinput … I’m going to guess the touchpad is being given id=11 but is then disconnected for some reason.

Can you run:

dmesg | grep syn

and post any output.

if there is NO output, run:

dmesg > ~/dmesg.txt

You’ll then find a file called dmesg.txt in you Home directory … attach that to the next posting.

ok, this is wht i got.

Hmm … doesn’t seem to be being detected at all ???

Have you tried it from a LiveUSB ? … just to rule out the install ?

May sound daft, but have you also tried (whilst the AA1 is switched OFF) removing both the battery and power lead … then hitting the power switch to discharge the motherboard capacitors … then reconnecting the battery and power lead, and booting ?

Have you recently taken the AA1 apart ?

Though this shouldn’t be necessary for the touchpad to work … have you run a system update ?

yes, i tried from diferent live distro to boot up… it could be hw failure cos i changed wireles adapter on my acer … thanks anyway
ill use usb mouse till i take it to the repair shop and post some updates on this

If you’ve had it apart, there’s a chance you’ve not seated the ribbon cable from the motherboard to the touchpad correctly … that happened to me once … took it apart t add more RAM, when I put it back together it “looked” OK, but the touchpad didn’t work … disconnected and reconnected, and it worked perfectly.

Good luck :slight_smile:

thanks, ill take it apart again :)))

If you’re comfortable taking it apart again … it’s certainly worth a shot :slight_smile:

The second time … it tested it before clicking the keyboard back in place … as IMHO the keyboard is the only fiddly bit.

Good luck.