TP Link and SSH/ swann DVR IP camera recorder/MEyeviewPro

While I’m lurking and before I go out for a beer. . . . … . . …

2 questions, network related-ish . . . . . .

I have a TP Link TL-WA801ND being used as an AP - I previously used SSH to connect from the downstairs laptop to the upstairs desktop, turning the superhubs wireless OFF to use the AP killed that of course but I’ve since added the APs IP to the firewall rules (UFW) - no dice, what have I missed? added it both ways. …

No2- I have a swann dvr unit and 4 cameras at home, the MEyePro app on my android, and much as I’d like to think I’d followed instructions properly. . . . . . . NO connection to it. . . . . port forwarding is enabled, DHCP is enabled, it shows as an attached device in the hubs control panel but doesn’t show under IP Lease Table if that makes a difference, just fishing for things to try/think of, my networking knowledge isn’t great but I can normally follow instructions OK so don’t know where I’ve gone wrong. I’ll reply tomorrow so if anyone’s had experience with these dvr’s or this type of setup I’d appreciate any pointers thanks.

  1. Does SSH work with ufw disabled ?
sudo ufw disable

you can re-enable it with:

sudo ufw enable
  1. Have you tried giving the DVR a static IP ?

With regards to the dvr.
This is just to prove that local network communication is working:
Are you able to log in locally (the dvr connected to a display unit)?
If so check the network settings and note the IPv4 address and Server Port (this should be 8000).
Once you got that info go to your PC and put the : url (like into the address bar of the web browser you are using. This should bring up the remote login interface.

Hello chaps, thanks for the replies -

Mark - yes I’ve tried disabling it an lo and behold it connects, re-enabled and it won’t - I’ve looked at my firewall rule and can’t see what the issue is ?

I’ve not tried giving the DVR a static IP, however, upon rebooting it’s always the same - if that makes a difference…


Sezo I’ll come back to your question shortly thanks

Sezo, here’s as much as I can tell you:

The DVR’s details tell me in network settings - DCHP/UPNP enabled - mobile port 18004, media port 9000, web port 00085 IP
netmask gateway then it has DNS 1 DNS 2 apparently all that is assigned by the router.

I’ve tried all sorts in the browser to connect - - shortens itself to just ‘85’ -, - nothing

on the mobile I’ve got mobile port 18004 - and it just says server unavailable - UPNP is enabled on the virgin superhub router and according to the booklet I don’t need to be concerned with forwarding ports as UPNP does all this for me - and I should use DHCP as this is preferable with UPNP enabled as it makes locating the DVR from other devices on the network easier . . . . .

Hands up, I’m a bit out of my depth here, it vaguely starts to make sense before I read too much and I’m back to lost lol. . . . :o

OK can we do these one at a time (or in separate topics), as it’s becoming confusing.

When you say it works when you disable the firewall, I’m not sure which you mean … DVR or SSH ?

With dynamic IP’s wouldn’t it just be easier to allow ALL connections from anything on your local network IP range


Allow In Both

I take it you’re behind a NAT router with a firewall anyway … so you could even turn the firewall off unless you’re blocking something specifically ?

Hi mark, I mean SSH works with ufw off, I can try what you suggested
I.e 01 to 254, so I just set that up as a rule on both machines on UFW? I’m not blocking anything particular …

Sent from my I9377 using Tapatalk

so I just set that up as a rule on both machines on UFW?

Hi Mark,

applied the rule and it works, but only with the GUFW turned off, any idea WHY this has suddenly changed? It’s only the same setup as I had on my older machine
and I’m curious as to what causes this? There must be something in UFW stopping it and if it’s not the rule then what?


Switch on UFW and in Terminal see the status:

sudo ufw status

See if SSH port 22 is Allowed
If not then add rule:

sudo ufw allow 22

Check status again:

sudo ufw status

Test SSH connection.