Trying to install I get an error[Fixed Thanks] don't know how?

when I was trying to install a web creator I got the following error

"The following packages have unmet dependencies:

rest2web: Depends: python-support (>= 0.90.0) but 1.0.10ubuntu3 is to be installed
Depends: python-docutils but it is not going to be installed" I am on ubuntu 11.04… is this waiting for an upgrade or part of the error… I suppose it could say is if it was waiting?

You’ll have to install the dependencies it’s looking for.



Have you got python installed?

It’s looking for a more recent version of python-docutils than is in the Ubuntu repos.

Unless you know how to install a later version and solve any dependencies it may need … you can’t install it.

Might help if you said exactly what you are trying to install.

My mistake … it’s actually looking for the python-support package with a version greater than or equal to 0.90.0 … have you installed that, it’s in Synaptic but I’m not sure which version is in the Natty repos.

I repeat … It would help if you said EXACTLY what you are trying to install … “a web creator” tells us nothing, and doesn’t allow us to check what it’s requirements are.

I assume what he means by “web page creator” is, a program which “codes” a page. Software like:




If that were to be the case, why not just use wordpress?

Yes, I get what “type” of application he means … but how are we supposed to check an applications system requirements, or try to work out a fix if he doesn’t say EXACTLY which application, version, and preferably where he’s getting it from ?

It’s kinda difficult (at best) to “usefully” answer a question without as much information as possible.

Which should ALWAYS include…

Application name

Application version

Where you got it from … and if from the web, a link.

Distro name and version

Error messages

and any other information you think may be relevant, such as anything you have already tried fix the problem.

Some of the above he has provided, but there are glaring holes in the information provided, such as the application name, version, where he got it, how he tried to install it … ie. where is the error message coming from ? … Synaptic, Ubuntu Software Centre, ap-get, aptitude, dpkg …

That is true.

@theporter2000: We have tried telling you before, you should give us as much details as possible to help us solve your problem. We cannot assume what you’ve done to try help you. We’d greatly appreciate it if you posted how, where and what program your trying to install.
Help us to help you.