Trying to make a wireless connection to my router

i have been trying to solve this myself but to no sucses, i clicked the network icon in the top right but im using this ethernet cable at the moment so i can try and find help.

the thing is i cant use it all the time hence i want to make a wireless one. which was possible before on windows 7. i tried to create new connection but it doesnt seem to work, i go back to the icon after putting in the name of the router and key code,

i either keep getting pop ups from some key ring thing which is anoying me cos i dont know the password. (now edited i do know the PW) ive done some update which someone suggested on google but that hasnt helped.

OK after that little rant i come back. so i have one connection availble which is the ethernet connection eth0. ive tried to add a wireless connection but on the icon at the top under wireless it still is blanked out cant disconnect or connect. pretty sure i filled out the ssid correct with the correct key. any advice would help.

edited for ease of reading, my grammer is poor sorry people

First go to System>Administration>Hardware Drivers, and see if you are being offered any wireless drivers to activate… if not…

Can you send us the output from these 2 commands



lspci | grep Ethernet

Enter them in a terminal, remember Linux IS case sensitive, so type them EXACTLY as shown.

there were 2 things there that had activate buttons so pressed em both. see what happens

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 064e:a127 Suyin Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

07:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)

ok clicking on the network button at the top right after installing those 2 broadcom drivers a list of wireless connections came up. i cant thank you enough for your help i was getting worried about switchin too linux. i think me and ubuntu will get along famously now though.

i unplugged my ethernet cable when i did those commands.

No problem… if you haven’t already… it may be a good idea to reconnect with your ethernet cable, and go to System>Administration>Update Manager, and get all the system updates before trying to set up your wireless connection.

It wouldn’t have mattered if you left the ethernet cable plugged in whilst entering those commands, but they weren’t needed in the end anyway… they were only to tell me which wireless chip was being used so I could search for the driver if needed :wink:

yeah i did this earlier to a google advice i read, ill do it again anyway, one question will this keyring password always pop when i do things? its rather anoying but funny cos if i dont laugh i feel like smacking my laptop. its good for helping me type faster but i dont see any other use :smiley:

Try setting your keyring password to be the same as your login password …

Go to System>Preferences>Passwords and Encryption Keys… on the Passwords tab, right click on Password: login, and select change password.

You should see - Choose a new password for the ‘Login’ keyring

Enter your Old Password:
but leave

Now click OK… click Use Unsafe Storage.

now after a reboot, you shouldn’t be asked for the keyring password any more.

Setting the keyring to the same as login password only works if you haven’t set auto login

People use the auto-login option ?!

Do they leave their front doors open too ? ???


yeah im using auto login, and yea in the summer m front door is open :stuck_out_tongue: its devon. i guess if i type it in on login thats alot less then every 5 minutes. while im here i managed to install wine. 1st i DL then extracted but no clicky install button, guess i got to get used to this terminal thing. im basically looking for a all in one app, tried filtering on wineapphq but it didnt quite work so off hand would anyone know of an app that would do my registry/disk defrag/disk clean/webhistory i had one for windows but cant remember its name.

sorry for the wall of text :stuck_out_tongue:

I was guessing… seems to be a Windows habit that some find hard to get over :wink:

I would agree disabling auto-login and using the same password for the keyring is the best way to go… I must admit I used to use auto-login, as I said old habits die hard.

on a single user home PC where security isn’t an over riding factor, It’s safe enough I suppose… but if you’re security concious…

Try to get out of the (bad) Windows habit of downloading your software from the interweb.
(this is one of the many routes by which windows gets its malware)

Either install wine (or any other software packages) from Synaptic (System>Administration>Synaptic Package Manager)

or from the Ubuntu Software Centre (Applications>Ubuntu Software Manager)

Software packages installed from these package managers, comes directly from the Ubuntu software repositories… so can be considered safe, and has been tested and compiled specifically for compatibility with your version of Ubuntu.

It is possible to get software from the web and install it, but always check to see if it’s available in your package managers first.

thanks still on A scrolling through them all, shud be under utilities right?

type wine into quick search.

Mine too… Cornwall… We go out regularly and leave the doors unlocked.

Bit different from when we lived in the West Midlands :wink:

getting the hang of this now, i managed to DL and install wine 1.3.3 via browsing the net, got azureus like that too. theres alot of apps out there maybe ill google the type of app but download the app when i find its proper name, typing defrag or registry cleaner didnt seem to work. seems being a simpleton isnt gonna cut it here, which is good havent worked my brain for a long time :smiley:

If you use synaptic, you can search by application type… just enter something like browser or game into the quick search.

and all browsers/games available in the repositories will be displayed in the main window.

same applies to the Ubuntu Software Centre.

there are literally 1000’s of packages available in synaptic.

Typing defrag, or registry cleaner wouldn’t have worked because Linux file systems don’t need defragging, so no defrag utils, and there is no registry in Ubuntu/Linux, so no cleaners… thank god :slight_smile:

yeah ive just been browsing and to my noobness i find that i dont need these things. if linux can do these things why havent windows implemented these things to prolong performance and lifespan of pc’s, they suck i remember crashing pc’s when i hadnt cleaned or defragged them for a long time :smiley: and having to defrag everytime i installed or uninstalled a new game.

things are looking up :smiley:

You might want to fire up synaptic, and install the ubuntu-restricted-extras package.

or it can be installed from the command line with:

sudo apt-get install ubuntu-restricted-extras

man thanks id be lost without these forums :smiley: