Tutorial - Installing PeppermintOS Five on an Acer Aspire One AOA110L ZG5


There’s a new tutorial for installing Peppermint Six here:


In this tutorial we will wipe the default OS (Linpus Lite) from the internal 8GB SSD (or hard drive in the case of the AOA150) and install PeppermintOS (Five) Linux is its place.

Why would you want to do this … Well Linpus Lite, though small and fast is based on Fedora core 8 which is a very old Linux distribution that has been out of active development for quite some time … so Linpus Lite doesn’t receive any updates, and it is nearly impossible to get any new software to install without jumping through hoops, if at all.

PeppermintOS (Five) on the other hand is based on the MUCH more recent Ubuntu 14.04 (Long Term Support release), but uses the LXDE desktop (with the Xfce4 window manager/compositor) which is more like a “normal” desktop environment, and is also small and fast … it also has the added benefit of having access to the Ubuntu software repositories, so it is VERY easy to install the latest software.

If you want a quick look at what the PeppermintOS Five desktop will look like by default, see here:
(obviously the appearance, wallpaper, themes, icons, etc. can easily be changed, and/or you can add dock bars such as docky/cairo-dock/etc. if you wish)
Or for a more in depth look at what PeppermintOS is all about, why not take a look through all the PeppermintOS user guide sections, here:

As you can see it has a single panel at the bottom, an application menu, a system tray, and a workspace that you can put application icons (shortcuts), files, or directories on … in fact (good or bad) it’s very similar to the Windows layout.

I’m going to set out this tutorial in stages … the first stage will tell you how to download the PeppermintOS Five ISO image, and how to use a Windows PC to write it to a 1GB or larger USB Stick.

The following stages will deal with installation, then some post-installation tasks to get Peppermint “just right”.

These instructions may look complex at first glance, but take it from me it is easier than it looks :slight_smile:

OK, Stage 1 …

Downloading the PeppermintOS (Five) ISO image (to a Windows PC) and writing it to the USB stick

The following instructions are for creating a PeppermintOS Five LiveUSB stick using a Windows PC … if you need instructions for creating a LiveUSB on an Ubuntu based Linux distro including an earlier version of Peppermint, see the instructions at the end of this posting.

On your Windows PC, download the PeppermintOS (Five) 32bit ISO image from here:
or see here:

Once you’ve got the ISO image … download Universal USB Installer (version or higher) from here:

Start Universal USB Installer, and at …

Step 1 … In the drop down list, select PeppermintOS
Step 2 … point it at the ISO image you downloaded
Step 3 … Choose your (already plugged in >= 1GB) USB stick … probably best to let it format it too, so backup its contents first.
Step 4 … (if available) Set the slider to the largest persistence file it will allow you… so you can save changes. (if you want to test drive it first)

Heres a pic of the Universal USB Installer interface


Click Create … and wait till it’s done … it will take a while, and may appear to have stopped … but just wait till it says it’s “Done” … as in the following pic

Pic of Universal USB Installer … Installing to USB Stick


Once the LiveUSB has been created, click Close, plug it into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB HDD as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

Be aware … running from a USB stick will be quite a bit slower that running it from the internal SSD after installation, so don’t draw any conclusions about speed at this point :wink:

I can tell you that once installed, it takes slightly longer to boot than Linpus Lite … but once booted it loads/runs applications just as quickly … and has access to all the latest software.

Once you’ve got to a working desktop, you can either test drive Peppermint from the USB stick … or you can just click the “Install Peppermint” icon that will be on the desktop … but we’ll get to that in a bit :slight_smile:

For users creating the LiveUSB stick in another version of Peppermint (or other Ubuntu based distro) -

First you’ll need too install usb-creator-gtk, so open a terminal (Ctrl+Alt+T) and run:

sudo apt install usb-creator-gtk

Now from your menu’s go to menu > System Tools > Startup Disk Creator

Here’s what to expect -


I’ve found it’s usually best to let it format the USB stick first, so in the bottom pane select your USB stick, and hit the “Erase Disk” button, and enter your password if prompted.

Once the format is done, in the top pane, select the ISO image you want to create the LiveUSB stick from (if it’s not already there, browse to it by clicking the “Other” button)

If you want the LiveUSB to be persistent (ie. able to save changes), make sure “Store in reserved extra space” is selected, and use the slider to adjust the size of the persistence file (the amount of room set aside for saving changes).

Click the “Make Startup Disk” button.

You’ll be prompted for your password a couple of times before it tells you the LiveUSB has been created and is ready for use.

Stage 2 …

Using the LiveUSB you just created to install PeppermintOS (Five) to the internal SSD (or HDD)


Make sure you have NO SD cards inserted during the Peppermint install … they may interfere with the installation procedure


This part is very easy … Plug the LiveUSB into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB stick as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

When you get to the desktop … Click the Install Peppermint icon on the desktop, and follow the onscreen prompts to install Peppermint

If you have your netbook connected to your router by an ethernet cable (or have enabled wireless from the Live desktop), when asked by the installer, put ticks in the boxes to

Install extra software
Install updates during installation

Otherwise leave them unticked.

If at any stage during the install process you’re asked if you want to use LVM, or encryption, say NO

When you get to the Allocate drive space part of the installer, allow it to replace Fedora release8 (werewolf) and use the whole drive.

When you get to the part where it ask you for a username and password etc … here’s a few hints -

You will be asked for things like -

Re-Enter Password:

The Computername field will probably be autofilled for you after you’ve entered your name … but you can change it.

Make sure the Username is all lower case, and no spaces

Here’s what I used for MY AA1

Name: Mark Greaves Computername: mark-AA1 Username: mark Password: whatever_you_want Re-Enter Password: whatever_you_want (again)

so keep the username short and lower case (and no spaces)

Password rules … I think it needs to be at least 6 digits and at least one number … and remember, passwords ARE case sensitive.

It may be a good idea to write down what you enter here, so you don’t forget them … you WILL need at least the Username and Password later on, so don’t forget them.

When asked if you want to enable “Auto Login” (Login Automatically) … tick that option if you DON’T want to have to enter your username and password at each boot.

Stage 3 …

Entering your Wireless key

When the installation has finished and you have rebooted to the internal SSD (or HDD) …

Whilst on the desktop …

Click the NetworkManager icon (it looks like little steps, or two unplugged cables in the system tray, by the clock) on the bottom panel … you should be presented with a list of available wireless networks.

Click YOUR network, and you will be given a message about “System Policy preventing changes” asking for your password … this dialog box expects your PEPPERMINT password (NOT your wireless key), so enter it and hit “Authenticate”

you should NOW be prompted for the WEP or WPA(2) key.

Enter your wireless network key, and click Connect.

That’s it… you’re connected :slight_smile:

Stage 4 …

Enabling the extra software repositories

In the menu, go to System Tools > Synaptic Package Manager, enter your password, when Synaptic starts -

Go to Settings > Repositories … when a new window opens -

On the “Peppermint Software” tab, make sure ALL 5 boxes are ticked.

On the “Other Software” tab, make sure all boxes are ticked EXCEPT (if present) the one that starts with cdrom:

Click Close

Click the Reload button on the Synaptic toolbar.

Close Synaptic.

(It’s IMPORTANT that you close Synaptic, or the commands in the next stage won’t run)

Stage 5 …

Run a System Update

Open a terminal by hitting these 3 keys at the same time Ctrl+Alt+T

When the terminal opens, enter:

sudo apt update

and hit the Enter key … you will be prompted for your password, so enter your password and hit Enter again.

Be aware … when entering your password into a terminal, nothing will get echoed to screen (not even ******) but it is going in … also remember Linux commands (and your password) ARE case sensitive.

When that command completes, and leaves you back at an $ prompt, (still in the terminal) run:

sudo apt upgrade

to pull in any software updates.

Stage 6 …

Installing the extra software (part one).

OK, we’re going to install the extra software in 2 stages … the first stage to install most of the software … but we’ll leave out ubuntu-restricted-extras and lubuntu-restricted-extras because those packages also install the ttf-mscorefonts-installer which always causes problems with it’s license acceptance window.
(you WILL want these package, because they installs support for mp3, flash etc. but we’ll install them later in the tutorial)

In the menu, go to Accessories > Terminal

When the terminal opens, enter:

sudo apt update


sudo apt install firefox vlc libreoffice thunderbird skype && sudo update-apt-xapian-index

hit enter, and your password if/when asked … and if it prompts you for a y/n, hit y and enter.

Stage 7 …

Installing the extra software (part two)

Open a terminal (Ctrl+Alt+T) and run:

sudo apt install ttf-mscorefonts-installer

at some point the terminal will turn blue telling you you need to accept a license, with at the bottom …
hit the Tab key so the is highlighted red … hit the Enter key …
the next screen will have , again hit the Tab key so/until is highlighted red … and hit the Enter key.

It will now install.

Once ttf-mscorefonts-installer has finished installing … still in the terminal run:

sudo apt install lubuntu-restricted-extras ubuntu-restricted-extras

The restricted-extras packages should now install without issue because the license for ttf-mscorefonts-installer has already been accepted.

Java -

Be Aware … the java browser plugin will only work in Firefox or pre-Aura versions of Chrome/Chromium, Google have decided to no longer support NPAPI plugins in the Aura versions.

If you’re going to NEED Java support (see warning below), you may want to install the openjdk-7-jre and icedtea-7-plugin … so back in the terminal, run:

sudo apt install openjdk-7-jre icedtea-7-plugin

WARNING … there is a known security vulnerability in Java 6 and 7 that can allow someone that exploits it to break out of the java sandbox … this vulnerability will not be fixed until Feb 2013 at the earliest (if at all), so if you don’t need Java don’t install it … if you do, disable the icedtea plugin in your web browser and only ever enable it for websites that require java.


Thanks to dsplayname (on the old Peppermint forum) if you’d prefer to try the Oracle Java 8 (JDK8 nad JRE8) you can follow the instructions on this webpage:

Stage 8 …

Fixing the Microphone for Skype.

First you need to change a setting in Skype … so go to:-


When Skype starts, login … then when Skype is running and you’re logged in … right-click the Skype icon in the system tray (bottom right, by the clock) and select:-

Options>Sound Devices and make SURE the -

Allow Skype to control my mixer levels

option is NOT ticked … click the “Apply” button … now quit Skype by right-clicking the Skype icon in the system tray (by the clock) and selecting “Quit”.

Open a terminal and enter:


and hit enter.

The terminal will change to a mixer.

Hit F4 to change to the Capture devices.

Hit the right arrow key … so Capture is light in red (at the bottom).

Hit the Q key till the left volume is at 75% … the Z key will lower if you go too far.

Hit the C key till the right volume is at 0% … the E key will raise it, but you want it on zero

Close the terminal

Fire up Skype again and test the mic.

Stage 9 …

Fixing the CPU fan (stopping it from running all the time)

The “acerhdf” module is already part of the kernel in Peppermint 5, so there’s no need to compile it … all we need to do is set the load options, so open a terminal and run:

sudo gedit /etc/modprobe.d/acerhdf.conf

When a BLANK file opens, add a single line that reads

options acerhdf interval=5 fanon=60000 fanoff=55000 kernelmode=1

SAVE the file, and exit gedit.
back in the terminal run:

sudo modprobe -r acerhdf


sudo modprobe acerhdf

The fan should now work properly, and only come on when the temperature reaches 60C, and go off again when it’s dropped to 55C.

You can check the temperature by running the following command in a terminal:

cat /sys/class/thermal/thermal_zone0/temp

the temperature will be returned in this format -
60000 = 60C
55000 = 55C
46000 = 46C

It would be a good idea to keep an eye on the temperature for a short while, just to check the fan does come on when the temperature reaches 60C … be aware, running the command to check the temperature takes a single reading, so you will have to run it again to get another reading.

Stage 10 (optional) …

Extending battery life by installing the TLP power management application

This is an optional install, but I recommend it for the Acer Aspire One, as when you switch from mains power to battery power, TLP will switch your CPU into power saving mode unless the CPU is under load, which will make your battery last longer.

Open a terminal and run:

sudo add-apt-repository ppa:linrunner/tlp


sudo apt update


sudo apt install tlp tlp-rdw smartmontools ethtool

then start tlp with:

sudo tlp start

and check it’s running with:

sudo tlp-stat | grep "TLP power save"

As long as (after a reboot) that last command still returns:-

TLP power save = enabled

you’re good to go …

It might now be a good idea to go to -

menu > System Tools > Software Updater

and see if it offers you any updates to install.

Then that’s it, you’re done with this tutorial … pat yourself on the back and enjoy Peppermint Five :slight_smile:

Thanks for the tutorial. P4 successfully upgraded to P5 :slight_smile: I notice this time you suggest the fan fix is necessary rater than optional. Is that what you intended? Many thanks

acerhdf is now installed (and should be loaded) by default anyway … so I figured if it’s already running may as well pass it the correct parameters :slight_smile:

The 3 main changes for the Peppermint 5 tutorial are:-

i) The right hand SDcard slot now works “out of the box” without any need to apply a workaround (thanks to the more recent kernel)

ii) acerhdf is now part of the kernel so is installed “out of the box” … so doesn’t require compiling.

iii) pulseaudio/pulseaudio-utils/pavucontrol are now installed by default in Peppermint 5 “out of the box”

So the instructions only really needed a little “tweaking” :slight_smile:

Hi to all. I’m new Linux user. Own Acer Aspire One ZG5 AOA110 I tried to install Peppermint 5 instead very old Linpus Lite. I’ve created LiveUSB stick using a Windows PC and made my AA1 ready for boot from USB, plug it to AA1, F12 on start up,choose option boot from usb and hit Enter and … nothing happen. Black screen with one line of text " SYSLINUX 4.07 EDO 2013-07-25 Copyright (C) 1994-2013 H. Peter Anvin et el" That’s all.

Am I doing something wrong? Tried to do that many times with different versions of Peppermint, Ubuntu etc.

Thanks for the overview of changes. Having set up skype, microsoft is copmlaining about the version:

We are now retiring older versions of Skype and it appears that at some point you signed into Skype with one of these. To continue signing into Skype on Linux you’ll need to download the latest version. The new version comes with improved performance, the latest features and security updates, so you’ll get the best possible Skype experience.

Will my current installation take care of this as an update, or do I have to work harder, if indeed the AA1 can cope with the new requirements?

Apperciate your guidance

OK, The AA1 is very “iffy” about certain USB sticks

First thing to try is at the flashing underscore type


and hit enter.

If it still doesn’t work, try using a different LiveUSB creator.

Are you using Windows or Linux to create the LiveUSB ?

Third thing to try is -

When you hit F12 to choose the USB stick as the boot device, does it list the USB stick as a “USB HDD” or a “USB FDD” ?

If it lists it as a USB FDD, you may need to use a different USB stick.

I’ve been getting emails from M$ suggesting I need to uprgade Skype with the same wording, but when I attempt to download Skype from their website it says it’s the same version as the one in the repos (

Can you post the output from:

dpkg -l | grep skype

and tell me when you’re getting that message ? … when you attempt to start Skype ?

Maybe you need to run a full system update:

sudo apt update


sudo apt upgrade


sudo apt dist-upgrade

then REBOOT … now test Skype.

The output is

dpkg -l | grep skype
ii skype i386 client for Skype VOIP and instant messaging service
ii skype-bin i386 client for Skype VOIP and instant messaging service - binary files

The microsoft message came as an email some time after I’d logged in to Skype as part of the microphone fixing procedure. I’ve not yet tried to operate Skype, but should be able to do so soon. Meanwhile I’ll run the updates you suggest and see what happens.

  1. Live not working.
  2. I’m using Windows 8
  3. It shows USB FDD

Well if you go to the skype website for Linux:

You’ll see that they’re offering the SAME version there … and that was where the email point you … so I’m assuming that email can be ignored

If you’re using Windows, you can try either of these LiveUSB creators

But as your AA1 is detecting the USB stick as a floppy disk drive, you’d probably be better off either just burning a LiveCD/LiveDVD or trying a different USB stick