Tutorial - Installing PeppermintOS Three on an Acer Aspire One AOA110L ZG5


There’s a new tutorial for installing PeppermintOS Five here:


In this tutorial we will wipe the default OS (Linpus Lite) from the internal 8GB SSD (or hard drive in the case of the AOA150) and install PeppermintOS (Three) Linux is its place.

Why would you want to do this … Well Linpus Lite, though small and fast is based on Fedora core 8 which is a very old Linux distribution that has been out of active development for quite some time … so Linpus Lite doesn’t receive any updates, and it is nearly impossible to get any new software to install without jumping through hoops, if at all.

PeppermintOS (Three) on the other hand is based on the MUCH more recent Ubuntu 12.04 LTS, but uses the LXDE desktop which is more like a “normal” desktop environment, and is also small and fast … it also has the added benefit of having access to the Ubuntu software repositories, so it is VERY easy to install the latest software.

Being based on the Ubuntu 12.04 LTS (Long Term Support) release, also means it will benefit from the FULL 5 year support cycle.

If you want a quick look at what the PeppermintOS desktop will look like (by default … obviously the appearance,wallpaper,etc. can easily be changed), see here:

As you can see it has a single panel at the bottom, an application menu, a system tray, and a workspace that you can put application icons (shortcuts), files, or directories on … in fact (good or bad) it’s very similar to the Windows layout.

I’m going to set out this tutorial in stages … the first stage will tell you how to download the PeppermintOS ISO image, and how to use a Windows PC to write it to a 1GB or larger USB Stick.

The following stages will deal with installation, then some post-installation tasks to get Peppermint “just right”.

These instructions may look complex at first glance, but take it from me it is easier than it looks :slight_smile:

OK, Stage 1 …

Downloading the PeppermintOS (Three) ISO image (to a Windows PC) and writing it to the USB stick

The following instructions are for creating a PeppermintOS Three LiveUSB stick using a Windows PC … if you need instructions for creating one on a Linux PC, let me know.

On your Windows PC, download the last PeppermintOS (Three) 32bit official respin ISO image from my server:
(MD5 Checksum = 05157d6dbd4ab7953870e9ee308a70a5)
or you can download an earlier version directly from the Peppermint website here:

Once you’ve got the ISO image … download Universal USB Installer (version or higher) from here:

Start Universal USB Installer, and at …

Step 1 … In the drop down list, select PeppermintOS (Three)
Step 2 … point it at the ISO image you downloaded
Step 3 … Choose your (already plugged in >= 1GB) USB stick … probably best to let it format it too, so backup its contents first.
Step 4 … Set the slider to the largest persistence file it will allow you… so you can save changes. (if you want to test drive it first)

Heres a pic of the Universal USB Installer interface


Click Create … and wait till it’s done … it will take a while, and may appear to have stopped … but just wait till it says it’s “Done” … as in the following pic

Pic of Universal USB Installer … Installing to USB Stick


Once the LiveUSB has been created, click Close, plug it into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB HDD as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

Be aware … running from a USB stick will be quite a bit slower that running it from the internal SSD after installation, so don’t draw any conclusions about speed at this point :wink:

I can tell you that once installed, it takes slightly longer to boot than Linpus Lite … but once booted it loads/runs applications just as quickly … and has access to all the latest software.

Once you’ve got to a working desktop, you can either test drive Peppermint from the USB stick … or you can just click the “Install Peppermint” icon that will be on the desktop … but we’ll get to that in a bit :slight_smile:


Stage 2 …

Using the LiveUSB you just created to install PeppermintOS (Three) to the internal SSD (or HDD)


Make sure you have NO SD cards inserted during the Peppermint install … they may interfere with the installation procedure


This part is very easy … Plug the LiveUSB into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB stick as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

When you get to the desktop … Click the Install Peppermint icon on the desktop, and follow the onscreen prompts to install Peppermint

If you have your netbook connected to your router by an ethernet cable (or have enabled wireless from the Live desktop), when asked by the installer, put ticks in the boxes to

Install extra software
Install updates during installation

Otherwise leave them unticked.

When you get to the Allocate drive space part of the installer, allow it to replace Fedora release8 (werewolf) and use the whole drive.

When you get to the part where it ask you for a username and password etc … here’s a few hints -

You will be asked for things like -

Re-Enter Password:

The Computername field will probably be autofilled for you after you’ve entered your name … but you can change it.

Make sure the Username is all lower case, and no spaces

Here’s what I used for MY AA1

Name: Mark Greaves Computername: mark-AA1 Username: mark Password: whatever_you_want Re-Enter Password: whatever_you_want (again)

so keep the username short and lower case (and no spaces)

Password rules … I think it needs to be at least 6 digits and at least one number … and remember, passwords ARE case sensitive.

It may be a good idea to write down what you enter here, so you don’t forget them … you WILL need at least the Username and Password later on, so don’t forget them.

When asked if you want to enable “Auto Login” (Login Automatically) … tick that option if you DON’T want to have to enter your username and password at each boot.


Stage 3 …

Entering your Wireless key

When the installation has finished and you have rebooted to the internal SSD (or HDD) …

Whilst on the desktop …

Click the NetworkManager icon (it looks like little steps, or two unplugged cables in the system tray, by the clock) on the bottom panel … you should be presented with a list of available wireless networks.

Click YOUR network, and you will be given a message about “System Policy preventing changes” asking for your password … this dialog box expects your PEPPERMINT password (NOT your wireless key), so enter it and hit “Authenticate”

you should NOW be prompted for the WEP or WPA(2) key.

Enter your key, and click Connect.

That’s it… you’re connected :slight_smile:


Stage 4 …

Enabling the extra software repositories

In the menu, go to System Tools > Synaptic Package Manager, enter your password, when Synaptic starts -

Go to Settings > Repositories … when a new window opens -

On the “Peppermint Software” tab, make sure ALL 4 boxes are ticked.

On the “Other Software” tab, make sure all boxes are ticked EXCEPT the cdrom:[Peppermint 3_Three_ - Release i386 (20120423)]/ precise

Click Close

Click the Reload button on the Synaptic toolbar.

Close Synaptic.

(It’s IMPORTANT that you close Synaptic, or the commands in the next stage won’t run)


Stage 5 …

Run a System Update

Open a terminal by hitting these 3 keys at the same time Ctrl+Alt+T

When the terminal opens, enter:

sudo apt-get update

and hit the Enter key … you will be prompted for your password, so enter your password and hit Enter again.

Be aware … when entering your password into a terminal, nothing will get echoed to screen (not even ******) but it is going in … also remember Linux commands (and your password) ARE case sensitive.

When that command completes, and leaves you back at an $ prompt, (still in the terminal) run:

sudo apt-get upgrade

to pull in any software updates.


Stage 6 …

Installing the extra software (part one).

OK, we’re going to install the extra software in 2 stages … the first stage to install most of the software … but we’ll leave out lubuntu-restricted-extras because this package also installs the ttf-mscorefonts-installer which always causes problems with it’s license acceptance window.
(you WILL want this package, because it installs support for mp3, flash etc. but we’ll do it in a min)

In the menu, go to Accessories > Terminal

When the terminal opens, enter:

sudo apt-get update

hit enter and your password when asked … when that command finishes, enter:

sudo apt-get install firefox vlc libreoffice-calc libreoffice-writer thunderbird apt-xapian-index skype pidgin && sudo update-apt-xapian-index

hit enter, and your password if/when asked … and if it prompts you for a y/n, hit y and enter.


Stage 7 …

Installing the extra software (part two)

Open a terminal (Ctrl+Alt+T) and run:

sudo apt-get install ttf-mscorefonts-installer

at some point the terminal will turn blue telling you you need to accept a license, with at the bottom …
hit the Tab key so the is highlighted red … hit the Enter key …
the next screen will have , again hit the Tab key so/until is highlighted red … and hit the Enter key.

It will now install.

Once ttf-mscorefonts-installer has finished installing … still in the terminal run:

sudo apt-get install lubuntu-restricted-extras ubuntu-restricted-extras

Now lubuntu-restricted-extras should install without issue because the license for ttf-mscorefonts-installer has already been accepted.

Java -

If you’re going to NEED Java support (see warning below), you may want to install the openjdk-7-jre and icedtea-7-plugin … so back in the terminal, run:

sudo apt-get install openjdk-7-jre icedtea-7-plugin

WARNING … there is a known security vulnerability in Java 6 and 7 that can allow someone that exploits it to break out of the java sandbox … this vulnerability will not be fixed until Feb 2013 at the earliest (if at all), so if you don’t need Java don’t install it … if you do, disable the icedtea plugin in your web browser and only ever enable it for websites that require java.


Thanks to dsplayname (on the Peppermint forum) if you’d prefer to try the Oracle Java 8 (JDK8 nad JRE8) you can follow the instructions on this webpage:

I haven’t tested this, but it should work.


Stage 8 …

Fixing the right-hand SD card reader.

Open a terminal and enter these 2 commands:

sudo cp /etc/default/grub /etc/default/grub.bak

(hit enter, and your password when asked)

then run:

sudo gedit /etc/default/grub

(hit enter, and your password if asked)

When gedit opens, look for the line:

and change it to:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pciehp.pciehp_force=1”

(enlarged only to make reading easier, so you don’t mix up i and l)

Visually check the edit to make sure there are no spaces where there shouldn’t be, then SAVE the file, and exit gedit.
(be sure to visually check before saving, some people are reporting that when they copy/paste the above a space is appearing in pciehp_force between _ and f)

Back in the terminal, run:

sudo update-grub

(hit enter, and your password if asked)

WARNING - Be 100% sure you enter the next command correctly before hitting enter (probably best to copy/paste AND visually check).

When that command finishes, and leaves you back at a prompt, enter:

sudo sh -c 'echo acpiphp >> /etc/modules'

(hit enter, and your password if asked)

Now reboot, and check if the right-hand SD card reader works.


Stage 9 …

Fixing the Microphone for Skype.

First you need to change a setting in Skype … so go to:-


When Skype starts, login … then when Skype is running and you’re logged in … right-click the Skype icon in the system tray (bottom right, by the clock) and select:-

Options>Sound Devices and make SURE the -

Allow Skype to control my mixer levels

option is NOT ticked … click the “Apply” button … now quit Skype by right-clicking the Skype icon in the system tray (by the clock) and selecting “Quit”.

Now you need to install pulse audio and adjust the “Capture” volume levels, so on the bottom panel, go to menu>Accessories>Terminal

When the terminal opens enter:

sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

and hit enter.
then enter:


and hit enter.

The terminal will change to a mixer.

Hit F4 to change to the Capture devices.

Hit the right arrow key … so Capture is light in red (at the bottom).

Hit the Q key till the left volume is at 75% … the Z key will lower if you go too far.

Hit the C key till the right volume is at 0% … the E key will raise it, but you want it on zero

Close the terminal

Fire up Skype again and test the mic.


Stage 10 …

Fixing the CPU fan (stopping it from running all the time)


Open a terminal and enter the following commands:

sudo su


echo "options acerhdf interval=5 fanon=60000 fanoff=55000 kernelmode=1" >> /etc/modprobe.d/local.conf




sudo modprobe -r acerhdf


sudo modprobe acerhdf

The fan should now work properly, and only come on when the temperature reaches 60C, and go off again when it’s dropped to 55C.

You can check the temperature by running the following command in a terminal:

cat /sys/class/thermal/thermal_zone0/temp

the temperature will be returned in this format -
60000 = 60C
55000 = 55C
46000 = 46C

If you have to apply this fix … It would be a good idea to keep an eye on the temperature for a short while, just to check the fan does come on when the temperature reaches 60C … be aware, running the command to check the temperature takes a single reading, so you will have to run it again to get another reading.


Stage 11 (optional) …

Extending battery life by installing the TLP power management application

This is an optional install, but I recommend it for the Acer Aspire One, as when you switch from mains power to battery power, TLP will switch your CPU into power saving mode unless the CPU is under load, which will make your battery last longer.

Open a terminal and run:

sudo add-apt-repository ppa:linrunner/tlp


sudo apt update


sudo apt install tlp tlp-rdw smartmontools ethtool

then start tlp with:

sudo tlp start

and check it’s running with:

sudo tlp-stat | grep "TLP power save"

As long as (after a reboot) that last command still returns:-

TLP power save = enabled

you’re good to go …

It might now be a good idea to go to -

menu > System Tools > Software Updater

and see if it offers you any updates to install.

Then that’s it, you’re done with this tutorial … pat yourself on the back and enjoy Peppermint Three :slight_smile:

Those of you that were already using PeppermintOS Two, and don’t like the new colour theme in Peppermint 3 … or the new notification system tray applet may be interested in some of the postings on this page:


Hi Mark, thanks so much for this tutorial. I was fed up of linpus lite and after following your tutorial for updating firefox I thought I’d give peppermint a try.

Unfortunately I have already hit a snag. I have created the USB and started the aa1. However when I get to the first peppermint screen asking to install or try peppermint the computer freezes. I have tried it a few times and if I push any buttons the thing just stops. I then tried redoing the USB stick, but this time when I boot it doesn’t even go to the peppermint screen. It freezes on a black screen with “copyright peter anvin et el…” and won’t go any further.

The USB stick is only 1 gig, is this the problem?

Thanks in advance.

If this is an Acer Aspire One … yes it’s highly likely to be the USB stick in combination with the AA1.

Easiest check seems to be …

With the USB stick inserted, turn on the AA1, and as you see the “Acer Empowering People” logo screen, hit F12 to bring up the Boot device selection screen.

Is your USB stick listed as a:-

USB HDD (Hard Disk Drive)

or a

USB FDD (Floppy Disk Drive)

If it’s listed as a USB FDD … you’ll need to use a different USB stick, as the AA1 can be choosy about USB sticks … someone else mentioned they need to be 2GB + (I’m not 100% sure this is the case).

It may be worth trying formatting the USB stick as FAT32 or FAT and see if that makes a difference, or try using a different LiveUSB creator (which has worked for some people), such as:-

Linux Live USB Creator



Ah yes, it is listed as FDD. I’ll go into town and buy a bigger one tomorrow and try again. Thanks for your help.

Mark, you legend.

I am writing this from my newly installed peppermint 3 with Spotify playing in the background. I can’t thank you enough for the tutorials, you deserve an OBE or something!

Well, I don’t quite know how to respond to that, other than to say “you’re more than welcome” :slight_smile:

If an Earl has an OBE, does that make him an earlobe ?
(sorry for that … but I couldn’t resist)

Hi Mark,

I am a Linux Virgin and have just got this up and running on a colleagues Aspire One, thank you for taking the time out to produce this invaluable tutorial it has certainly made installing this OS a doddle.

You should get a Knighthood for services to the newbie Linux community… :smiley:



Hi elcuolo, and welcome to the forum :slight_smile:

I’m glad to hear it was of some help … and thanks for the feedback.

I reckon a knighthood is probably out of the question … Though “Sir Mark of Cornwall” has got a certain ring to it :wink:

Ok, well maybe a nice cool pint of Pear Rattler instead then?