Ubuntu 10.10 can't mount?

Downloaded the new Ubuntu 10.10 distro from


. I downloaded the 32-bit version, since I was going to install it along side Vista. It’s my mothers laptop, but my PC is currently broken atm, (needs new mobo & CPU), so I’m using my mum’s laptop. Downloaded fine, actually finished downloaded just after I got up at half 5. I’ve burned two discs and neither of them are working, so I’m beginning to think that there’s something wrong with the download. I burned one disc at a speed of x4 and the other one at x2.4 onto a DVD-R for data/video. I’ve installed Ubuntu 10.09 on these discs before so I know it ain’t the discs, and I’ve burned numberous Windows OS’s aswell.

I keep getting an error message about Ubuntu failing to mount because of some I/O error. If I was to put the disc in when logged into windows it would run wubi.exe and it boots up the loading screen when I boot from disc. Anyone know what the problem might be?

EDIT: I’ve tried to boot from a USB using the “usb-creator” but for some reason it won’t insert the file into the menu… like if I choose “Other” and then point it to the file location “C:\Users\Me\Downloads\ubuntu-10.10-desktop-i386.iso” it won’t appear in the menu. I’m even running the program as an administrator. Also tried following this guide


The Universal USB Installer works with Ubuntu 10.10, and can be downloaded here:

Further info here:

(I know it says 10.04 in the URL, but if you read the page it says it covers 10.10 too)

Download it… fire it up… select “Ubuntu 10.10 Desktop i386” from the drop down menu… click “Browse” and point it at your downloaded ubuntu-10.10-desktop-i386.iso

If you want to test your download, you could either check the downloaded ISO’s md5 checksum, which should be:


for ubuntu-10.10-desktop-i386.iso… you’ll need a 3rd party application for generating md5 checksums in Windows, such as:
(BTW, you might want to check this for viruses… I haven’t)


Boot from the LiveCD that you’ve burned, and as soon as the Ubuntu boot screen appears (as soon as the BIOS screen disappears) hit the “Shift” key, and keep your finger on it till you get to the GRUB bootscreen, then select “Check the CDROM for defects” or similar.

If it checks out OK, can you post the exact error message.

Cheers mark. Started install at around half 10, was stuck at the Who are you? section for at least 4/5 hours. So I just restarted install. I’m now again stuck at the same Who are you? screen… it won’t let me forward for some reason. At the bottom it says “Ready when you are” but I can’t do anything. Apart from write in details about myself, i.e. Name, Username, Name of computer & Password. Seems to be doing something though, so I’ll leave it on through the night, I’m really needing sleep. Never had this much hassle with 10.09 though :(.

Writing this from the Live demo btw, just incase you were wondering.

Is there a green tick at the end of these 3 fields? (even if there IS, read on)-

Your name: Whatever You Want (capitals and spaces ARE allowed)

Pick a username: must be all lower case (and I think no spaces)

Confirm your password: ******* (I think it needs to be at least 6 digits and contain a number)

BTW, if it also asks for a computer name… some people say “that needs to be all lower case too”… My computername has a capital, but was an upgrade from 10.04 and not a fresh install, so I can’t say for sure.

If there ISN’T a tick at the end of those 3 lines then you haven’t met the correct criteria for the field and it won’t let you continue until you correct it.

Message to Canonical/Ubuntu… It would probably be handy to let users know on this screen that the “Pick a username” field can’t contain upper case characters, and/or STOP including the word “Username” (greyed but with a capital “U”) in the box, which gives the impression that capitals are OK.
(A lot of what I’m reading online leads me to think that 10.10’s new version of Ubiquity gives you a green tick even if you use a capital letter in the “Pick a username:” field, but it won’t let you continue until you change it to all lower case… but it gives no warning of this… if this is true, that’s a major oversight/bug that needs fixing… previous Ubiquity versions used to warn you.)


If there ARE ticks after each of those 3 fields and you used all lower case for the username… and it still won’t let you continue, you could try using the “Alternate Install CD”
or direct download:
32bit - http://releases.ubuntu.com/10.10/ubuntu-10.10-alternate-i386.iso
64bit - http://releases.ubuntu.com/10.10/ubuntu-10.10-alternate-amd64.iso

Well that’s just like awkward. That’s near enough 12 hours I left this laptop on, to see if it would do something to find that the username can’t contain capital letters.
Install seems to be fine now, think maybe they should sort out the Ubuquity for the next version of Ubuntu. I guess I got the impression that you can use capital letters due the, greyed-out letters in the field box.

If I come across anymore problems I’ll let you know. Cheers again Mark.

Well I’m not in a good mood. I’ve now installed Ubuntu 10.10 twice and both times it have installed successfully, yet when I restart the laptop it boots straight into windows. I’m guessing GRUB isn’t installing for some reason. I did give Ubuntu its own seperate partition, and I’m kinda confused as to why GRUB didn’t install =/.

Need help :frowning: ?

Did you tell it to install GRUB to the master boot record (MBR) ?.. I would have expected it to do this by default though.

Are you installing it on the same drive as windows ?

It is possible to install (or reinstall) GRUB from the LiveCD, but you may find it a bit involved… instructions here:

Yes, it’s on the same harddrive as windows but in its own partition. I didn’t get anything to tell me where to install GRUB, so I would’ve expected to do it by default as well.

I’ll give the install from the live CD a go, see if that works.

Haven’t tried the live CD yet, but I have installed this distro like 6 times and I’m having no luck at all. GRUB won’t seem to install for some reason.
I’m not really wanting to boot up the liveCD and go and reinstall GRUB2 manually, but it’s looking like I’m having to do that, since I’ve just done another install from the CD. I did a couple from the USB as well. It did say during installation “GRUB install successful” … and it was installed too “dev/sda3” so I’m kinda confused.

Does it boot directly to the Windows bootloader, or GRUB ?

What happens if you hit shift immediately after the BIOS POST screen… does it load grub ?

It could be telling you GRUB stage 2 is loaded on /dev/sda3 which is probably correct, but you need GRUB stage 1 loaded on the Master Boot Record.

Yeah, directly boots straight to the Windows bootloader. I haven’t tried pressing shift but I’ll give it a go.

Boot from the LiveCD, open a terminal and enter:

sudo fdisk -l

If that reports /dev/sda3 as being your Linux partition, enter these commands one line at a time… hitting enter after each line:

sudo mount /dev/sda3 /mnt
sudo grub-install --root-directory=/mnt/ /dev/sda

then reboot, and GRUB should be installed.

When you’ve rebooted into Ubuntu (on the hard drive)… open a terminal and enter:

sudo update-grub

Cheers mark. Seems to have done the trick [:

Have you run:

sudo update-grub


If you don’t, you may find Windows is missing from the GRUB boot menu.

Yeah, I did it as soon as Ubuntu logged in. Everythings cool beans now.