Ubuntu 11.10 32bit will not boot

I get the Grub list normal boot from the present Linux or any of the previous 4 versions results in the same error. I have tried the recover menu all options but the problems remain.

Is there\any way to determine if it is a HDD problem… Because if it is then there is no point in doing a fresh install…

Error: mountall Disconnected from Plymouth mount error: could not resolve address for networkspace: Unknown error

Looks like more of a problem with mounting a network share … though quite why it’s hanging there is a bit weird.

Have you turned anything off … NAS maybe ?

Can you boot to a LiveCD and post the contents of the /etc/fstab file from the hard drive.

Be sure to get the one from the hard drive, not the one from the LiveCD

How do I ensure it is from the hard drive? I have to hard drives.

OK worked it out.

There is no /ect/fstab folder on the drive. I am using a live CD with 11.4 hope this not an issue. This happened yesterday after we had a power cut 5 programs were open at the time. When I restarted after the power cut I got this issue.

/etc not /ect

And a file, not a folder

There WILL be one :slight_smile:

Contents of file-

/etc/fstab: static file system information.

Use ‘blkid -o value -s UUID’ to print the universally unique identifier

for a device; this may be used with UUID= as a more robust way to name

devices that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdb6 during installation

UUID=2de65054-dc65-49a2-938e-5e65a3bde7d8 / ext4 errors=remount-ro,user_xattr 0 1

swap was on /dev/sdb7 during installation

UUID=2406e6c0-e8a3-4a99-84c9-0270bcf7858a none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
//networkspace/openshare /mnt/shared cifs user=,password=,domain=000D0B6DA3C4,uid=1000 0 0

Yup … looks like the last ilne:

//networkspace/openshare /mnt/shared cifs user=*********,password=*********,domain=000D0B6DA3C4,uid=1000 0 0

Is causing the problem … try commenting it out , so it reads:

# //networkspace/openshare /mnt/shared cifs user=*********,password=*********,domain=000D0B6DA3C4,uid=1000 0 0

SAVE the file, and reboot to the hard drive.

BTW, I’ve edited your last posting to remove the username and password from that line … for security :slight_smile:

When you edit the /etc/fstab DON’T change the username and password … just prefix the line with an #

The boot process seems to be stalling because it can’t bring up that network share (or is attempting to mount the share before networking is fully enabled) … once we’ve tested this theory by commenting out the line … we can maybe, add the _netdev pararmeter to the fstab entry, which tells it to not attempt to mount the drive till networking is up.

how do I open the file for editing as it is read only.

Easiest way (without knowing the path) … open nautilus as root:

sudo nautilus

Then browse to the file and open it.

Yes that’s no longer a problem but still will not boot now get error- postgse SQL server failed to start please check log output

OK, I’m wondering if this is an issue with HDD space (or file system) … can you boot the LiveCD, and send the output from:

df -i


df -h


sudo fdisk -l

ubuntu@ubuntu:~$ df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
aufs 215209 602 214607 1% /
none 211765 910 210855 1% /dev
/dev/sr0 0 0 0 - /cdrom
/dev/loop0 149991 149991 0 100% /rofs
none 215209 5 215204 1% /dev/shm
tmpfs 215209 694 214515 1% /tmp
none 215209 49 215160 1% /var/run
none 215209 2 215207 1% /var/lock

ubuntu@ubuntu:~$ df -h
Filesystem Size Used Avail Use% Mounted on
aufs 1.5G 122M 1.3G 9% /
none 1.5G 656K 1.5G 1% /dev
/dev/sr0 686M 686M 0 100% /cdrom
/dev/loop0 658M 658M 0 100% /rofs
none 1.5G 112K 1.5G 1% /dev/shm
tmpfs 1.5G 7.7M 1.5G 1% /tmp
none 1.5G 92K 1.5G 1% /var/run
none 1.5G 4.0K 1.5G 1% /var/lock

buntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa970a970

Device Boot Start End Blocks Id System
/dev/sda1 * 1 19457 156288321 b W95 FAT32

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00031f7b

Device Boot Start End Blocks Id System
/dev/sdb1 1 9305 74739352+ 83 Linux
/dev/sdb2 9305 19458 81549313 5 Extended
/dev/sdb5 18663 19458 6384640 82 Linux swap / Solaris
/dev/sdb6 9305 18141 70970368 83 Linux
/dev/sdb7 18141 18662 4190208 82 Linux swap / Solaris

Partition table entries are not in disk order

I do not know if it is an issue but was using Word on wine at the time of the power cut and had just received a low memory warning.

Ahh … you hadn’t mentioned a power cut … and with a 160GB HDD it’s probably not a space issue.

REBOOT to the LiveCD (important that you reboot, so no drives/partitions are mounted), then open a terminal (Ctrl+Alt+T) and run:

sudo fsck /dev/sdb6

and see if it finds/fixes any file system errors.

if not, do the same with:

sudo fsck /dev/sdb1

Then see if it will boot.

NO will not boot.

The following line fails shown in red - PostgreSQL server failed to start. Please check log output.

All the other commands report OK and boot stops at a flashing curse

Just as a matter of interest … what is that //networkspace/openshare share ?

Any idea what you have PostgreSQL installed for ?

and have you tried moving something (from your home directory) off the hard drive … to see if it IS a space issue ?

if that doesn’t help, can you post the EXACT error message.

//networkspace/openshare share is a network drive on the LAN it is listed in my book marks.

That is the full line. PostgreSQL server failed to start. Please check log output

No Error message…

We may be chasing a phantom here, as I can’t see that postgresql failing to start would kill the boot process … have you tried making some room on your HDD … it may be that postgre isn’t starting because of a lack of space ?


What is postgre being used for … any ideas ?

I do not know what What postgre being used for

https://help.ubuntu.com/8.04/serverguide/postgresql.html This is what Ubuntu has to say about what it is but it’s to Tec for me…

Nothing has change since it booted OK and only 66GB out of 160GB are in use so space is not a problem.

When you get to the flashing cursor, are you able to log on using the (text) console ?

ie. get to the flashing cursor, hit Ctrl+Alt+F3 … can you now log in in text mode ?

Yes can log in to text mode…