Ubuntu 18.04 not working on live USB [SOLVED]

Lenovo Thinkpad T500 64-bit laptop running Ubuntu 16.04

Thought I’d have a look at Ubuntu 18.04 before upgrading. I usually delay upgrading to allow the bugs to be ironed out. Here’s the process:

  • I downloaded the ISO file OK (ubuntu-18.04.1-desktop-amd64.iso) and the md5sum value agreed with the published value.
  • Next I used the excellent UnetBootin to create a live USB, and this process seemed to go OK with no reported errors.
  • Rebooted the PC with the USB in then selected “Try Ubuntu without installing”.

Several attempts to boot into the live USB failed with errors:
[ 8.770062] tpm tpm0 error (6) occurred attempting to read a pcr value
[ 8.864554] tpm tpm0 error (6) occurred attempting to read a pcr value

So I recreated the live USB and tried again.
The same errors occurred but after a couple of attempts Ubuntu 18 fired up.
I can connect to my network, and the terminal and FireFox work but nothings else - the little wheel rotates for a while then disappears.
The exit button results in the usual Ubuntu blinking dots then the original Selection screen (Try Ubuntu, etc) plus a few more errors, but doesn’t exit, so I crashed out.


I am guessing that as the MD5SUM is correct, then the ISO is fine, and I’ve never had any trouble with UnetBootin.
I’m not desperate as I have two PCs running 16.04 but it would be nice to check out the much vaunted 18.04 and would welcome suggestions.
Thank you.

Have you tried using Etcher to create the LiveUSB

or direct download links below:-



Unpack the zip file, and double-click the included etcher-electron appimage.

That worked a treat, Mark.
I had a bit of trouble at first until I discovered that one must physically remove the USB after creation and before rebooting (even though it’s not mounted). Perhaps that was the reason that UnetBootin appeared to fail. Whatever the reason, I have two possible methods of creating live USBs. Incidentally: the same two errors that I mentioned earlier appeared this time, too, although the live USB seems to be working OK (I’m writing this through it). I shall give it a thorough testing before considering installation

Although Ubuntu 18 is Gnome-based it still has the Unity-like desktop. Before I install it, I’d like to check with you, please, that I can still install the Gnome Session Flashback (Classic View) in the normal way. I don’t know anyone who likes Unity - all my elderly friends prefer Classic View, too, as it’s very straightforward.

Many thanks as usual, Mark.


It’s as simple as

sudo apt update


sudo apt install gnome-session-flashback

then choosing it from the login screen

Perfect - just as I thought.

Very many thanks for your guidance, Mark.

You’re most welcome Keith :slight_smile:

Have you considered Ubuntu MATE 18.04 … this has the MATE desktop (which is a fork of Gnome 2.x, so very much like gnome-session-flashback which is trying to ‘mimic’ Gnome 2.x) out of the box … it also appears more tweakable and has a decent file manager Caja (again a fork of Gnome’s Nautilus but without having being stripped of functionality as recent version of Nautilus have). It’s also lighter on system resources (not as light as Pepermint, but not far off).

Gnome IMHO have oversimplified the Gnome 3 UI (whilst at the same time having made it ‘heavier’), so if you prefer making it more like Gnome 2.x via flashback you’d probably be better off with MATE which was forked from Gnome 2.x in the first place.

Just a thought :wink: