Ubuntu freezes when I open Firefox

I have a Dell Lattitude 7490 with Ubuntu installed.

However, every time, today, I have attempted to use the Firefox brower it freezes completely and i need to do a hard reset.

Does anyone have any ideas what I can do to avoid this, please?



Hi Jay,

This sounds (generically) like it’s going to be an issue with your graphics driver. Looking at the specs for your machine, it may have an Intel UMD 620 card, which unfortunately seems to have a reputation for freezing under certain workloads under both on Linux and Windows.


$ lspci -k | grep -EA3 'VGA|3D|Display'

Just to check what you have and which driver is in use.

The first thing I’d say, although I know it’s an unpopular opinion, try with Chromium just to see if it makes any difference. If not, in Chromium / Settings / System, turn off hardware acceleration. Things may slow down a bit, but this feature uses parts of the graphics driver that the normal desktop may not, this may be activating the bug / issue. (Firefox also uses Hardware acceleration I think, although I’m not so sure how you turn it off…)

If you can run Chrome with or without hardware acceleration, that should give an indication of whether or not it’s the graphics card.

If it is, the answer is likely a newer version of the driver. There’s an article here that details how you can add the latest Intel drivers to your Ubuntu system.

The issue “could” of course be related to any number of different hardware issues, however only a few would in this case be “likely” and cause that particular type of result. Let is know how it goes, if it’s not the graphics driver then we might need a little more detail.

In general, most graphics cards run fine on Linux, however certain vendors had better reputations than others. Personally I tend to prefer AMD over Intel when I get a choice, typically NVidia cards have always done a good job for me.

Thanks MP,

I’ll let you know how things go later.