Ubuntu install on a new laptop [SOLVED]

I have just purchased a new laptop and I would like to install Ubuntu 12.04 onto it. I have tried Ubuntu on a wubi install on my old machine and do not want to do another wubi install. Can I do a proper install of Ubuntu and still keep windows, if so dose one interfere with the running of the other? Or is it better to remove windows and install Ubuntu 12.04? How do I go about doing it?
The laptop is this one Acer-Aspire-5755G-2678G50Bnks


You can run them side by side called duel boot. Do you have a Ubuntu install on USB or DVD rom? if yes just boot from the usb or DVD rom and follow the install instructions.

You are given the option of keeping windows and installing Ubuntu alongside, Each time you boot you are given the option to chouse which system you want to use.

Can I do a proper install of Ubuntu and still keep windows

You most certainly can :slight_smile:

if so dose one interfere with the running of the other?

Nope … as Tramlink says, you’ll be offered which OS to boot into as you turn on your laptop … Windows won’t even know Linux is there, though Linux will be able to see the Windows partition.

How do I go about doing it?

Again as tramlink says, the Ubuntu LiveCD will step you through resizing the partitions and installing Ubuntu “along side” Windows … but first things first.

As the installer is going to be manipulating the partition table … it would be a VERY good idea to make SURE you’ve created a set of Windows recovery DVD’s … any partition manipulation carries a small risk of corruption.

There should be something in the Windows menu’s to create a set of recovery disks … DO THAT FIRST.

If you can’t find the app for creating the Acer Recovery Disks … let us know.

Once you’ve created the recovery disks … my advice would be to boot to the LiveCD, select “Try Ubuntu”, then when at the desktop open a terminal (Ctrl+Alt+T) and post the output from this command:

sudo fdisk -l

so we can take a look at your current partition setup, before advising further.


see here, for how to create the “Factory Default Disk(s)” in eRecovery:

Also be aware that laptop has an nVidia Optimus graphics setup … so after installing Ubuntu, you’re gong to want to install bumblebee … see here:

But we’ll get to that later.

For now … create the recovery disks, and send the output from that command … and we’ll take it from there.

I have made the recovery disks and the output from" sudo fdisk -l " is in the screen shot.


OK … from memory, I’m not 100% sure whether the Ubuntu installer resizes the Windows partition for you, and if it doesn’t, creating a bunch of partitions (all in an extended partition) may be a little awkward to explain.

So I think it best to manually resize the Windows partition (sda3), then tell the Ubuntu installer to use the free space … the rest should be automatic.

So, boot to the LiveCD and fire up Gparted … once Gparted starts, drag the right hand side of the sda3 partition to the left (in other words shrinking the sda3 partition) leaving however much free space at the end of the drive that you want to allocate to Ubuntu (100GB is plenty, but only you can decide how much).

(DO NOT resize or move the sda1 or sda2 partitions … leave them alone)

Once you are happy you have set the Windows partition to be shrunk by 100GB leaving 100GB of free (unpartitioned) space at the end (right) of the drive … click the “Apply” button … and wait for it to finish.

When it’s finished … REBOOT into Windows, and schedule a disk check (chkdsk) … reboot back to Windows so it runs the disk check.

Once you’ve done that … come back here, and we’ll install Ubuntu 12.04 in the free space you’ve just created :slight_smile:

Any questions … ask them BEFORE hitting the “Apply” button in Gparted … no changes are made until you hit “Apply” :slight_smile:

Where do I find Gparted? and is 100gb as much as I can have?

Nope you can have as much as you like … I was just considering that Windows tends to be used for things like games which can take up a lot of room.

Anyway … 100GB for Linux seems plenty to me, specially when you consider (as far as user files … pics, docs, etc) Linux can read and write them to the Windows partition if necessary … but Windows will NOT even be able to see the Linux partition.

But partition size is up to you.

OK, where is Gparted …

Boot your LiveCD … select “Try Ubuntu” … when at the desktop, click the “Application” lens (little magnifying glass on left panel) type gparted in the search box … click the displayed Gparted icon :slight_smile:

Or I take it you can just type its name in the HUD … but I aint got 12.04 yet … so maybe someone else can help with navigation to Gparted ?

Done that. I now have a 146 Gb windows and a about 300Gb spare.
When I booted to windows it automaticaly started a windows 7 fault finding / recovery and then booted up. I have run the chkdsk and rebooted all seams ok.
I am wanting to run the grome 3 shell I think it was that I tryed last time (the pop up bar only pops up when you go to the top corner). just thourght I better say incase it maked a diffrence at some point.

OK, first see this bunch of screenshots:

(I know those screenshots say 11.04, but it will be similar for 12.04)

In particular, see the 4th pic (Allocate Drive Space):-

So boot to the LiveCD … select “Install Ubuntu” … and go through the installation routine, until you get to the “Allocate Drive Space” screen

There should be an option to “Install Ubuntu alongside Windows 7” … so when you see this:-

Select the Install Ubuntu alongside Windows 7 option (NOT the one shown as selected in the pic).

It then may ask if you want to install it in the “free space” (or Unallocated/Unpartitioned space) … that’s where you want to install it :slight_smile:

Then just carry on with the installation.

Once done … come back here, and we’ll install bumblebee, and the Gnome shell.

Is Ubuntu 12.04 stable and advisable to install or is 11.04 a better option?

11.04 reaches end of life in October … so no, I’d go with 12.04 which as an LTS version will have a full 5 years support :slight_smile: … you can always remove it later if you don’t like it.

Most people are reporting 12.04 as stable … but there are always a few cases where it isn’t at first … updates usually resolve any issues fairly quickly though.

If you ALREADY had 11.04 or 11.10 installed, I may have said wait for the 12.04.1 release before upgrading … but as it’s a a new install, I’d say go with 12.04 (or Mint 13 if you’d prefer, which is based on 12.04) :slight_smile:

I have installed Ubuntu as you said. It all works and windows is still there as well ( so I must have ticked the right box’s). I have attached a screen shot of sudo fdisk 1. Dose it look as you would expect.
The only thing I was expecting that is different is when I open the folder explorer I can see the spare space on Acer drive and there is a System reserved drive as well. What is this part? The properties of the home folder is 294Gb which is about what I expected (300Gb).
The other thing I like is it defaults to booting up in to Linux not windows if I don’t choose one in the time limit.
So far all doing well ;D ;D :slight_smile:

Yup, looks good to me, though

df -h

may give you a better idea of partition sizes.

There are actually 3 Windows partitions
1 = The system restore partition (PQSERVICE partition)
2 = the Windows boot partition
3 = the “actual” Windows partition

OK, next … to install Gnome … giving you the Gnome shell, and Gnome (Classic) desktops … open a terminal, and run:

sudo apt-get update


sudo apt-get upgrade


sudo apt-get install gnome-shell

You should now be able to change desktops at the login screen.

Do that whilst I check out the bumblebee installation procedure.


Can you post the output from:
sudo lshw -C display
be aware, that command my take a few seconds to return anything :slight_smile:

Can you also do me a favour … post it as text rather than as a screenshot … screenshots don’t help people when running a search :slight_smile: … copy and paste it from the terminal.

Hi. as requested the out put from sudo lshw -C display


mark@mark-Aspire-5755G:~$ sudo lshw -C display
[sudo] password for mark:
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:16 memory:d0000000-d0ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:2000(size=128) memory:d1000000-d107ffff
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:57 memory:d1400000-d17fffff memory:c0000000-cfffffff ioport:3000(size=64)

Mean anything to you???

Grome 3 loaded and working :slight_smile:

OK, now for Bumblebee …

Open a terminal and run:

sudo add-apt-repository ppa:bumblebee/stable


sudo add-apt-repository ppa:ubuntu-x-swat/x-updates


sudo apt-get update


sudo apt-get install bumblebee bumblebee-nvidia

When those have finished … reboot.

When rebooted … open a terminal and run:


That should run on the (lower powered but better battery life) Intel graphics card … let it run for a few lines … just to get an idea of the frames/sec rate … remember it, and close glxspheres.

Now run:

optirun glxspheres

That should run on the more powerful Nvidia graphics card … check to see if the frames/sec has markedly improved … and let me know.

I have a small problem.
I started then canceled the first command. then did it again but now I cannot type anything into the terminal after I have pressed enter on the first line.

You lost me … how did you cancel the command ? … and out of interest, why ?

And what happens if you close the terminal, reopen the terminal … and run the first command ?

I ran the first command. Read what came up about checking for the latest drivers. I decided to cancel using C to cancel as it said. That was because I thought I should run the command it gave for the drivers first. But after I canceled I thought that the commands you have given me would probability get the the latest for it anyway and tried it again. But then I could not input anything after I entered the first command. i tried closing and reopening the terminal no diffidence so I tried rebooting No diffidence.
Now wish I had not started thinking for myself and just followed what I was told to do. :-[ Sorry

Is the terminal working at all ? … or does it only lock up after the first “add-apt-repository” command ?

What happens if you open a terminal and run:

sudo apt-get update

Does that command finish without error ?

If so, what is the output from:

ls -a /etc/apt/sources.list.d

While you’re at it, please install the synaptic and ppa-purge packages:

sudo apt-get install synaptic ppa-purge

only locks up after first command.

hat happens if you open a terminal and run:
Code: [Select]

sudo apt-get update

Does that command finish without error ?

I locks up after I press enter,