Ubuntu scanner driver for Epson Stylus SX440W

In january I had a computer crash. No problem, I thought, I have a backup for everything but the driver scanner; but this I can download any time at the website where I found it 9 months ago (avasys.jp). However, on the avasys.jp website I found only a transfer notice: they had handed over the Epson scanner drivers to the Epson Download Service at the end of 2012. At the Epson Download Service I typed in the model of my copier (Stylus SX440W) and got the answer: „no scanner drivers for Linux“. I phoned the Epson Customer Service and got the answer: „Epson doesn’t support Ubuntu“.

With a Google search I obtained the correct data package – deb package (iscan-data_1.13.0-1_all.deb).
However, the core package offered (iscan_2.28.1-3.ltdl7_i386.deb) is not the right one for me.

I need the core package – deb 64 bit package [libltdl7] for Ubuntu 8.10 or later: iscan_2.28.1-3.ltdl7_amd64.deb

Do you know anyone who could send me a copy of this core package?
My e-mail address is saller.jk@alice.it

Thanks for your help and best regards

Hi Hanskarl, and welcome to the forum :slight_smile:

I’m not sure who you talked to at Epson, but he needs sacking … the Linux drivers ARE on the Epson website including .deb files that work in Ubuntu. ???

That said, they are impossible to link to directly.

So go here:

and in the search box enter:
and hit enter.

On the next page, select
Scanner Driver > Core Package/Data Package
and hit the Download button.

On the next page, cliick the Accept button.

A list of drivers will appear underneth the Accept button including:
Click the Download button.

Hello Mark,

thanks for your your help. Following your advice it was easy to get the driver I needed.
I already worked with it several hours and enjoyed it.

best regards

You’re most welcome :slight_smile:


I got the same problem Mark did. However When I download the suggested file I can’t seem to install it.
Shall I choose “Save” or “open with…”?
Either way when I click on the file a new window opens with “Iscan” and states the the file is not supported.

What to do?

/Thankfull for help

Hi Juslina, and welcome to the forum :slight_smile:

Can you open a terminal (Ctrl+Alt+T) and run this command:

uname -a

then post what is returned in the terminal back here.

I take it you already have the printer working, so just need the scanner drivers ?

How will the printer/scanner be connected … USB or wireless ?

I’m sorry … call me stupid I don’t follow.

I Have the terminal open and have tried to write the full address to the file.
“/home/juslina/hämtningar/sx440” (I’ve renamned the file)
The answer is " The file or folder does not exist"

I’ve tried writing “cd /home/juslina/hämtningar/sx440”. But I get the same result.

I tried “sudo dpkg -i sx440.deb”.
I got to write my password and then I got the message. Fault while handeling the file. Can’t reache the archive. The file or folder does not excist.

No. I have not got the printer to work with this computer. Only others. It will be used via wifi.

I can’t tell you which files to get, and what to do with them til I know which kernel you’re running.

Hit these 3 keys at the same time Ctrl+Alt+T … a terminal should open.

in the terminal type:-

uname -a

and hit the enter key

then post back here what is returned form that command.

Ok, now I got it. :slight_smile:

Linux juslina-HP-Compaq-6715s-GR653ET-AK8 3.5.0-25-generic #39-Ubuntu SMP Mon Feb 25 19:02:34 UTC 2013 i686 athlon i 686 GNU/Linux

As long as you have an Epson Stylus SX440W …

OK, download these 3 files, and install them in this order.




You should be able to install them by just double-clicking them (one at a time) … but be sure to install them in the right order.

Once you’ve installed them … check if your printer and scanner work when connected by USB

Then we’ll move on to wireless if necessary.