Ubuntu took a crap on me again :(

Sorry, dinners just arrived… I’ll take a looksee in a bit :wink:

Cool ::slight_smile:

I can’t see anything that jumps out in there… you’re either going to have to go through the logs yourself, or email them ALL to me.

Have you tried installing kernel 2.6.39-0 ? … don’t panic, it won’t remove 2.6.28-8 … but it will add another kernel which will generate another initrd image (initrd.img-2.6.39-0-generic) … giving you a new option in the GRUB menu to boot 2.6.39.

If selecting 2.6.39 in the GRUB menu allows your system to boot … then you can always remove and reinstall 2.6.38 if you wish.

yeah i’ve tried, but the first command doesn’t seem to be working.

sudo add-apt-repository ppa:kernel-ppa/ppa [sudo] password for bally: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 800AA67AE64A6D9E1859C561A8267963484B044F gpg: requesting key 484B044F from hkp server keyserver.ubuntu.com gpg: key 484B044F: "Launchpad PPA for Ubuntu Kernel PPA" not changed gpg: Total number processed: 1 gpg: unchanged: 1


sudo apt-get update

Then what is the output from:

apt-cache showpkg linux-image


uname -r

Fire up Synaptic… go to Settings>Reositories>Other Software (tab)

look for -
http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu natty main
and if exists
http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu natty main (Source Code)
and take the ticks out of their boxes (to disable them).

Click close, and close Synaptic.

Now run:

sudo apt-get update

and if you get no errors:

sudo apt-get upgrade

Hopefully, that will add the 2.6.38-10 kernel which is an upgrade to the one you have anyway… when it’s done, reboot.

When rebooted, run:

uname -r

and paste the output.

I did exactly as you said, but it still hangs at the “UBUNTU” screen.

output from “uname -f”


OK, doesn’t look like 2.6.38-10 got installed… try running:

sudo apt-get install linux-headers-2.6.38-10 linux-headers-2.6.38-10-generic linux-image-2.6.38-10-generic  --fix-missing

When finished, reboot … If it doesn’t boot, reboot to the GRUB menu, and select the 2.6.38-8 (failsafe) to boot.

I know I’ve said it before, but does the word BACKUP mean anything to you :wink:

It didn’t boot :frowning:

Short of emailing me ALL your log files, I don’t know what to suggest.

Didn’t the screen give you a clue when you got rid of the quiet splash kernel boot parameters ?

Ahhh, just remembered you were playing with multiple monitors recently weren’t you ?.. if you select a normal boot at the GRUB menu… is the system locking up, or is it just not displaying to screen ? (ie. is this an X server issue)

Things to check -

  1. Is the hard drive activity light still flashing ?

  2. What happens if you wait for a minute or 2, then select Ctrl+Alt+F3 … does it go into a console ?

  3. What happens if you rename /etc/X11/xorg.conf to something else … then reboot.

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

I’m betting on 3 … I’ll keep my fingers crossed :wink:

It wouldn’t have been 3 as I had disconnected the monitor because I’ve been at my cousins most of the week, there. Just back home now, so I’ve access to my LiveCD now (if needed.) The harddrive light doesn’t flash, just stays still for a couple of seconds then you get the odd flash after 5 minutes or so. I also realised that, after updating the kernel… Failsafe is actually taking longer to login and get everything started up, where as the old default kernel was actually really quick.

Have you tried 3 ? … ad as far as I’m aware, 2.6.38-10 is now the default kernel (though I could be wrong, I’m on 2.6.39), but there should be nothing stopping you using 2.6.38-8 (it should still be there in the GRUB menu) … or removing 2.6.38-10 (as long as 2.6.38-8 is still there).

Other than that, you’ll have to email me all your logs.

What happened when you removed quiet splash from the kernel line of GRUB… did you see the boot process scrolling by, and how far did it get ?

Without some kind of error to work with, or a better description of what is happening, this will be hard to diagnose.

Does SMART mention anything about bad blocks on the hard drive ?

I’ll tell you what, I’ll take a video and upload it to YT. The old kernel isn’t there anymore, it’s only the new one :confused: When I removed quiet splash, it just gave me the same problem with all the other normals boots. I haven’t tried SMART yet, I’ll tell you in a mo.

sudo apt-get install linux-headers-2.6.38-8 linux-headers-2.6.38-8-generic linux-image-2.6.38-8-generic  --fix-missing

Should put you back to 2.6.38-8, if you wish.

Here’s the video. Maybe you’ll have a better understanding now. It just won’t budge after “Checking Battery State [OK].” last night I left the laptop on at that stage for a good 2 hours and it still never budged, just hangs and hangs.

If you wait a min or 2 then hit Ctrl+Alt+F1 does it drop you to a black screen with white writing with a login prompt ?

If so, what happens if you log in with your username and password, then enter:

sudo service gdm restart


and most importantly… have you tried 3 yet ← important because most people who have the same symptons are reporting an issue with the nvidia drivers and Xorg.

see post #9 here:

[b]Recovery mode still works[/b], i can even ssh after the hang,

Which version of the nVidia drivers are you using ?

Is there anything useful in the Xorg.0.log ?

Seems that there is definitely a problem between the drivers & Xorg. I just renamed the old Xorg, restarted and it booted up fine. To double check, I shut down completely, unpluged the power cord, took out the battery, waited 30 secs, put it all back together and then booted up again. Worked perfect, only thing I lost was my wallpaper, but that’s not a big deal, lol.


Your options are

a) generate a new xorg.conf
b) try another driver version, and generate a new xorg.conf
c) leave it as is :wink:

So it turns out, Ubuntu didn’t take a crap on you… the nVidia drivers did :wink:


Next time it might be a good idea to take a backup of a working xorg.conf … so you can easily replace it if it plays up again :slight_smile:

Hahaha, oh well. Yeah, I’ve generated a new config, but I’ll go back it up just now that way I won’t have these problems again. But how can I sort these very slow start up times? Because once I’ve logged in, it takes Ubuntu about 1min to actually load Unity & everything else and it only seem to be with the new kernel.