Ubuntu took a crap on me again :(

I’ll cut a long story short… I was watching a YT video, forget to plug in my charger for the laptop, laptop decided it wanted to go into sleep mode, had to wait on it letting it goto sleep. I powered it up again, and boom! blank black screen. Ever since then I haven’t been able to boot into Ubuntu, it just hangs at the Ubuntu bootloader screen. Currently booted into Failsafe Low Graphics Mode. Need to get this sorted ASAP :frowning:

You can force fsck (file system check) to run at next bootup by opening a terminal and entering:

sudo touch /forcefsck

hitting enter, and your password.

Then rebooting.

Does your PC normally resume from suspend OK ?

Of course you need it fixed ASAP… doesn’t everyone need their PC fixing yesterday ? :wink:

Mark I’ve ran filesystem check like 6/7 times, and nothing is working. It’ll either hang at the Ubuntu bootloader, or at the stupid “* Checking Battery State [OK]” bit. Yes usually resumes with no problems at all, kind of weird tbh.

if it hangs at the bootloader, how are you able to boot failsafe mode… I’m just trying to get a handle on where it’s locking up.

I know when my system (desktop) is accidentally put into suspend from the keyboard, it fails to resume… I have to unplug the system, then replug it before it will start at all.

With the PC switched OFF… try removing the battery and the power lead, then hit the ON switch (obviously it won’t start but this will drain any residual power))… now put the battery back in and connect the power… and see what happens when you switch it on.

Well I’m boot up into failsafe because I manage to get GRUB’s key command thingy to bring up the recovery mode option. Started that up, and ran failsafe from there. I’ve also tried using the “Repair broken packages” option but that didn’t work either… i’m scared to turn off the laptop incase it won’t boot-up at all xD

Just tried this, still having the same problem :frowning:

Have you got more than one kernel listed in GRUB, and can you boot from any of the others ?

I have only one kernel, and one with recovery mode :confused: That’s all I have atm.

Hmm… this is pretty much the reason why it’s always a good idea to keep the old kernels :wink:

If you can boot to failsafe low graphics mode… you could always try adding the 2.6.39 kernel, and see if it will boot to that.

Instructions here:

But that’s up to you.

Can you describe exactly where it locks up ?

Have you fired up the log file viewer, and seen if there are any clues in the boot.log ?

Well I’ll have to get this working >.< So I’ll have to try something, and yeah I have. Didn’t find nothing :frowning: but I’m not really sure what I’m looking for.

Attach your boot.log and bootstrap.log … or email em to me.

But I can see no harm in installing the 2.6.39 kernel … that should give you the option which kernel to boot.

But as always back up anything you can’t afford to loose first :wink:

Your call.


See next response first.[/b]

Or even better… try this first:

use the GRUB2 part.

at the very least, removing “quiet splash” may give you a clue where it’s locking up… as it will now scroll through the load sequence.

I have a feeling it is attempting to load a corrupt hibernate state… I don’t think it is actually a kernel issue, as failsafe uses the same kernel.

What is the make/model of your laptop/netbook ?

Acer Aspire 6920, and I think it may be trying to start one of those as well, because I can get in and out of failsafe easily. ::slight_smile:

EDIT: Attached the boot & bootstrap files :slight_smile:

Have you tried editing the kernel boot parameters as above ?

ie. replaced
quiet spalsh

and seen if it will boot ?

it won’t goto the editing bit if i press e, just forces a filesystem check :frowning: i’m currently having to boot into failsafe just to reply atm.

Can you get to the GRUB menu (by holding shift at bootup) ?

if so, highlight the top (not failsafe) entry… and press the “E” key … you should end up at a screen like this:


then change quiet splash to no_console_suspend

then hit Ctrl+X to continue booting.

If that fails, can you attach the dmesg log and the output from:

cat /proc/cmdline
cat /etc/initramfs-tools/conf.d/resume


you might want to take a look at this:

I’ve tried the “no_console_suspend” thing, and it failed. I’ve attached the dmesg file, and the output for the terminal commands are;

Dunno if it’s just me, but I can’t see any attachment ???

My bad, I added it to another post on the first page by accident, try again now.