Unable to change ownership of files/folders

As the Subject header says…
I have tried under sudo, changing ownership of the above to me ‘pooky2483’ but it stays at ‘root’.
I’ve tried chown and chmod, still don’t know why it won’t give me ownership of my own files?

ou’re bieng far too vague, what exact chown command are you trying ?

You need to give us an example, or at least tell us what you’re trying to change, and what the output was when you tried.

In dolphin, after navigating to the drive ‘EXT-02’ showing the folders which have the files inside, I press ‘F4’ which opens up a small ‘terminal’ window at the bottom of dolphin, I type;

chown pooky2483 /media/EXT-01

a) If “pooky2483” doesn’t own the files/directories, then “pooky2483” can’t change any permissions for them … they’ll need to be changed with elevated privileges (sudo) :wink:

b) you’ll also most likely want to change the group too.

c) you’ll also most likely want to recursively change ownership of everything inside that directory too.

if that’s the case:

sudo chown -R pooky2483:pooky2483 /media/EXT-01

That will change owner:group of the /media/EXT-01 directory and everything contained in it … if that’s not what you want to do, STOP, and explain what it is you’re trying to do.

That’s exactly what I want to do but after entering the command, the files and folders are still under ‘root’!

How is /media/EXT-01 formatted? Let me guess, FAT32 or NTFS?

Yep, it’s NTFS SeZo.

NTFS should stand for Not The F****** Same :wink:

Don’t tell me NTFS & FAT are going to be a problem?


No, but Windows file systems don’t support “permissions”.

What exactly are you trying to do ?

In Kubuntu I can change the picture of a folder to a specific image of my choice.
I have managed to do it on some folders but on others, in the same sub folder, it doesn’t work!

…And sometimes it (the system) won’t let me delete files/folders.

I take it EXT-01 is an external HDD ?

How is it being mounted ?

It’s mounted in fstab at boot.

Can you post the contents of fstab

My fstab;

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sdc5 during installation

UUID=80841ba0-ba90-4a33-8b74-748b0b13dd8d / ext4 errors=remount-ro 0 1

swap was on /dev/sda2 during installation

UUID=03b9f227-9f5c-4abc-a50b-74ecc1590f44 none swap sw 0 0

swap was on /dev/sdc2 during installation

UUID=718377f7-8759-44ad-888d-e0fb3f91c5e4 none swap sw 0 0

UUID=9472C6BD72C6A37A /media/EXT-01 ntfs-3g defaults,windows_names,locale=en_GB.utf8 0 0
UUID=3E9E5F1B0F3E4B8D /media/EXT-02 ntfs-3g defaults,windows_names,locale=en_GB.utf8 0 0

UUID=d5e1db61-b980-4624-801c-e0546b288b8f /media/Drive1/ ext4 defaults 0 0
UUID=1e72a175-851f-43c3-a251-241d0e3800a7 /media/Drive3/ ext4 defaults 0 0

/dev/sdb1: LABEL=“Drive3” UUID=“1e72a175-851f-43c3-a251-241d0e3800a7” TYPE=“ext4”

/dev/sdc1: LABEL=“Ubuntu 12.04TLS” UUID=“201d2f3e-f865-4912-b852-99b5b24f3457” TYPE=“ext4”

/dev/sdc2: UUID=“718377f7-8759-44ad-888d-e0fb3f91c5e4” TYPE=“swap”

/dev/sdc5: LABEL=“Ubuntu 12.04LTS” UUID=“bcb8b27e-dd9e-4c09-a259-48cf4f937c9e” TYPE=“ext4”

/dev/sdc6: LABEL=“Manjaro” UUID=“954eee59-c8c3-465e-adb6-892a44e673be” TYPE=“ext4”

/dev/sdd1: LABEL=“Drive1” UUID=“d5e1db61-b980-4624-801c-e0546b288b8f” TYPE=“ext4”

/dev/sde1: LABEL=“EXT-01” UUID=“9472C6BD72C6A37A” TYPE=“ntfs”

/dev/sdf1: LABEL=“EXT-02” UUID=“3E9E5F1B0F3E4B8D” TYPE=“ntfs”

Ttry changing

UUID=9472C6BD72C6A37A  /media/EXT-01  ntfs-3g  defaults,windows_names,locale=en_GB.utf8  0 0
UUID=3E9E5F1B0F3E4B8D  /media/EXT-02  ntfs-3g  defaults,windows_names,locale=en_GB.utf8  0 0


UUID=9472C6BD72C6A37A  /media/EXT-01  ntfs-3g  defaults,uid=1000,gid=1000,umask=027,windows_names,locale=en_GB.utf8  0 0
UUID=3E9E5F1B0F3E4B8D  /media/EXT-02  ntfs-3g  defaults,uid=1000,gid=1000,umask=027,windows_names,locale=en_GB.utf8  0 0

SAVE fstab and REBOOT.

Nos see if you own the files.

That worked Mark, but I still can’t change the folder picture;
Right click on the specific folder then select ‘Proprties’ then left click on the folder icon in the information box, then ‘Other Icons’ then ‘Browse’… select the specific picture you want to be displayed ‘inside’ the folder. e.g. a picture depicting a certain TV Series.