Unable to install driver usb wifi adapter Realtek RTL8188EUS

Hello World!

As some of you might predict based on my welcome words I’m quite new guy in Linux trying to set things up. I just installed my new Linux Kali and bought several wifi adapters of the same kind - Realtek RTL8188EUS . I’ve also received a CD with drivers included also to linux however it doesn’t work as expected. When I run this install.sh all at the end there’s an error

Authentication requested [root] for make driver:
./install.sh: 48: [: unexpected operator
cp: target `Driver/driver/rtl8188EUS_rtl8189ES_linux_v4.1.2_4787.20120803/include/autoconf.h’ is not a directory
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/3.14-kali1-amd64/build M=/root/Desktop/linux android driver/Linux_Android Driver/driver/rtl8188EUS_rtl8189ES_linux_v4.1.2_4787.20120803 modules
make: *** /lib/modules/3.14-kali1-amd64/build: No such file or directory. Stop.
make: *** [modules] Error 2
Compile make driver error: 2
Please check error Mesg

This is a virtual machine run on vmWare workstation.

I’ve seen on this forum that some of you guys successfully helped one similar greenhorn like it’s me now with almost the same issue by entering command

apt-get install linux-headers-$(uname -r)

however when I run this specific command the output is not so successful as in his case. I’ve got this output:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package linux-headers-3.14-kali1-amd64
E: Couldn’t find any package by regex ‘linux-headers-3.14-kali1-amd64’

Is there any chance there’s someone able to help me with this thing? I’m quite lost - so is google obviously and I can’t help myself.

I appreciate any assistance in advance

Thanks boys. And girls of course if any.

Have you got an active internet connection (via ethernet cable) ?

If so, run a full system update (to pull in the latest kernel)

Then reboot the VM (this is important, to load any new kernel that was downloaded during the system update)

Then try that command again.


thanks for your reply.

I performed sw update which was recommended by system itself and also I run a command

apt-get dist-upgrade

I’m not sure this is a way how to upgrade kernel to latest available version. My current version is

Unfortunately the issue is still not solved :confused: . Is there any other way to upgrade kernel or should i try something else? :slight_smile:

Thanks in advance

What do you get from:

sudo apt-get update && apt-cache search headers

Might need to put that on pastebin, if the output is too long

Hello :slight_smile:

So I run this command as requested

sudo apt-get update && apt-cache search headers

and the output is

Hit http://security.kali.org kali/updates Release.gpg
Hit http://security.kali.org kali/updates Release
Hit http://security.kali.org kali/updates/main amd64 Packages
Hit http://security.kali.org kali/updates/contrib amd64 Packages
Hit http://security.kali.org kali/updates/non-free amd64 Packages
Ign http://security.kali.org kali/updates/contrib Translation-en_US
Ign http://security.kali.org kali/updates/contrib Translation-en
Ign http://security.kali.org kali/updates/main Translation-en_US
Ign http://security.kali.org kali/updates/main Translation-en
Ign http://security.kali.org kali/updates/non-free Translation-en_US
Ign http://security.kali.org kali/updates/non-free Translation-en
Reading package lists… Done
apache2-prefork-dev - Apache development headers - non-threaded MPM
apache2-threaded-dev - Apache development headers - threaded MPM
bash-builtins - Bash loadable builtins - headers & examples
kfreebsd-headers-9-amd64 - header files for kernel of FreeBSD 9 (meta-package)
kfreebsd-headers-9.0-2 - Common architecture-specific header files for kernel of FreeBSD 9.0
kfreebsd-headers-9.0-2-amd64 - header files for kernel of FreeBSD 9.0
libbind-dev - Static Libraries and Headers used by BIND
libdbus-1-dev - simple interprocess messaging system (development headers)
libdmx-dev - X11 Distributed Multihead extension library (development headers)
libfs-dev - X11 Font Services library (development headers)
libgimp2.0-dev - Headers and other files for compiling plugins for GIMP
libgraphviz-dev - graphviz libs and headers against which to build applications
libkrb5-dev - Headers and development libraries for MIT Kerberos
libx11-dev - X11 client-side library (development headers)
libx11-xcb-dev - Xlib/XCB interface library (development headers)
libxen-dev - Public headers and libs for Xen
libxext-dev - X11 miscellaneous extensions library (development headers)
libxfixes-dev - X11 miscellaneous ‘fixes’ extension library (development headers)
libxfont-dev - X11 font rasterisation library (development headers)
libxi-dev - X11 Input extension library (development headers)
libxinerama-dev - X11 Xinerama extension library (development headers)
libxrandr-dev - X11 RandR extension library (development headers)
libxres-dev - X11 Resource extension library (development headers)
libxt-dev - X11 toolkit intrinsics library (development headers)
libxtst-dev - X11 Record extension library (development headers)
libxv-dev - X11 Video extension library (development headers)
libxvmc-dev - X11 Video extension library (development headers)
libxxf86dga-dev - X11 Direct Graphics Access extension library (development headers)
libxxf86vm-dev - X11 XFree86 video mode extension library (development headers)
libstdc++6-4.7-dev - GNU Standard C++ Library v3 (development files)
x11proto-input-dev - X11 Input extension wire protocol
libclang-common-dev - clang library - Common development package
python-requests - elegant and simple HTTP library for Python, built for human beings
libxdmcp-dev - X11 authorisation library (development headers)
libstdc++6-4.6-dev - GNU Standard C++ Library v3 (development files)
llvm-3.0-dev - Low-Level Virtual Machine (LLVM), libraries and headers
linux-libc-dev - Linux support headers for userspace development
x11proto-xext-dev - X11 various extension wire protocol
libhttp-cookies-perl - HTTP cookie jars
testdisk - Partition scanner and disk recovery tool
libfontconfig1-dev - generic font configuration library - development
libsm-dev - X11 Session Management library (development headers)
libice-dev - X11 Inter-Client Exchange library (development headers)
x11proto-fixes-dev - X11 Fixes extension wire protocol
libffi-dev - Foreign Function Interface library (development files)
x11proto-render-dev - X11 Render extension wire protocol
libhttp-message-perl - perl interface to HTTP style messages
tcpdump - command-line network traffic analyzer
x11proto-randr-dev - X11 RandR extension wire protocol
x11proto-kb-dev - X11 XKB extension wire protocol
x11proto-xinerama-dev - X11 Xinerama extension wire protocol
ruby-simple-oauth - Simply builds and verifies OAuth headers
texlive-latex-base - TeX Live: Basic LaTeX packages
libxdamage-dev - X11 damaged region extension library (development headers)
libopenexr6 - runtime files for the OpenEXR image library
binwalk - A firmware analysis tool
texlive-font-utils - TeX Live: Graphics and font utilities
libxau-dev - X11 authorisation library (development headers)
texlive-latex-extra - TeX Live: LaTeX supplementary packages
foremost - forensic program to recover lost files
insserv - boot sequence organizer using LSB init.d script dependency information
pev - text-based tool to analyze PE files
x11proto-core-dev - X11 core wire protocol and auxiliary headers
x11proto-damage-dev - X11 Damage extension wire protocol
x11proto-composite-dev - X11 Composite extension wire protocol
libpcre3-dev - Perl 5 Compatible Regular Expression Library - development files
libfreetype6-dev - FreeType 2 font engine, development files
libxcomposite-dev - X11 Composite extension library (development headers)

Hopefully this is what you’ve been looking for :smiley: Btw guys I’m so amazed you’re able to help me troubleshoot this… I hope I’ll reach this level once…

Thanks in advance.

The output from your “update” seems very short …the other guy you mentioned in your first posting had
Index of /kali kali/main
in his sources, where you only appear to have the security repo enabled.

Can you post the contents of:

gedit /etc/apt/sources.list

it was not proceeded

bash: gedit: command not found

anything I type wrong?

“root@kali:/# gedit /etc/apt/sources.list”


nano /etc/apt/sources.list

This is what appears after that

deb cdrom:[Debian GNU/Linux 7.0 Kali - Official Snapshot amd64 LIVE/INSTALL$

#deb cdrom:[Debian GNU/Linux 7.0 Kali - Official Snapshot amd64 LIVE/INSTALL $

Security updates

deb http://security.kali.org/kali-security kali/updates main contrib non-free

Any chance someone has an idea what to do about it? Would it help to have other distribution of linux?

OK, the problem here is that your sources.list should contain 2 entries:-

deb Index of /kali kali main contrib non-free
deb http://security.kali.org/kali-security kali/updates main contrib non-free

See here:

Now the next problem is going to be adding the missing entry to your sources.list file with nano (as kali doesn’t appear to have a GUI text editor by default).

(at a root prompt ‘#’) Run:

nano /etc/apt/sources.list

use the down arrow key until the flashing cursor is at the very bottom of the file, and add a NEW LINE that reads:

deb Index of /kali kali main contrib non-free

Now hit Ctrl+X to exit

then hit Y to save modified buffer

Then hit Enter to let it overwrite /etc/apt/sources.list

You should now be back at an # prompt

now run:

apt-get update


apt-get install linux-headers-$(uname -r)

did the headers install this time ?

headers are now installed! :smiley:

I still had an issue with this stupid driver however it was SOLVED by finding another topic over here so just to be clear if anyone will be dealing the same issue it’s here


I’d like to say one BIG thanks to all of you guys. I really appreciate your honest help. You guys totally ROCK! :smiley:

Thank you very much again :slight_smile:

You’re most welcome :slight_smile: