Updating Golf Rangefinder - Abandoned

Hi All - something a bit different, this time!

I have a SkyCaddie Gimme rangefinder that needs to be re-registered every 12 months. In order to do so, I have to download a program (from SkyGolf) called CxSetup.exe. But, when downloaded, the file has changed to CaddieSync.dmg or CaddieSyncExpress.dmg.

I would have expected to be able to run a .exe file in Wine but have no idea what to do with a .dmg file. It seems a .dmg file is a Mac application? This software needs to be installed to allow the device to ‘talk’ to SkyCaddie and therefore update it.

Is there any way to get this to install in Mint 17, run it in Wine (or similar) or will I need to beg a friend with a Windows pc to do it for me? (I’d rather not, naturally, if I can avoid it!)

Any advice on this one would be most welcome!



a .dmg is an OS X installer … for some reason it’s assuming you’re using Apple OS X instead of Windows

Try using a user agent switcher in your web browser so your browser reports to the site that you’re running Windows.


Or just use this direct download link for the Windows version:

Hi Mark - thanks for the info!

The .exe file downloaded ok and installed the program straight away through Wine. Clicking it’s icon took me straight to SkyCaddie’s site and prompted me to ‘Sync’ the device, so that part works ok. However, when I attached the device and followed the instructions, the device wasn’t found and the ‘Sync’ failed. It’s impossible to know whether the problem lies at this end or at the website - but I don’t expect you to be able to answer that one! But…

Normally, if I connect a camera or phone via usb, Mint will ‘see’ it immediately and ask what to do. Could the rangefinder be expected to act similarly? I looked in ‘Computer/Media’ where devices are usually listed, but nothing showed. Is there a way to manually mount the device, or to find out if the system recognises it? I suspect the issue is at my end… it may be a device driver problem, perhaps, but without being able to update it online I’m snookered!

Many thanks for the help so far.


IIRC, USB in WINE is a pain in the ar*e

Maybe you could create a minimal Windows VM … do your update, then delete (or archive) the VM until next year

No worries - looks like I’ll have to swallow my pride and beg a go on a mate’s lappy! ::slight_smile: I have managed to get on their website and do an update of my status there but the device itself still shows a warning every time it’s switched on and I’m not sure if it’s time-limited and will cease to work if not updated.

Thanks for the help, once again.


Why not download one of the digitalriver versions of Win7

that gives you 30 days usage before it has to be registered (or reinstalled for another 30 days usage)

this is a torrent that will get you the Win7 SP1 32bit (previously issued by Microsoft themselves via msft.digitalrivercontent.net)
you can check the MD5sum online or from the mirror above

this is a torrent that will get you the Win7 SP1 64bit (previously issued by Microsoft themselves via msft.digitalrivercontent.net)
you can check the MD5sum online or from the mirror above.

If you have a Win7 home premium sticker on your PC, these can also be used for a legitimate installation and activated via phone.

Thanks Mark - I’ll give it a go with the 30 day version - if you wouldn’t mind running me through the setting up of a VM etc as I’ve never done one before?

I’m downloading it now via transmission but the connection is very slow - I’ll repost when I have the .iso



a) be sure to get the 32bit version of Win7:
(unless you’re absolutely sure your PC can run 64bit VM’s)

b) which distro / version / architecture are we talking about again ?


it is VERY slow - is there a way to speed things up

not really … it depends on how many people are sharing it at any particular moment, as microsoft stopped hosting the files so theere’s no direct download links any more.

Hopefully it’ll speed up a bit when some Americans come online later.

Mint 17, OK I’ll post instructions for installing Virtualbox a bit later … do NOT attempt to install the version from the repos, that’s the OSS version and doesn’t have USB passthrough (which you need).

Mint 17, OK I'll post instructions for installing Virtualbox a bit later .. do NOT attempt to install the version from the repos, that's the OSS version and doesn't have USB passthrough (which you need).
I find that interesting.Running Win XP in Virtualbox on Mint 17.1 (from the repos) and had no trouble with attached USB disks. Perhaps it changedsince you last tried it?

As for the Win(X) you can still download them for free (90 day limitation) to run in Virtualbox.Instructions are here..

Quite possibly … it used to actually be called sommat like virtualbox-oss in the repos, now it isn’t.

OK, we’ll try the repo version first … cheers SeZo

also for the info about the VM images … sommat else I didn’t know :-[

Probably still a good idea to download the digitalriver ISO’s whist they’re still available … microsoft ma not leave those MV images up forever, they’ve already taken down the digitalriver content, and you can be fairly certain there’ll be a takedown notice for that torrent mirror eventually … so I reckon it’s a good idea to get em whilst you can, particularly if you have a legit key, or regularly fix other people windows PC’s and need legit original installation media that can be registered with their key.

Mark, sorry to A) Hijack this, B) Ask a question about Microsoft on a Linux forum, but…

Do you know if you can use an OEM product key (i.e. the one on my pre-installed laptop) with this media? I’m currently in a big hole with my old laptop following a botched recovery attempt, I can’t even boot a Linux liveCD on it atm :frowning:

@ chemicalfan

YES you can use an OEM key (the one on the sticker on your PC) with a digitalriver ISO … you’ll then (after installation) have to phone microsoft to activate it by following the instructions here:

at least that’s always worked for me.

Just be sure to use the correct Win7 version … ie don’t install the digitalriver Win7 Business/Ultimate 64bit if your key is for Win7 Home Premium 32bit

Activate using the telephone

If Windows isn’t able to activate online, you’ll have the option to activate Windows 7 using an automated phone system.

  1. Open Windows Activation by clicking the Start button Picture of the Start button, right-clicking Computer, clicking Properties, and then clicking Activate Windows now.‌

  2. Click Show me other ways to activate.

  3. ype your Windows 7 product key, and then click Next.

  4. Click Use the automated phone system. Administrator permission required If you’re prompted for an administrator password or confirmation, type the password or provide confirmation.

  5. Click the location nearest you from the drop-down list, and then click Next.

  6. Call one of the available phone numbers listed. An automated system will guide you through the activation process.

  7. When prompted, enter the installation ID that’s listed on your screen into your phone’s keypad.

  8. Write down the confirmation ID that the phone system gives you.

  9. Type the confirmation ID into the space provided under Step 3 in the activation dialog, click Next, and then follow the instructions.

  10. If activation isn’t successful, stay on the line to be transferred to a customer service representative who can assist you.

Hi All - thanks for your efforts on this but there’s no need to continue any longer…

All my attempts to download the .iso files failed due to the extremely slow speeds so I’ve given up on it. Also, I don’t have an activation key to activate!

Yesterday, I was passing the retailer’s where I bought the rangefinder and dropped it in on the off-chance they could sort it and they did, for free - in 2 minutes!

I hadn’t realised it would involve a huge amount of hassle to set up a program that I only need for 2 minutes every 12 months, so practicality overrode pride! ::slight_smile:

Thanks again for the help and I’m sure the advice will be useful to others wishing to set up a VM. :wink:



Not a problem mate … but can you please edit the FIRST posting in this topic and change

Subject: Updating Golf Rangefinder (ABANDONED)

Thanks in advance :wink:

Done as requested



Thanks Rich :slight_smile: