Upgrade from Mint 18.3 to 21.1 breaks WiFi (Atheros AR93xx Network Adapter)


I’ve recently upgraded to Linux Mint 21.1 (Kernel: 5.15.0-56-generic) after using Mint 18.3 on the same hardware for several years. However, I now have a recurring problem where nearby WiFi networks disappear (i.e. are not shown in Network Settings) after working as normal for 4-8 hours. I don’t know what’s causing this; the WiFi connections are visible (and work as normal) on other devices. Note: I have an antenna-type WiFi card slotted into my PC (not a built-in card) with separate 2.4Ghz and 5Ghz channels.

I can get the network back (and use WiFi as normal) by switching the power off and on the router. The WiFi connection works as normal for another 5-8 hours and then disappears again (“state: down” in inxi).

Has anyone seen this before? Many thanks if you are able to help.


Wifi card: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01)
Driver: ath9k

Hi emac
Welcome to the forum, from what your describing and if this problem only started immediately after upgrading to Mint 21, it might be an IP conflict, try setting a static ip address in network manager also set ipv6 to ignored, bear in mind once you do that you will have to reboot the computer for the changes to take effect, if you’re unsure how to do that post back and either myself or someone will talk you through it

Good luck

Oh don’t remind me, I had a similar problem. When I first started using Linux it was with Mint 19, and everything was ok. Then at some point I upgraded to Mint 21, oh dear! I was suffering from losing wifi, and also had a couple of other issues which I hadn’t had before.

I also found the same issues arose in Ubuntu and other Ubuntu based distros. If you do a search on something like “Ubuntu randomly losing internet connection”, you’ll see quite a lot of other people have had similar problems.

I tried a few of the suggestions for fixes but none of them worked. In the end I abandoned Mint and moved on to MX, which I’ve been using ever since, and have never had any of these issues.

Thanks for the responses, much appreciated. Also, apologies for delay, I was away.

Strangely, I’ve now lost the 5GHz network; it’s not showing in WiFi settings after restarting the router but I can still use the 2.4Ghz network (which I really don’t want to as it sometimes has other connection issues). Any idea how I can scan and check for other available networks? I assume they should just be visible in the WiFi network menu? I ideally want to set a static ip address on the 5GHz network and use this network only.

I tried something else too: as my router can host two WiFi networks simultaneously, I’ve enabled the second network with the intention of using it for this PC only (and thus avoid any IP address conflicts since this would be the only device on it), but the 2nd network is also not showing as an option in WiFi settings… Note: I can see all three networks on my mobile phone (WiFi 1: 2.4 GHz & 5GHz, and WiFi 2: 5GHz).

I’ve switched off IPv6 as suggested and tried to set a static ip address using the following guide but unfortunately this resulted in no internet access after restarting. How do I know what ip address, netmask and gateway values to choose?

Thanks again,

5G penetration is typically not as good as 2.4G and some devices seem to switch bands without warning preferring a faster connection even if the signal’s not quite up to it. I’ve found a dual-band WiFi repeater plug is a pretty good solution, placed half way between the router and the device … I’ve had good results from a TP-Link N-300, £12 from Amazon … Failing that, I’ve found turning off 5G on the router also works albeit you end up with a much slower connection … fine for TV/Roku boxes, no so much fun if you’re copying files.