Upgrading HPLIP in Peppermint 3

I am about to upgrade my version of HPLIP.
The HP site invites me to choose which distro I am using and the likely choices are Ubuntu and Debian.
Which should I use? Or is there a better way?


For Peppermint 3 you’d want the version for Ubuntu 12.04 (precise pangolin).

But why are you upgrading hplip in the first place ?

Thanks, Mark.

I’m upgrading partly because it invited me to (I’m running 3.13.9 and 3.13.11 is available) and partly because the fax facility doesn’t work and I thought an upgrade might do the trick.
In practice, everything else is working fine, so I’m not desperate to change if you advise me not to bother. It is, after all, a bit of hassle to do so.


Upgarding to a version from outside the normal repo’s might screw up the hplip-gui application (if you use it).

I didn’t think of using the repos!
Upon looking, Synaptic Package Manager won’t mark the 3.13.19 version as upgradeable so I guess that the new version is not in the repos yet - is that the case?
If so then I’ll leave it for now.
Am I right in thinking that any available update will appear in the “daily” automatic updates?

Am I right in thinking that any available update will appear in the "daily" automatic updates?

Only if they add it to the repo’s

Did we ever manually install hplip previously ?

I’ve done it a couple of times - because I was too dim to think of the Package Manager!
I found it very fiddly at first but got the hang of it, but the current instructions look a bit harder, using tarballs.

Today is the only time I’ve ever needed to fax something, so I’m sure I can do without it, and everything else is working well.
So I shall leave well alone, I think, and wait for the repos to catch up.

Sorry to trouble you. But then you’re used to that!

No trouble.

What’s the output from:

dpkg -l | grep hplip

and what is the model of your printer ?

My printer is an HP Photosmart C7200 Series.
The output is:
keith@D505 ~ $ dpkg -l | grep hplip
ii hplip 3.13.9-1ubuntu0.1~ubuntu12.04.1 HP Linux Printing and Imaging System (HPLIP)
ii hplip-data 3.13.9-1ubuntu0.1~ubuntu12.04.1 HP Linux Printing and Imaging - data files
ii hplip-gui 3.13.9-1ubuntu0.1~ubuntu12.04.1 HP Linux Printing and Imaging - GUI utilities (Qt-based)

Well according to this:

the C7200 series has supported PC Fax since hplip version 2.7.9

So what makes you think it doesn’t work ?

I take it you have a modem and it’s configured to work properly ?

I thought it didn’t work because I tried it and… it didn’t work. However (and you won’t be surprised to hear this) the only time I have used it successfully was years ago when I simply connected it to a modem and operated it by pressing buttons.

But life moves on, if my intelligence hasn’t, and now that I have HPLIP and wireless connectivity I tried sending a fax assuming that I didn’t need to connect printer to modem. And that’s where I got stuck, but today I have discovered that there is more to do in the way of setting up HPLIP for fax use.

May I suggest that, since faxing is not really related to the post title, I play around for a while to see if I can solve it myself before starting a new thread?

Thanks as always for your help.