USB stick: can no longer transfer files [SOLVED]

Having successfully used a USB stick to solve a wireless driver problem yesterday, I began today to transfer my notes on that subject from the laptop to the USB stick, but failed.
Upon plugging in the stick, I am asked if I want to open the device in File Manager, to which I agreed (what else?!). The device appears not in the customary position in the list but in /media/device-name, and although I can open files in that folder, I cannot move files between the device and the laptop via the File Manager.
I can move files using terminal commands.

Your help would be appreciated.

with the USB stick plugged in, can you send the output from:

ls -l /media

Have you tried copying everything off the USB stick … formatting it (and preferably giving it a new label) … then seeing it it will work as expected ?

Terminal output:

ls -l /media
total 4
drwx------ 14 harry harry 4096 Jan 1 1970 207D-42B2

fdisk -l has no output
I can try your formatting suggestion if you would kindly advise me how to do that.


Use “Disk Utility” to format the drive as FAT32

if you’re in Peppermint 4, Disk Utility is now just called “Disks” in the Preference menu.

Another option would be to install Gparted:

sudo apt-get install gparted

Then use that to format the USB stick.

in BOTH cases, be careful to select the right drive/partition(s) … you wouldn’t want to format your hard drive now would you :wink:

Something else you could try before formatting may be to get Gparted to check the filesystem of the USB stick for errors

Just found which mentions Gparted, so was going to ask you about that.
~Oh, and I’m on Peppermint 3, if that makes a difference.

Well the reformatting went OK using the disk utility but upon un-mounting then re-inserting the stick, it still appears in /media rather than the usual listing.

It’s SUPPOSED to be mounted at /media :o

But it should still show up in the left hand column of the file manager … with a little arrow next to it to unmount

Yep, I realise it should be listed in /media but it definitely doesn’t appear in the usual place with the unmount arrow.
I have a confession to make: yesterday I unplugged the stick without un-mounting it first! Would that have screwed everything up?

with the stick plugged in, what’s the output from:

ls -a /media

and also the same output WITHOUT iit plugged in.

ls -a /media
. … pq1
(where I have changed the name)

Without (after unmounting it):
ls -a /media
. …

BTW: it may be relevant that I cannot move files by click & drag between any folders

with it plugged in, what’s the output from:

ls -al /media

ls -al /media
total 12
drwxr-xr-x 3 root root 4096 Aug 4 18:56 .
drwxr-xr-x 23 root root 4096 Aug 3 13:58 …
drwx------ 2 harry harry 4096 Jan 1 1970 pq1

If you start the file manager … what’s at the top of the left hand column ? (“Places” or “Directory Tree”)

Directory Tree

OH!!! There it is! I am soooo sorry to have troubled you.

Click where it says “Directory Tree”, and change it to “Places”

Does it now display with the arrow ?

or you can change the view with

Ctrl+6 = Places
Ctrl+7 = Directory Tree

As Reply #12 edit - yes it’s there now.
You must get fed up with people who don’t do enough exploring before bothering the Forum.

Very many thanks for your help - as usual!

Hey, it’s easy to get lost in a new desktop environment :wink: … we’ve all done it, I know I have.