Using an encryption programme in Ubuntu

When I use my work computer my files have to be encrypted (due to previous theft of iimportant files on USB). We currently use an old but effective windows programme called ‘Private file’.

I cannot get this to work under Wine so I was wondering if there is a cross platform programme that will run under linux and windows?


Also posted in Security section.

When you install Ubuntu, one of the questions is “encrypt home filesystem” … if you say “yes” to this, you don’t need to worry about encrypting specific files, the act of copying it onto your computer secures it.

I’m guessing this solves your problem (?)

But that wouldn’t allow encrypted files stored on a USB memory stick to be opened in Windows would it?.. which encryption does it use? (although this feature would be very handy for laptops etc.)

I’m guessing encryption is only needed for “mobile” media?


is supposed to be cross platform, and has installers for Linux,OSX, and Windows

The Ubuntu repos also contain a package called easycrypt, which is a frontend for truecrypt, so truecrypt must be installed first.

Other than that, you’ll need to see if there are any graphical front ends for PGP

Ok, so I have a mental block when it comes to people wanting to encrypt things on Windows … a little voice in the back of my mind says “what on earth is the point?”.

Anyway, what about this one?

Can’t say I’ve tried it, but if I’m reading it right, it’ll read Linux encrypted filesystems, and it’ll work on a USB key and on Windows …

And it even integrates into Windows explorer … (??)

Thanks for the help.

Well, I have true crypt up and running on my own and work computers, it works across Linux and Windows. The only niggle is that when I run Truecrypt in Ubuntu it wont close when I exit, it still is running in the background. This doesn’t happen in Windows. Any ideas?

is it truecrypt, or easycrypt that won’t shut down properly ?

Are you ALSO using easycrypt ?

if only truecrypt…

start truecrypt… go to Settings>Preferences>Background Task (tab)

make sure there are ticks in
TrueCrypt Background Task
Exit when there are no mounted volumes

now when you use truecrypt, make sure you click “Dismount All” volumes before unplugging your device.

I can’t get into Truecrypt as it says it is already running. I cant see it running though!

I’m only using Truecrypt. What’s Easycrypt?


Syatem>Administration>System Monitor>Processes (tab)

Right-click any listed truecrypt processes, and select Kill Process

ignore easycrypt, that caused my system to do what yours is doing… the truecrypt back end wouldn’t quit

Done, thanks. It changed to a description called ‘Zombie’ then vanished!?

All sorted. Thanks again Mark.

true crypt is great :smiley:

Yep! I am running it across Linux and windows, really good.