Using "mpack" to send files [SOLVED]

I use mpack on my T500 laptop, after a lot of initial difficulty, and now want to use it on an ASUSTeK P6-P5G41E running Ubuntu 18.04 in gnome-flashback.

The command format is mpack -s “” -a which works fine on my T500 but on the Asus the error message is “execv: No such file or directory” although the specified file-path is valid.

Any ideas would be welcome.

[EDIT] It turns out that the Mail Transfer Agent “sendmail” was not installed by default. Installing it removes the error message but the email is still not sent.
[EDIT2] Remembered that I need to set up a ssmtp.conf file in /etc/ssmtp so copied the file from my T500 and edited it for the owner of the Asus. Still no joy.
[EDIT 3] It turns out that SSMTP was not installed despite Thunderbird working well. Installing it makes mpack work OK.

Install sendmail
Install SSMTP
Create a file /etc/ssmtp/ssmtp.conf
See the second link below.

Useful links:

Providing your own solutions again eh Keith…

Nice :slight_smile:

I was a bit embarrassed about that as I ought to have persevered before launching a post. On the other hand these difficulties I’ve had seem to be common, judging by the number of posts in other forums, so if my solutions are useful to others then I don’t feel so daft.

Useful forum content never hurts :slight_smile: