Virgin doesn't like Linux?

It’s come to my attention that “Virgin Media” my broadband provider, seems to have a rather dislike for Linux. How can I prove this? Well take a look.

I have a windows 7 box & a Ubuntu 11.04 box, both running Chrome and on wireless.

Now, the windows box gives out this as a speedtest result.

However, when I use the Ubuntu box, I get this.

I tried them both on wired connections too, and this is were you have to laugh. With the windows box, I get the same result on wired as I did with wireless, yet if I connect the Ubuntu box to the router, it doesn’t even wanna connect to the net. Weird much? I know the ethernet connection works, because I use it to connect my xbox to the router, instead of buying MS’s stupid 60 buck wireless adapter. I did all of these tests literally 2cm’s away from the router.

So my question, why won’t my ubuntu box connect via wired? :confused:

This has nothing to do with Virgin liking or disliking the OS… the “main” connection is between you router and your ISP, Virgin are unaware that it is a Linux system attached… the “speed” between the router and the ISP will not be affected in any way by the OS, but the wireless speed to your router can vary wildly… as can things like the speed at which the PC handles the data and WPA encryption etc.(is the Win7 box a more powerful system?)

For a true “comparison” test, it would have to be run on the same box.

I also hope you ran this multiple times and took an average, as it will vary on the same box every time you run it… did you notice the Upload transfer rate was faster on the Linux box :wink:

As for the wired connection, it’s probably a driver issue…

Send the output from

sudo lshw -C network



Virgin are very aware that itis a Linux system attached because I phoned up to get an engineer out, because my line had a high power adjustment.

Believe it or not, the linux box is actually MUCH more powerful than the Win7 box.

Yup I took an average of each and i did notice that, but uploading is only oke if i’m uploading to vimeo, youtube or flickr. The win7 box (much less powerful than the linux box) gets on average 95-97Mbps on wireless & wired.
The linux box on the other hand, well that gets on average 35-48Mbps. So something isn’t right :frowning:

I did all these test’s right next to the router for the best possible result.

description: Ethernet interface
product: AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
vendor: Atheros Communications
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: b0
serial: 00:a0:d1:ab:4e:d1
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=ATL1E driverversion= firmware=L1e latency=0 link=no multicast=yes port=twisted pair
resources: irq:49 memory:f6000000-f603ffff ioport:3000(size=128)
description: Wireless interface
product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:08:00.0
logical name: wlan0
version: 61
serial: 00:1f:3b:54:7d:c7
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-10-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:47 memory:c2000000-c2001fff

eth0 Link encap:Ethernet HWaddr 00:a0:d1:ab:4e:d1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:2089 errors:0 dropped:0 overruns:0 frame:0
TX packets:2089 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:104403 (104.4 KB) TX bytes:104403 (104.4 KB)

wlan0 Link encap:Ethernet HWaddr 00:1f:3b:54:7d:c7
inet addr: Bcast: Mask:
inet6 addr: fe80::21f:3bff:fe54:7dc7/64 Scope:Link
RX packets:14604 errors:0 dropped:0 overruns:0 frame:0
TX packets:12207 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13599359 (13.5 MB) TX bytes:2045023 (2.0 MB)

Unless you are suggesting that the person at Virgin that you talked to immediately went and manually throttled your connection because you told him you used Linux… then their system is unaware of which OS you are running… and he couldn’t have manually throttled the connection, or it would equally affect the Windows box.

Anywho… if you are only getting 35-48Mbp on the Linux box, it could be a driver issue, or it could just be a slower (wireless G 54Mbps) card… the one on the Windows box is obviously a wireless N card… that said, I would expect even a wireless G card to easily be able to keep up with your routers download rate… so I’m guessing it’s a driver issue.

Wired seems OK, but have you left it set to “Shared to other computers” in the IPv4 tab in networkmanager, rather than “Automatic (DHCP)”… from when you used it with the PS3 ?

Try deleting the connecttion on the “Wired” tab in NetworkManager, and set up a new connection.

Lmao, how I can only imagined he did that xD He was foreign too, and I did give him some abuse after telling him I wanted to talk to a technician. Lol.

Well is there a way to find out?

I did change it back to Automatic (DHCP) when I tried connecting it to the router, but I just got error: couldn’t load page, especially when I try to goto the routers own settings page. I’ll try giving the “delete the connection” thing a go.

I’ll see what I can dig up about the Intel PRO/Wireless 4965 AG or AGN [Kedron] wireless adapter, and the iwlagn driver (AFAIK, I haven’t come across this one before).

Is this a laptop ? … if so can you supply the make/model… as I’d like to know if it’s a “G” or “N” adapter… the name suggests it could be either.

Does your router support Wireless “N” ?

Have you got another wireless adapter you could try ?

Yup it’s a laptop, Acer Aspire 6920, and I think my router is a wireless N combined comblned modem/router.
You’d have to check up on it, it’s Virgin Media’s Super-hub or Netgear CG3101D.

OK the router has dual-band 2.4 and 5ghz a/b/g/n capabilities.

Now a couple of things spring to mind…

  1. The 5Ghz band tends to be faster than the 2.4Ghz band… but your router cannot do both at the same time, so if 1 connected device only supports 2.4Ghz, they will all use 2.4Ghz… that said the card in the Acer is dual-band, so this probably isn’t the issue.

But you could easily rule this out by having both machines connected to the router at the same time, and seeing if it slows the Win7 connection.

  1. 45Mbps seems a reasonable throughput for a wireless G card … see here:
    Virgin Media Super Hub review | Expert Reviews

So I’m going to guess that the Acer has a 54 G adapter, and the Win7 box has a wireless N adapter… but it will remain a guess unless you can specify the exact model of the Acer… Acer Aspire 6920 is a series not a particular model… some of the 6920 series had a/g/n … and others had the slower a/b/g adapters.

See the “Ethernet” section here:

See if you can get the exact model… usually on a sticker underneath.

The model number for the Linux box, (because both win7 & linux boxes are Acer’s), model number is LF1 from the Aspire 6920 series. Just incase you need it, the win7 box is model number, MS2264 from the Aspire 5738Z series.

Quick bump, did you find anything? :slight_smile:

Nope… I can’t seem to find any specs for the LF1 online that state if it supports wireless N

But could it be related to this bug:

you could try it from a 10.10 LiveCD… or try turning off WPA encryption in the router just as a test.

Hmm… perhaps. I’ll maybe give it a go later on :slight_smile:

Right I did some more digging around and opened up my lappy to check the wireless card model. It currently has the “Intel Wireless WiFi Link 4965ANG MM2.”

Now I’ve highlighted MM2 for a reason, that is the specific model of the series, and it is a 802.11a/b/g/n PCIe mini card. So I think it could be a driver issue here. I’ll go check the Win7 box, but I’m positive that’s an a/b/g/n card too, because the series was only launched last year and the laptop isn’t even a year old yet.

Can you send the output from:

ls -a /etc/modprobe.d


dmesg | grep -i iwl


uname -a

. blacklist-framebuffer.conf
… blacklist-modem.conf
alsa-base.conf blacklist-oss.conf
blacklist-ath_pci.conf blacklist-rare-network.conf
blacklist.conf blacklist-watchdog.conf
blacklist-firewire.conf nvidia-graphics-drivers.conf

[ 16.675885] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 16.675889] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[ 16.676017] iwlagn 0000:08:00.0: PCI INT A → GSI 19 (level, low) → IRQ 19
[ 16.676027] iwlagn 0000:08:00.0: setting latency timer to 64
[ 16.676059] iwlagn 0000:08:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[ 16.714561] iwlagn 0000:08:00.0: device EEPROM VER=0x36, CALIB=0x5
[ 16.714564] iwlagn 0000:08:00.0: Device SKU: 0Xb
[ 16.727863] iwlagn 0000:08:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 16.727951] iwlagn 0000:08:00.0: irq 47 for MSI/MSI-X
[ 17.570972] iwlagn 0000:08:00.0: loaded firmware version
[ 17.580701] ieee80211 phy0: Selected rate control algorithm ‘iwl-agn-rs’
[ 68.049501] iwlagn 0000:08:00.0: Aggregation not enabled for tid 0 because load = 5
[ 83.268037] iwlagn 0000:08:00.0: iwlagn_tx_agg_start on ra = a0:21:b7:59:4b:ad tid = 0
[ 108.507625] iwlagn 0000:08:00.0: Aggregation not enabled for tid 6 because load = 0

Linux bally-laptop 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 i686 i386 GNU/Linux

This won’t survive a reboot, but try running these 2 commands… then testing the connection speed:

sudo modprobe -r iwlagn


sudo modprobe iwlagn 11n_disable=0

and let me know if there is a difference.

More (bad?) news on the Intel(R) Wireless WiFi Link 4965AGN to follow :wink:

I got this for the very first test when I was downstairs.

I then did a further 10 tests. 5 of them downstairs beside the router, and 5 in my room.

On average, I get somewhere between 40-44.7Mbps D/L and a stable 9.1Mbps upload. (An improvement for upload.)
Not much of an improvement however, it is now more stable and consistant. In my room I’m still getting around the average, which I wasn’t before, and let me guess the bad news. 11.10 isn’t going to support it :frowning: ?

OK, the “news” I mentioned…

There appear to be MANY issues with the iwlagn driver and Intel’s Linux firmware for the 4965AGN… and Intel appear to have NO intention of fixing the firmware for it… they now consider it a “legacy” product.

Indeed wireless “N” has been disabled (at least it was) in Linux because of stability issues.

There even appear to be stability issues at “G” 54Mbps … Though I read these can be mitigated to a certain extent.




amongst many others.

The first and third links seems to suggest there is a proposed fix at least one of the issues that may or may not have made it into the 2.6.39 kernel

You could try some of the MANY suggested fixes in the last link (and other places on the interweb) to make the “G” connection more stable (if this is an issue), or try the 2.6.39 kernel… but in my opinion, I’d just get another card.

Blame Intel, if you feel the need to blame anyone.

11.10 will use the 2.6.39 kernel by default, so you never know your luck… that patch may have made it into the kernel.


One more to try…

sudo modprobe -r iwlagn


sudo modprobe iwlagn 11n_disable=0 11n_disable50=0 swcrypto=1 swcrypto50=1

Then test… again, this will not survive a reboot, but once you find which options work best, it will be easy to make it permanent.

Options taken from the last posting here:

I’m thinkin’ just to go and get a new card. I’d rather not be messin’ about with all the issues. So since your the brain of brains round here, which card would you suggest I buy, with it being in reasonable price ofcourse but able to handle >100Mbps speeds. (I do plan on upgrading once Virgin decide to bring out they’re 200 & 500Mbps packages.) Something that’ll work straight out of the box.

Check the EDIT to my last respone.