Virgin Superhub and TP Link TL-WA810ND

Just wanted to check the settings for this combination, as you might have guessed I’ve gone out and bought an AP, I just wanted to run a few questions by you in case I need to make amendments -

Just set this up and it’s working, the VM superhub is connected to my desktop, the AP is connected to that via ethernet, seesm to be working as it should and my android’s connected fine just now, I’ll try the laptop in the shed in a minute! So . . . . . .

  1. Do I need to put the superhub into modem mode? Any point in it broadcasting if I’m going to connect to the AP or doesn’t it matter?
  2. The SH is on channel 6, I changed the AP to this as well thinking that was the sensible thing to do?
  3. the ‘Mode’ has options, it’s on 11bgn mixed at the moment, is it better just on ‘n’ ? or no difference?
  4. I changed the band to 5ghz as opposed to 2.4, will this help?
  5. Do I need to enable DHCP on the AP and change some settings, I can’t print from my android now, no route to host ? It’s currently set as disabled.

Footnote: findings from the shed are good, signal as good as I was getting on the laptop downstairs on the SH. :slight_smile:
**better than expected, I get a stronger signal 100ft away at the bottom of the garden than I could get sitting in the kitchen sat underneath the superhub!


says a lot about superhubs that :slight_smile:

Is this TP-Link doodad just a wireless access point … or is it a router/bridge in its own right

Assuming it’s just an access point

  1. NO … the SH will still be doing the LAN routing … but you should turn off it’s wireless.
  2. NO they should NOT be on the same channel … but as you need to turn off wireless on the SH it doesn’t matter
  3. leave it as b/g/n unless you’re 100% sure you’re not going to connect with anything other than wireless n
  4. If that didn’t kill your wireless network for most devices I’m guessing enabling the 5Ghz band does NOT disable 2.4 … more that both are enabled at the same time (as is normal) … you need wireless adapters capable of 5Ghz to make use of it.
  5. I’d say NO … let the superhub take care of all IP assignment

If the TP-Link is a router (which a quick google suggests it’s not) … then non of what I just said applies :slight_smile:


Just read the website here:

and noticed this
Supports multiple operation modes: Access Point, Multi-SSID, Client, Universal/WDS Repeater, Bridge with AP
which mode have you got it set to ?

Thanks Mark, it is an access point, or sold/described as such.

yes . . . . superhub, supercrap more like, my old netgear router was way better as fare as broadcast was concerned, covered my shed no problem in the past.

It’s set to access point, changing to 5ghz has not bothered my laptops or phone, If it’s not a hindrance, I’ll leave as is? Unless there’s an advantage to 2.4ghz.

I’ll turn it on to modem mode then, I thought it seemed a bit daft the two trying to broadcast. . . . . . So none of this will/should affect my wifi printer we did the week before last? If you remember you had me change the DHCP pool for that, just don’t want to inadvertently screw anything up lol : |

I’m sure I’ll let you know if i do though . . . . .:wink:


You DON’T want to set the SH to Modem Mode … as it’s still going to be doing the routing and DHCP … all you want to do is disable the wireless in the SH.

It's set to access point, changing to 5ghz has not bothered my laptops or phone, If it's not a hindrance, I'll leave as is? Unless there's an advantage to 2.4ghz.

I’m willing to bet most if not all your devices are still connecting at 2.4Ghz and aren’t capable of 5Ghz … won’t hurt to leave both bands on though.

I took the time to read . . . so just disabled wireless, not set to modem mode :slight_smile:

Can’t seem to find my printer though ? It’s ok of course via usb but wireless has gone capput, I get nothing trying to log into it on and if I try off the phone I get failed to connect (port 515) EHOSTUNREACH no route to host, off the laptop I just get nothing but it looks as if its gone off to print as normal ?

If you turn off everything … then turn on the SH, then once that’s up turn on the Access point

What IP addresses are handed out to any PC’s on the wireless network ?

My IP’s on other devices all seem to be the same as before . . . . I have on the laptop, 0.12 on the android 0.11 as my desktop address and the TP link is

Have you associated the printer with the new wireless access point and key ?

You might want to turn off the 5Ghz band for now … you know everything works on 2.4Ghz … and I vaguely remember reading 5Ghz can confuse some Epson printers (I could be wrong here … but there’s no reason to complicate things more at this point)

Have you associated the printer with the new wireless access point and key ?

I haven’t done anything specific no, more to the point, I don’t remember trying to log into it before I changed the SH to 5 ghz so I’ll change it back, good enough chance that’s what it is …

Edit: No . . . . . didn’t help, still can’t see/connect to the printer . . .

What I mean is did you (in the printer control panel) associate the Printer with the new wireless access point ?

or is the printer still trying to associate with the SH.

Ah I see, well therein lies the dilemma, I can’t log into it . . . . .

doesn’t it have a control panel on the printer itself ?

I’ve got it . . . . . jesus I’ve got a head like a sieve, I’m putting this one down to a blond day, they weren’t even paired with wps, I’d done everything but . . . . . derp ::slight_smile:

As soon as I read ‘control panel’ . . . . . . .

Thank you :o

We all have our moments, I know I do :slight_smile: