Web browser problems

Dunno if it’s something the wife has done on facebook or not but all this week I’ve been getting these bloody text enhanced advertising on every page I load and shockwave flash keeps crashing (google chrome)
Firefox just says flash player needed (but it’s installed cos it works ok in Google chrome)
Thought I’d try Chromium but flash player won’t work there either. Trying to use speedtest.net I get this message…

Welcome to Speedtest.net! If you are seeing this error message it could be due to one or more of the problems listed below, together with potential solutions.

Be sure to enable JavaScript. Here's how: http://enable-javascript.com/.
Have Flash v.10+? If you do, try uninstalling Flash. Either way, get the latest Flash client here.
Still no luck? Sorry. You can either visit our Support section to troubleshoot further or try our non-JavaScript site. Unfortunately you still need Flash v10+ and there is no guarantee everything will work correctly!
Please visit again when you are able to use Flash (v.10+) and JavaScript but take a moment to learn more about Speedtest.net.

Any help or advice will be greatly appreciated.

Hmm … you’re the second person I’ve come across who’s had flash problems in the last week or so.

are you running 32bit Ubuntu, or 64bit ?

What’s the output from:

uname -a

32 bit as far as I’m aware.

2.6.38-15-generic #64-Ubuntu SMP Fri Jul 6 17:18:17 UTC 2012 i686 i686 i386 GNU/Linux

Happy to continue using G Chrome if I can get rid of this text enhanced advertising.

Can you post the output from this command:

sudo find / -name libflashplayer.so

Be aware, that command may take a minute or two to complete … it’s searching your whole hard drive :slight_smile:


OK, first try this …

Open a terminal, and run:

mkdir ~/.mozilla/plugins

(thiat command may fail if the directory already exists … but just carry on with the next command)

cd ~/.mozilla/plugins


wget http://fpdownload.macromedia.com/get/flashplayer/pdc/


tar -xzvf install_flash_player_11_linux.i386.tar.gz libflashplayer.so

Now close ALL web browsers … and reopen Firefox

Does flash work ?

If not, in Firefox go to Tools>Add-ons>Plugins … you now may see 2 “Shockwave Flash 11.2 r202” listed … can you enable them one at a time then restart firefox to test (ie. test them both, but one at a time) … it’s important that you restart firefox after any changes, to pick up the changes.

fell at the first hurdle there

bash: cd: /home/gill/.mozilla/plugins: No such file or directory

Ooops … first run:

mkdir ~/.mozilla/plugins

THEN do the above.

I’ll edit my last response too.

Yay, Flash now working in FF and chromium.
Guessing we installed the latest version, but why would the old version stop working all of a sudden?
Now don’t misunderstand here, I really appreciate your help so far but simply because it’s annoying me, is there any advice you can offer about the text enhanced ads in google chrome?

I know you’re busy on Pooky’s problem so no rush on this one.

I’m not sure exactly what you mean by “text enhanced adverts” ?

Guessing we installed the latest version, but why would the old version stop working all of a sudden?

Yeh, we installed the latest version … but I have no idea why the system-wide version would stop working … all I can say is someone else seems to have had the same issue on the Peppermint forum.

You could try clearing the chromium browser cookies and cache …

in Chromium, enter this address in the address bar:


and hit enter.

Click the “Clear Browsing Data” button

Set the time frame for deletion to:-

Obliterate the following items from: The beginning of time

and tick these 2 (or 4) boxes:-

Empty the cache
Delete cookies and other site and plug-in data

Clear browsing history <— Optional
Clear download history <— Optional

And click the “Clear Browsing Data” button.

When that finishes … close ALL Chromium instances, and restart it … did that get rid of your problem ?

Done that twice (and again now) but it hasn’t worked.
Text enhanced advertising is randomly highlighted word on any given page and if you hover over them you get a pop up advert.
If necessary can it be purged then re installed to start fresh?

In Chromium, go to:

are there any extensions installed ?

That got it.
Don’t know how it got there but there was one called,
Damn it I forgot already.
Deleted it and the problem is gone.
Thanx very muchly Mark.

As always, you’re welcome :slight_smile: