Wifi adaptor not adapting

I’m trying to learn Linux and have installed it on an old Dell laptop. All OK except for the wifi adaptor.

I got the Peppermint Linux in a disc with Linux User magazine; running the OS from the CD as a trial run the adaptor (a USB TP-LINK plug-in) worked straight off, found the local networks, connected to the router and broadband and ran the internet fine.

So then I installed said Peppermint Linux. The adaptor will now see the available networks but will not attach to my home hub.

Any helpful suggestions, please?

Hello PJ - and welcome to the Forum.

It won’t connect automatically. You will need to select your router from the list then enter all the required info such as the router name (ESSID) and router password, and then authenticate with your computer password. Or did you do all this?


Thanks for the response, Keith. Yes, did all that. Double checked password and everything. What’s throwing me is that it worked perfectly well when the OS ran from disc, but now when installed. Duh!

I’ll boot up a Peppermint 10 disc tomorrow and see if I can reproduce the symptoms.
Meanwhile, Rich et al might have some ideas.


Hi peejay

Have you tried rebooting the hub ?


Re my post #3: I failed to find a computer that I could use to try Peppermint 10 - they were all duff.
Do try Emegra’s suggestion.


It may be that the onboard Dell wireless card is conflicting with the plug-in? And being ‘old’, is unable to handle modern wi-fi… just guessing here… Try disabling wifi on the Dell, then plug in the adaptor and see if it works ok. It’s possible that, when in ‘try-out’ mode on the disc, the onboard card was not activated, thus allowing the plug-in to work. Failing that, you might have to physically disconnect the onboard card to get the plug-in to work - from memory Dell’s are often sited under a plate containing the memory sticks also. Remember to reinstate wifi too. :wink: