WiFi connection not working with peppermint 3 on-Acer Aspire one- AOA150[SOLVED

Hi Please can someone help,
I,m new to the forum also to Linux. I did however read Marks tutorial on installing peppermint 3, Also in doing so I printed off all the info he provided. with the intention of replacing my partners old OS Linpus Linux lite, with peppermint three.(after keenly reading about it)
I followed it best I could step by step everything seemed well. Mark its my own fault :-[, if I,ve inadvertently missed/omitted anything. Well it worked fine until I tried to connect via WiFi. After inputting the encryption password Key, I then receive a message “your Authentication was unsuccessful. Please try again”.?I,ve done this a dozen times and get the same outcome. In saying that I have also tried it Wired and this Works fine. please can you assist as i,m out of my depth at present.
Thank you in advance.

Hi Eddie, and welcome to the forum :slight_smile:

OK, maybe I should have been clearer.

When NetworkManager says System policy prevents modification of network settings … it wants you Linux password.

When it says Authentication required by wireless network it wants your WEP/WPA(2) wireless key.


Hi Mark,
Thank you for your quick response. can you please give me a step by step guide as to how to set up this WiFi, Mark i,m nearly tearing my scalp scratching away. I,m in network connections at the moment, you have Five options along the top(eg) Wired-Wireless-Mobile Broadband-VPN-DSL
Then under that (a box with)–[ +Add ] under that Edit, and Delete. but in the Wireless Tab its empty. should I start over again and re install
Peppermint 3.?

OK, you’re in NetworkManager :slight_smile:

Click the Wireless tab

if there are ANY listed connections … one at a time, click them once to highlight them, then click the “Delete” button … until there are NO connections listed on the Wireless tab.

Close NetworkManager.

Now down by the clock normal (left) click the NetworkManager icon … you should be presented with a list of available networks … click yours.

it may ask for “System policy prevents modification of network settings” … if it does enter your LINUX password

when it asks for “Authentication required by wireless network” … enter your Wireless key.

Hi Mark ,
There is no WiFi connections available, box opens after right clicking showing only: Enable Networking, this is ticked. and on the bottom of the box Edit connections. this has a pencil icon in front.

There is no WiFi connections available

Could you post the result from this (entered in the Terminal) (Ctrl+Alt+T to open a terminal):

lsmod | grep acer_wmi

~ $ 1smod grep acer-vmi
No command ‘1smod’ found, did you mean:
command ‘lsmod’ from package ‘module-init-tools’ (main)
1smod: command not found

This is what was returned, hope this helps.
Regards Eddie.

No command '1smod' found, did you mean: command 'lsmod' from package 'module-init-tools' (main) 1smod: command not found

It might not be obvious but it should read:
lsmod | grep acer_wmi
That is mod <pipe |> grep acer_wmi
This might or might not return anything

OK, let’s do this from scratch.

First I’d like you to shut down your AA1 (Acer Aspire One) … whilst it is switched off, unlpug the power adapter from the AA1 and remove the battery … now whilst it has NO power source attached, hit the ON button as though you want to switch it on (to discharge any remaining power in the motherboards capacitors).

Now replace the battery and power adapter and turn on the AA1

Once booted, see if there are any networks listed by NetworkManager

If not, can you open a terminal and post the output from the following commands … probably best to copy/paste these commands into the terminal and copy/paste what’s returned in the terminal back here.

If the terminal prompts for a password, just type in your password and hit enter … be aware when entering your password nothing will be echoed to screen (not even ******).

And remember (unlike Windows) Linux commands ARE case sensitive … not that you’ll need to worry about thata if you copy/paste the commands :wink:

You can open a terminal with Ctrl+Alt+T

Here’s the commands I’d like the output from:

sudo lshw -C network




iwlist scanning


lsmod | grep acer


lsmod | grep ath


rfkill list

Hi Mark/Sezo,
just an update to inform you everything is well. Peppermint3 is as I type, up and running.Thanks to you both for your patience, also yes i,v been converted to Linux. Can i just add the tutorial Mark wrote is first class, if followed to the letter, including every space required in the commands given will produce a positive result.WiFi works immediately,I don,t know why but i,m happy to get online at last with the Aspire one.
Without the use of another computer I would not have had access to the forum, in saying this I found doing a screen print, from AOA150 to a Windows computer, for the purpose of error finding seemed difficult.never the less managed to get round the problem by doing a complete re install of peppermint 3 via USB and starting completely from scratch following Marks tutorial.(please mark this as Solved)
Regards to both.

Happy to hear a reinstall solved the problem … and thanks for the kind words about the tutorial :slight_smile:

I found doing a screen print, from AOA150 to a Windows computer, for the purpose of error finding seemed difficult.

Do you mean passing the file across the local network ? … if networking (sharing) the AA1 with your Windows machines is the problem we may be able to help.

BTW, if you want to mark this topic SOLVED … please go to the FIRST posting in the topic, click the “Modify” button, and change:

Subject: WiFi connection not working with peppermint 3 on-Acer Aspire one- AOA150 SOLVED

Hi Mark,
yes Mark transferring across the local network,and the like.
If you have a thread or tutorial on such, I would be very interested to learn more.Especially commands,explanation of them and so forth.
Being a windows user most of my computing life has in some respects taken me on a path of being lazy in computing.I,m now beginning to realize there are other way,s of doing things. If that makes any sense.I,m willing to learn and listen,also if necessary take a new approach.
I,m of the frame of mind not to old to learn. :slight_smile:

OK, let’s set up a shared folder in Peppermint that should be accessible from Windows PC’s on the network.

First let’s install system-config-samba … Open a terminal and run:

sudo apt-get install system-config-samba

Now go to your Home directory and (if one doesn’t already exist) create a directory called “Public” … or you can create this directory from the command line with:

mkdir ~/Public

Now got to the menu’s and fire up the Samba configuration application you just installed … you’ll find it at:-

menu>System Tools>Samba

Once that starts, click the Add button (+)

In the next Window click the “Browse” button and browse to the “Public” folder you just created … it will be at:-


edit the other fields so they all read:-

Directory: /home/<your_username>/Public
Share name: Public
Desscription: Peppermint shared folder

now make sure you have ticks in both:-



Now click the “Access” tab … and make sure the:-

Allow access to everyone

box is ticked.

Now click the “OK” button.

OK, you should now be able to see a “Public” folder when you search the network from your Windows PC’s.

(you may need to reboot both the Peppermint and Windows PC’s first)

OK … the other way round … accessing the Windows shares from the Peppermint PC.

First you’ll need to install smbclient:

sudo apt-get install smbclient

If you cannot now access the Windows shared folders by opening the File Manager, then going to Go>Network Drives and browsing the network, let us know which version(s) of Windows you’re using, and/or any error messages you reciev whilst trying to access them.

thanks for pointing me here to help resolve my linux / winxp / win7 networking issues Mark… i’ve got more of the computers on speaking terms than i have in a long while… life is good… and you are defintely da Man! :wink:

No problem :slight_smile: