Wifi firmware problem


I have peppermint 3 on my dual boot (XP) Compaq V5000 (V5214ea to be precise) .

The WiFi applet indicates it is not working due to firmware problems. It’s never worked. I rarely use this laptop but I am trying to get some more use out of it. It is old but hardly used. Before I have just used my Mobile phone acting as a router linked up by cable to it.

Directions to upgrade the firmware would appreciated. :slight_smile:

If this should be in another category please feel free to move it. :slight_smile:

I was also wondering…should we not have a Mint/Peppermint category? As a lot of questions are about that distro’.

Can you post the output from:



lspci | grep -i net

Sorry for the delay.

First one

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 04e8:6864 Samsung Electronics Co., Ltd

Second one

06:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
08:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 01)


Can you also post the output from:

sudo lshw -C network


lspci -vnn | grep -i net


description: Network controller
product: BCM4311 802.11b/g WLAN
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:06:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:18 memory:40000000-40003fff
description: Ethernet interface
product: PRO/100 VE Network Connection
vendor: Intel Corporation
physical id: 8
bus info: pci@0000:08:08.0
logical name: eth0
version: 01
serial: 00:16:d4:36:67:4e
size: 10Mbit/s
capacity: 100Mbit/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=half firmware=N/A latency=66 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=10Mbit/s
resources: irq:20 memory:d0100000-d0100fff ioport:2000(size=64)
description: Ethernet interface
physical id: 1
logical name: usb0
serial: 02:00:61:37:62:30
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip= link=yes multicast=yes
*-network:1 DISABLED
description: Wireless interface
physical id: 2
logical name: wlan0
serial: 00:14:a5:b7:88:0f
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=3.2.0-23-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
a@a-Presario-V5000-RE308EA-ABU ~ $


06:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
08:08.0 Ethernet controller [0200]: Intel Corporation PRO/100 VE Network Connection [8086:1092] (rev 01)


Can you connect to a router with an ethernet cable so you have an active internet connection ?

Hi mark

yes, as I said in the opening paragraph I use a my mobile (by cable). I do not have a normal wired broadband connection.

OK first let’s try the reinstalling the firmware, and if that doesn’t work try the wl drivers … and if that doesn’t work you’ll have to describe the connection and issue a little better :slight_smile:

Whilst connected to the interweb, run:

sudo apt-get install --reinstall build-essential linux-headers-generic dkms bcmwl-kernel-source linux-firmware firmware-b43-installer

Now check if your wireless works the way you expect it to

If not, try unloading the b43 driver, and loading the wl driver (your card is supposed to be supported by both drivers)

sudo modprobe -r b43


sudo modprobe wl

Be aware - swapping the drivers will NOT survive a reboot and will need to be re-applied, but if it works we can make it permanent.

OK. Tried all of the above without any difference. I booted into XP and noticed that the button that turns WiFi on and off was blue (on).

Re-booting into Peppermint showed that the Button was not blue (on) but unlit. Pressing the WiFi on off button mad no difference. So, it may be that Peppermint cannot recognize the on/off button and that the drivers are OK really.

What do you think?


This may a resurrection too far anyway. I am finding it impossible to install software via software manager. The mouse jumps around the screen randomly. When I’m typing text it goes all over the place missing spaces and inserting text randomly. I have had to edit this post 5 times but…it doesn’t do this in XP?!

Odd, you’re the second person that seems to be having the skipping around cursor in Peppermint 3 (on this forum), yet nobody has reported it on the Peppermint forum ??

Can you post the output from:

rfkill list

and the make/model of your laptop

to kill the touchpad whilst typing … run:

syndaemon -i 1 &

This should kill the touchpad whilst you type with a 1 second delay between the last keystroke and the touchpad becoming active again.

Does that help ?

it won’t survive a reboot … but if it helps, we can automate it to run at bootup.

here we go

0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes

Is there a hardware switch, or a key combo, or a BIOS entry for turning wireless ON/OFF ?

What happens if you run:

rfkill unblock all

There is a button that when pressed should light up blue.
I have tried live Peppermint 4 cd and Ubuntu 13.04…nothing.


Can’t open RFKILL control device: Permission denied

The “firmware” message you refer to in your original posting … where is that coming from, and what’s the exact wording ?

Did wireless used to work ?

have you tried booting an earlier kernel ?

Have you tried reinstalling linux-firmware:

sudo apt-get install --reinstall linux-firmware

The ‘Firmware’ notice was displayed by hovering the mouse pointer over the connections applet.

The WiFi has never worked and TBH is now becoming a secondary issue behind the keyboard and mouse problems.

It seems that the WiFi button is behind the fact that I cannot make the hardware active by pressing the WiFi button. A reboot into XP shows the button to be active at startup and can be pressed off.


E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

Which I did and nothing has changed.

On another note I am wondering if there is damage to the keyboard mouse pad. Plugging in a USB mouse and keyboared has just as good as confirmed it.
Don’t bust yourself over the WiFi Mark as at least tether it.

On the plus side…seeing how much trouble I have had recently trying to keep knackered old laptops survive my Wife has decided I can spend some of MY own money and get a new one! Jeez! Thanks love, as I looked at her iPad brick with D&G cover that can do virtually FA.

I will use this laptop as a workstation with USB mouse and keyboard.


Okey Dokey … have you tried a Peppermint 4 LiveUSB … maybe the later kernel would help … if it does, we can either update the Peppermint 3 kernel, or just install Peppermint 4.

Just a though :slight_smile:

The bios doesn’t support usb booting so I tried Peppermint 4 and Ubuntu on live cd, still no change.

Thanks for trying. There will have been a good reason why this old Compaq was replaced by me and has sat in the cupboard and it probably was a damaged keyboard mouse…can’t remember.

Now to look for a low cost laptop 14"-15" not to big. Didn’t like what I saw in PC World might give Dell a go.

What do you think of this? http://www.ebuyer.com/519940-asus-x401a-laptop-x401a-wx453h

As it is built for Win8, just make sure you can switch off secure boot…

Thanks Sezo

How will I Know?

Looks like it’s possible: