YouTube induce a kernel panic [Solved]

Yeah it sounds stupid, but YouTube froze up my whole system when my brother put a video into fullscreen which caused the Nvidia drivers to force closed which resulted in a kernel panic.

I was able to reboot by hard shutdown only, but I did try Alt Gr+Sys+REISUB first nothing was responding though.

Once rebooted, the nvidia drivers wouldn’t boot up. I tried forcing them too by doing:

sudo nvidia-xconfig
sudo restart lightdm

But to no avail. I’ve checked the logs, but cant find nothing. Help?

Have you tried renaming xorg.conf … then booting … then reinstalling the nvidia drivers ?

Yep, tried renaming the xconfig. Haven’t tried reinstalling the drivers though because I can’t remember if I added the Nvidia repository or it was just the ones from the additional drivers menu.

This should display your sources.list, and any active PPA’s:

cat /etc/apt/sources.list; for X in /etc/apt/sources.list.d/*.list; do echo; echo; echo "** $X:"; echo; cat $X; done

beyond that, you’d have to run:

dpkg -l | grep nvidia

and check the versions against the repos.

Ok, so somehow inbetween all the madness the nvidia-drivers have uninstalled themselves. So I installed the available 310.xx drivers in the ubuntu repos.

Restarted X-server, nothing. Says Im not using the nvidia-drivers, so ti double check I did a full system reboot. Then I hit another snag, my laptop wont load past grun after choosing Ubuntu to boot nor will it boot into failsafe mode.

So currently Im at the kernel recovery menu. Waiting for further instructions.

You know the routine :wink: … if you remove quiet splash from the kernel boot line … are there any clues ?

So you cannot even get to a command prompt ?

Even if I remove quite splash, it just freezes as soon as I boot Ubuntu.

I’ve been able to drop to a root shell, and I tried to force fsck, but it froze when checking /dev/sda5.

I’ve left it for about 2 hours now, it ain’t budged.

Boot to a LiveCD/LiveUSB … then check the SMART data for that drive in Disk Utility … try running fsck on /dev/sda5 from the Live environment (make sure it’s not mounted first.

is /dev/sda5 where Linux is installed ?

Coolbeans, and I cant remember. Pretty sure its the root partition.

Ok been avoiding Linux for a few days. Been busy backing up some files in Windows, so an update:

I’ve tried to boot multiple liveCD/DVDs and my laptop wont boot it. Haven’t tried a LiveUSB because I ain’t got a USB stick, however, its probably best I go get one. So thats what I’ll do on Tuesday because thats payday.

All I can do for now I use the Win8 CP partition, which I’ll be replacing with W7.

Unless someone knows a command that can uninstall the Nvidia drivers from the Ubuntu repos? As I can drop to a root console.

Why not try the ones from x-updates

sudo apt-get remove --purge nvidia-*
sudoa apt-get install ppa-purge
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

I personally think my Ubuntu partition is fecked. Root won’t do the first command, as it’s says:

W: Not using locking for read only lock file /var/lib/dpkg/lock E: Unable to write to /var/cache/apt/ E: The package lists or status file could not be parsed or opened.

Seems your filesystem is being mounted read-only (probably because of errors) … you really need to run fsck.

If you cannot boot to a LiveCD (I think you said that somewhere) … try this:

sudo mount -n -o remount,rw /

to remount the partition read/write
then run:

sudo touch /forcefsck

and reboot.

Ok, it did a filesystem check, but it still won’t boot or remove the Nvidia drivers.

Is it still booting read-only ?

Did it check all file systems or skipped any?
Does the line for your disk in /etc/fstab end with “0 0” or is missing the final column?
If the 6th column is missing or 0, the startup scripts should skip that device when doing an fsck at start-up.

Also, did you try to modify your kernel line at boot up with nomodeset?
On the grub menu, just add the ‘nomodeset’ option when booting
(choose ubuntu from grub, hit ‘e’ and add ‘nomodeset’ option and press ‘ctrl+x’),
and hopefully you can boot into Ubuntu.

Must be, because I got the same errors again.

I couldn’t tell you if it has “0 0” at the end, but it didnt skip any filesystems.

I’ll give that a go SeZo.:slight_smile:

When using the ‘nomodeset’ kernel line, it’ll boot passed the ubuntu logo, then drop to a command line, then it comes up with an error message.

end request: critical target error, dev sdb, sector 0 end request: critical target error, dev sdb, sector 4096 end request: critical target error, dev sdb, sector 50 end request: critical target error, dev sdb, sector 24 usb 5-2: device descriptor read/64, error -71 hub 5-0: 1.0: unable to enumerate USB device on port 2 hub 2-0: 1.0: over-current condition on port 3 hub 6-0: 1.0: over-current condition on port1port

EDIT: I’ve managed to drop to the console by pressing CTRL+F3. I’ve also been able to remove the nvidia drivers, and install the PPA Mark provided earlier, Let’s hope I’m getting somewhere.


It’s working again… thank god.