"Cannot write bytes: Broken pipe" Error [Solved]

Hi there,

I recently installed Ubunut 12.04 LTS alongside my Windows 7(dual partition). Everything was working fine for the last few days. Today however, I tried to get my graphic tablet(Huion P608N) working on Ubuntu and I was following some wiki guides about installing the driver for it, installing wizardpen, wine, etc.

After I finished all that, I rebooted to see if the tablet was working. From the boot screen, I chose the regular boot option for Ubuntu. Then i get a black screen with a few lines of code, followed by the purple Ubuntu screen, and finally a black screen that says “Cannot write to bytes: Broken pipe.”

I’ve googled around, and tried a few things since this doesn’t seem to be a very rare problem, but to no avail.

Also, I am encountering the exact problem that this person faced: 12.04 - Cannot write bytes: Broken pipe - Ask Ubuntu.

Any help would be appreciated.

you mean you’re getting the gedit error ?

You can’t run gedit in a console.

Can you post a link to the instructions you were following ?

And (because of that link) did you also install some graphics drivers … or reboot whilst something was installing ?

I’m not sure what you mean by gedit error? I cannot log in to the computer, in fact, right when the login screen should appear, I get the “Could not write bytes: broken pipes” screen.

This is the driver I installed for the tablet:

and GitHub - DIGImend/uclogic-tools: UC-Logic graphics tablet diagnostic tools

These are the instructions for installing the wizardpen(actually it was a different website- a wikia- but I cannot seem to find it since I can’t access the browser history on Ubuntu, they are very similar instructions though):

I did update libusb to the most recent version.

When you get that error, are you able to drop to a console (text command line prompt) by hitting


then log in ?

From that error screen, I can’t get into anything. I can only turn of the machine from pressing the power button.

However, if I spam Ctrl+Alt+F1 before it appears I can get to a terminal and log in.

Can you navigate (change directory) to the source directories of those 2 apps you installed and run:

sudo make remove

from each ?

They are all on my Desktop currently. Should I cd into the file and then do sudo make remove?

I am asking just because they are folders with multiple files/folders in them.

cd(ing) into the directory that contains the make file, then running:

sudo make remove

should uninstall the app

So you need to be in the same directory you were in when you ran “make install” … if you get my meaning.

Had you created an xorg.conf file whilst trying to get the tablet to work ?
(or even better had you backed up xorg.conf at some point ?)

If so, have you tried renaming it and seeing if you can boot ?

Ok, for the wizardpen one, I navigated to the “src” directory which contains Makefile.am, Makefile.in, wizardpen.c, wizardpen.h

But running sudo make remove gives me the following error:

(I also tried this in the main folder which also contains the same Makefile.am and Makefile.in, but also got the same error)

make: ***No rule to make target ‘remove’. Stop.

And no, I am not sure about the xorg.conf file. I will try to find it and rename it to see if that will help.

Try this:

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.old


sudo mv -v ~/.Xauthority ~/.Xauthority.old


sudo service lightdm start


sudo service lightdm restart

did Ubuntu start … or were there any errors from that last command.

After running the first command I am getting an error:

mv: cannot stat ‘etc/X11/xorg/conf’ : no such file or directory

Perhaps, I am running the command in the wrong place? I ran it in the wizardpen folder and in the home directory to be check. Received same error on both tries.

Just checked the /etc/X11 folder… Found xorg.conf.d and xorg.conf.failsafe but did not see xorg.conf

After trying the lightdm restart command, it went straight to the could not write bytes: broken pipe screen

OK, you’re going to need to look through the Xorg logs for clues/errors.

This would be easier done from a LiveCD or LiveUSB, have you got one handy

The logs are located at:
and will be called

Might also want to look in

I’m off to bed now, but will be online tomorrow.

I have a live CD that I can boot from, yes.

Okay, I will check those directories.

Thank you very much for all your help tonight, goodnight.

Thank me if we solve it tomorrow :slight_smile:


So, I booted from a live cd and found ‘Xorg.0.log’ and ‘Xorg.0.log.old’
I cannot open Xorg.0.log.old though.

What sort of thing should I be looking for in the Xorg.0.log file?

First of all, are you looking on the hard drive and not the live session ?

From the liveCD, open the file manager and click (in the left hand panel) on the hard drive

Then open a terminal and post the output from:

mount | grep media

Have you got tthe Live session internet enabled … either connected wirelessly or with an ethernet cable ?